LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2008, 01:03 PM   #1
anotherpenguin
Member
 
Registered: Nov 2008
Posts: 44

Rep: Reputation: 15
lilo won't load windows FAT partions not recognized


I was finally able to install my slackware distro.
while lilo loads my linux fine it can't do same for my windows.
which is installed on sda1 and linux on hda1.
linux reads the fat partition on hda1 fine, but seems unable to recognize sda.
I'm new to linux so please be specific with your instructions
 
Old 11-14-2008, 01:30 PM   #2
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Could you please post your "/etc/lilo.conf" file? That might help in us getting down to the bottom of things.
 
Old 11-14-2008, 02:15 PM   #3
anotherpenguin
Member
 
Registered: Nov 2008
Posts: 44

Original Poster
Rep: Reputation: 15
ok i think i got it figured out, correct me if I'm wrong.
i put all my Fat partions in /windows directory during setup.
so as linux loads them up only the last one gets displayed.
can some one tell how to fix that.
 
Old 11-14-2008, 02:43 PM   #4
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Please post your /etc/lilo.conf file - as that is probably where the issue exists.
 
Old 11-14-2008, 06:43 PM   #5
JosipBroz
Member
 
Registered: Nov 2008
Location: Ljubljana
Distribution: OpenSuSE
Posts: 56

Rep: Reputation: 18
Talking

You're right, it's not wise to mount all your fat partitions in one slim directory. To correct this, create additional directories in the same location where your "/windows" directory is (apparently it's in /), giving them sensible names. Then (as root) edit your fstab accordingly. If you created them in the same location, you'll just have to copy the windows line in fstab and paste it (once for each of your fat partitions), making sure to replace "windows" with the appropriate directory name(s). You then execute mount -a (as root, IIRC) and you should be OK.

Last edited by JosipBroz; 11-14-2008 at 06:44 PM.
 
Old 11-15-2008, 08:16 AM   #6
anotherpenguin
Member
 
Registered: Nov 2008
Posts: 44

Original Poster
Rep: Reputation: 15
ok here is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact # faster, but won't work on all systems.
prompt
#timeout = 300
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
read-only # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/sda
# Windows bootable partition config ends



it seems ok as my windows is on sda1
 
Old 11-15-2008, 08:18 AM   #7
anotherpenguin
Member
 
Registered: Nov 2008
Posts: 44

Original Poster
Rep: Reputation: 15
was able to rectify fat partition problems on my own
i just wish slackware would boot up my XP
 
Old 11-15-2008, 11:55 PM   #8
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Change where it says "table" to "other". So, instead of this for your Windows boot declaration:
Code:
label = Windows
table = /dev/sda
you will have this:
Code:
label = Windows
other = /dev/sda
 
Old 11-16-2008, 04:38 AM   #9
anotherpenguin
Member
 
Registered: Nov 2008
Posts: 44

Original Poster
Rep: Reputation: 15
fixed, thanks everyone
 
Old 11-16-2008, 10:40 AM   #10
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
You're very welcome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot access Windows partions in Suse 10.1 santhoshunnikrishnan Linux - Newbie 1 04-02-2008 06:44 AM
windows wont load from lilo (did before) petezilla Linux - Newbie 7 01-06-2006 02:24 AM
FC 2: Automounting Windows partions (fstab) shelldinesh Linux - General 1 10-19-2005 05:53 PM
Read/write to windows partions from RH9 scm86 Linux - Newbie 0 01-05-2004 05:42 PM
Viewing Windows Partions PlatinumRik Linux - Software 4 10-19-2003 03:50 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration