LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2007, 09:03 AM   #1
dbough
LQ Newbie
 
Registered: Sep 2006
Distribution: Various - getting my feet wet!
Posts: 19

Rep: Reputation: 0
Lilo + Windows XP / Slackware


Once again I am having issues getting a bootloader to work with Windows XP and Linux ... I'm beginning to feel like this is an ID10T error ... quite frustrating.

I've installed Slackware 11 now (a distro I am semi-familiar with - I've used 10.2 in the past w/o issues.)

Setup:

hda = DVD Burner (or so I think, I can't seem to locate it through slackware.)

hdb = Slackware
hdb1 = /
hdb2 = extended
hdb5 = swap
hdb6 = /usr
hdb7 = /opt
hdb8 = /home

sda1 = Windows XP (/WindowsXP)
sda2 = small partition on XP drive (/XPExtra)
sdb = Storage (/storage)

While installing Slackware I told lilo to install in the root directory of the linux drive. I then copied the boot sector of the linux drive to /bootsect.lnx. I then copied bootsect.lnx to sda1 (which is mounted as /WindowsXP.) I went into Windows and changed the boot.ini to included c:\bootsect.lnx="Linux."

When my boot menu comes up and I select 'Linux' it flashes quickly and goes right back to the choices.

Ok, I was a little confused but not put off. I decided to throw caution to the wind and install lilo on the MBR of sda1. It didn't allow me to choose where to through LILO - I assume it went to hdb1 (which is not what I wanted.) When doing this it gave me an error of "Sorry but the attempt to install LILO has returned an error, so LILO has not been correctly installed..."

Ok, fine. Well, as a last resort I thought I might try to throw LILO on a pen drive and only use it when I wanted to boot to linux (I don't have a floppy drive.) Apparently thats not an option (or I just can't figure out how to do it.)

So now I am at a loss. Are there any suggestions that could be offered? My lilo.conf is listed below:

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/hdb
message = /boot/boot_message.txt
#prompt
#timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdb1
label = Linux
read-only
# Linux bootable partition config ends
Thanks!!

DB

Last edited by dbough; 04-24-2007 at 10:27 AM.
 
Old 04-24-2007, 11:06 AM   #2
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 977

Rep: Reputation: 36
/dev/hda = primary master
/dev/hdb = primary slave
/dev/hdc = secondary master
/dev/hdd = secondary slave

as far as lilo is concerned add this:

other = /dev/sda1
label = Windows
table = /dev/sda

that should boot windows...
 
Old 04-24-2007, 04:31 PM   #3
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 37
slackware install says that installing lilo on MBR is not recommended
so why not just install it to hdb1 and give hdb disk the boot flag?
 
Old 04-24-2007, 07:43 PM   #4
dbough
LQ Newbie
 
Registered: Sep 2006
Distribution: Various - getting my feet wet!
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Tux-Slack
slackware install says that installing lilo on MBR is not recommended
so why not just install it to hdb1 and give hdb disk the boot flag?
Are you recommending taking away sda1's boot flag?

I did add the boot flag to hdb1 (it is also on sda1.) Would this cause conflict? When I did this I'm getting issues as stated in the OP

Quote:
While installing Slackware I told lilo to install in the root directory of the linux drive. I then copied the boot sector of the linux drive to /bootsect.lnx. I then copied bootsect.lnx to sda1 (which is mounted as /WindowsXP.) I went into Windows and changed the boot.ini to included c:\bootsect.lnx="Linux."

When my boot menu comes up and I select 'Linux' it flashes quickly and goes right back to the choices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo + Windows XP / Slackware dbough Linux - Newbie 0 04-24-2007 09:01 AM
lilo ntldr missing after running lilo after slackware install SeriousArnoud Slackware 1 08-16-2005 10:07 AM
Windows XP / Slackware LILO boot problem. Clumsy Slackware 3 03-26-2005 07:04 PM
Slackware 10 in "Lilo vs Windows 98 SE" el_vits Linux - Hardware 2 11-28-2004 08:27 AM
I install Slackware on small HDD with LILO, can't boot LILO? kleptophobiac Slackware 4 08-10-2003 05:50 PM


All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration