LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-02-2005, 12:59 PM   #1
jam5173
LQ Newbie
 
Registered: Dec 2005
Location: Houston, Texas
Distribution: Fedora 7
Posts: 4

Rep: Reputation: 0
LILO Update After Upgrade-How?


Patience: This is my first post.

I wanted to learn more about Linux so I installed SuSE 9 Professional behind my WinXP. Once I finally configured it to see my DSL modem, I began the update.

I updated my SuSE 9. However, the update said I needed to update my LILO before rebooting.
My book (I know RTFM) says "This is easily done by launching the map installer as root:
/sbin/lilo

I've tried executing that command (/sbin/lilo) at the root level (I think) through the Shell Konsole, but it says:

linux:~ # root: /sbin/lilo
bash: root:: command not found

I can't figure out how to update the LILO boot loader. Any help would be appreciated.

I didn't realize Linux would be so much fun. Thanks,

Jim
 
Old 12-02-2005, 01:07 PM   #2
Keruskerfuerst
Member
 
Registered: Oct 2005
Location: Lat: 482356N, Lon: 104145E
Distribution: Gentoo 2006
Posts: 719

Rep: Reputation: 31
It works as follows:
as root:

#cd /sbin
#lilo

These commands reinstall lilo.
 
Old 12-02-2005, 06:01 PM   #3
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 530

Rep: Reputation: 30
Are you sure you've lilo installed ?
Usually standard Suse installation set up grub as bootloader.
If connected as normal user try to "su" this way
su -
password ........
in order you "sued" in the right environment
then
which lilo
should output the path if lilo is installed
Ciao
 
Old 12-03-2005, 01:43 AM   #4
jam5173
LQ Newbie
 
Registered: Dec 2005
Location: Houston, Texas
Distribution: Fedora 7
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the help.
It appears that I am using GRUB instead of LILO, thus didn't need to update LILO. Thanks for that little tidbit. I alway noticed GRUB run at boot.

It was a relief to see Linux come back up after boot. I really appreciate the help.

Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
run /sbin/lilo after update IF you use LILO (don't know) jdblick Suse/Novell 3 12-28-2004 03:06 PM
When Do You Update Lilo? Lucinda Slackware 4 05-26-2004 08:21 AM
lilo reinstall or update help gavinbeatty Linux - Newbie 2 03-18-2004 04:00 PM
lilo update jaz9090 Slackware 2 01-26-2004 02:40 PM
How do I update Lilo ? DavidTempler Mandriva 2 10-23-2003 06:01 AM


All times are GMT -5. The time now is 03:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration