LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2005, 09:15 AM   #1
rinku
LQ Newbie
 
Registered: Mar 2005
Location: india
Posts: 18

Rep: Reputation: 0
Lightbulb LILO problem


hello all

i have installed the linux(redhat release 9).whenever i install
the windows after installing the linux the LILO automatically
removes and only the windows option appears for booting.

so how i recovers LILO tell me exact steps of recovery

and also give me steps of dual booting. How to dual boot with lilo?

i am very very thankful to you intelligent guy.

my linux is on /dev/hda5
 
Old 03-07-2005, 11:29 AM   #2
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
install windows first then linux or you could install lilo to your distros root partition and use a boot disk or you could use ntldr to boot linux. Lots of options do your research google works wonders.
 
Old 03-08-2005, 04:11 AM   #3
rinku
LQ Newbie
 
Registered: Mar 2005
Location: india
Posts: 18

Original Poster
Rep: Reputation: 0
lilo

hello all

i have installed the linux(redhat release 9).whenever i install
the windows after installing the linux the LILO automatically
removes and only the windows option appears for booting.

so how i recovers LILO tell me exact steps of recovery

and also give me steps of dual booting. How to dual boot with lilo?

i am very very thankful to you intelligent guy.

my linux is on /dev/hda5
 
Old 03-08-2005, 09:50 AM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
Thats why you install windows first. if you install linux first then windows it over writes the mbr. did you make a boot disk when you installed linux. if you dont have a bootdisk.

boot your first install cd.

type linux rescue at the boot prompt

it will scan for your redhat partition select it

it will mount your redhat partition in /mnt/sysimage

chroot /mnt/sysimage

doen't redhat install grub by default


/sbin/lilo if lilo does work than
grub-install /dev/hda

ctrl+d

reboot besure to remove cd

post back if it worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo Problem $@ya Linux - General 2 07-21-2005 02:28 PM
Lilo vs Grub - PROBLEM with lilo nelsonnery Linux - Software 2 09-09-2004 12:09 PM
LiLo Installation problem ?and (GNOME and KDE problem) hitesh_linux Linux - Software 1 01-01-2002 05:56 AM
LILO problem amam Linux - Newbie 5 07-16-2001 12:06 AM
Problem with Lilo not updating (yes I ran lilo after changing the conf) webguy Linux - General 2 06-24-2001 08:12 PM


All times are GMT -5. The time now is 12:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration