LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2004, 04:13 PM   #1
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 188

Rep: Reputation: 16
LILO on root hdb, is this possible?


previously i put lilo on the MBR, which works fine except i would like to keep my win & linux hard disks totally separate, so i could take out linux hdb and windows would still boot.

what i am now doing is telling lilo to go onto the root part of hdb, and it automatically puts the boot DOS option in it too. (slack 9.1, choose Simple lilo config, then ROOT (not floppy or MBR)).

it loads linux fine, so long as i get the bios to boot from IDE1, but windows doesnt load when i choose it. it just says 'loading windows' and then stares at me as if im a newbie... the cheek.

when i set the bios to boot IDE0, it loads windows fine (no LILO), which is what i want.

i'd like to be able to set the bios to load IDE1, then LILO, but for the windows option to work. is this possible or has it already gone past the stage of booting windows if lilo boots from root on hdb?

hey, im using slackware, i want it to work MY way!

Last edited by Mr Marmmalade; 05-11-2004 at 04:14 PM.
 
Old 05-11-2004, 04:22 PM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
yeah you can do that...

i have the windows bootloader installed on the MBR of hda which boots windows
and i have grub installed on the MBR of hdb which boots linux.

i use boot options in bios (F8) to select what to boot,
and i can remove any hard disk, stick it in anouther machine, and each disk is un-effected by the loss of its friend.
 
Old 05-11-2004, 08:19 PM   #3
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try this in your lilo.conf for the section to load Windows:
Code:
other=/dev/hda1
label=windows
boot-as=0x80
change /dev/hda1 to whereever your windows partition is.
 
Old 05-12-2004, 02:33 PM   #4
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Slackware + Debian
Posts: 188

Original Poster
Rep: Reputation: 16
brilliant! it worked, just added "boot-as=0x80" into lilo.conf and it worked. thanks!



i searched up on the 'boot-as' option and the 'googled' lilo how-to i found mentioned putting "bios=0x80". but 'boot-as' worked fine.
 
Old 05-12-2004, 09:53 PM   #5
hooya27
Member
 
Registered: Aug 2003
Location: In a van down by the river
Distribution: Mandrake
Posts: 48

Rep: Reputation: 15
Alrighty,

I've got a harddrive from another machine, with windows on it. I just put it on the secondary of my Promise UltraATA/66 card, and can get to it from linux as /dev/hde1. My primary carries my linux drive, as /dev/hdc, with various partitions mounted as /, /home,/var, and such.

I want to modify lilo.conf to let me boot (or see if it is bootable) my windows hd from the other machine. I've tried the "boot-as=0x80" and lilo chokes, saying something about unrecognized tokens at or near line ##. Here is my lilo.conf:

[root@localhost dan]# cat /etc/lilo.conf
boot=/dev/hdc
map=/boot/map
vga=normal
default="mdk9.1"
keytable=/boot/us.klt
prompt
nowarn
timeout=300
message=/boot/message
menu-scheme=wb:bw:wb:bw

image=/boot/vmlinuz-2.4.21-0.13mdk
label="mdk9.1"
root=/dev/hdc1
initrd=/boot/initrd-2.4.21-0.13mdk.img
append="quiet devfs=mount hda=ide-scsi acpi=off"
vga=792
read-only

image=/boot/vmlinuz-2.4.21-0.13mdk
label="linux-nonfb"
root=/dev/hdc1
initrd=/boot/initrd-2.4.21-0.13mdk.img
append="devfs=mount hda=ide-scsi acpi=off"
read-only

image=/boot/vmlinuz-2.4.21-0.13mdk
label="failsafe"
root=/dev/hdc1
initrd=/boot/initrd-2.4.21-0.13mdk.img
append="failsafe devfs=nomount hda=ide-scsi acpi=off"
read-only

other=/dev/hde1
label="windows"

Now, like mrmarmmalade above, I get the "loading windows" thing, and nothing else. Here is what lilo says about the 0x80 thing in the windows stanza:

Unrecognized token "boot-as" at or above line 45 in file '/etc/lilo.conf'

If I try the "bios=0x80" lilo says there is a syntax error.

Any help would be keen.

Thanks,

Dan
 
Old 05-13-2004, 04:36 AM   #6
sbogus
Member
 
Registered: May 2004
Location: Germany, Munich
Distribution: SuSE Pro Releases 7.3, 9.0, CentOS 4.0, Kubuntu 6.0x
Posts: 103

Rep: Reputation: 15
qwijibow:

Quote:
Originally posted by qwijibow
yeah you can do that...

i have the windows bootloader installed on the MBR of hda which boots windows
and i have grub installed on the MBR of hdb which boots linux.

i use boot options in bios (F8) to select what to boot,
and i can remove any hard disk, stick it in anouther machine, and each disk is un-effected by the loss of its friend.
Hi,
excuse me for the newbie-question, but how did you configure the GRUB loader (or probably it should be the LILO one?) in order to be able to boot from hdb without hda?!
I'm trying just the same thing with my SuSE 9.0 but it doesn't work. I have to put the bootloader (LILO or GRUB) into the MBR of hda in order to be able to boot the instalation on hdb.

When I put GRUB on MBR on the hdb disk, then it says just "GRUB " and freezes on the screen, if I use LILO instead then the LILO prints one screen with "99"s and freezes too. Puting the bootloader in the /boot section of the the /root partition on hdb causes the BIOS not to recognize this disk as bootable and to proceed directly to the next boot disk (I use BIOS to switch the boot drives sequence to: 1st = HDD-1, wich is hdb, then 2nd = CDROM, 3rd = Floppy).
My SuSE 9.0 installation on hdb has only two primary partitions on hdb, hdb1 is the swap (1GB) and the hdb2 is the native Linux partition (40 GB), both have as file system the reiserfs.

Many thanks in advance.

Kind regards,
sbogus
 
Old 05-13-2004, 05:40 AM   #7
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Quote:

Now, like mrmarmmalade above, I get the "loading windows" thing, and nothing else. Here is what lilo says about the 0x80 thing in the windows stanza:

Unrecognized token "boot-as" at or above line 45 in file '/etc/lilo.conf'

If I try the "bios=0x80" lilo says there is a syntax error.

Any help would be keen.

Thanks,

Dan

the config looks alright to me, maybe your version of lilo is too old, IIRC the "boot-as" directive is not supported in versions below 22.5.5.
assuming you only have 2 harddrives, try this one:
Code:
other=/dev/hde1
label="windows"
map-drive=0x80 to=0x81
map-drive=0x81 to=0x80

Quote:

Hi,
excuse me for the newbie-question, but how did you configure the GRUB loader (or probably it should be the LILO one?) in order to be able to boot from hdb without hda?!
I'm trying just the same thing with my SuSE 9.0 but it doesn't work. I have to put the bootloader (LILO or GRUB) into the MBR of hda in order to be able to boot the instalation on hdb.

When I put GRUB on MBR on the hdb disk, then it says just "GRUB " and freezes on the screen, if I use LILO instead then the LILO prints one screen with "99"s and freezes too. Puting the bootloader in the /boot section of the the /root partition on hdb causes the BIOS not to recognize this disk as bootable and to proceed directly to the next boot disk (I use BIOS to switch the boot drives sequence to: 1st = HDD-1, wich is hdb, then 2nd = CDROM, 3rd = Floppy).
My SuSE 9.0 installation on hdb has only two primary partitions on hdb, hdb1 is the swap (1GB) and the hdb2 is the native Linux partition (40 GB), both have as file system the reiserfs.

Many thanks in advance.

Kind regards,
sbogus

Try installing GRUB manually using the GRUB shell, first create a /boot/grub/device.map file if it doesn't exist and make sure it has the following content:
Code:
(hd0)    /dev/hdb
(hd1)    /dev/hda
invoke the grub shell by running
Code:
 
/sbin/grub --device-map=/boot/grub/device.map
then
Code:
grub> root (hd0,1)
grub> setup (hd0)
and see if it helps.

Last edited by Demonbane; 05-13-2004 at 05:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root disk with LILO sheky Slackware 1 11-10-2005 04:44 AM
/dev/hda under lilo.conf even thoug my HD is under /dev/hdb Basel Slackware 8 10-27-2005 07:00 PM
lilo in root partition subh Linux - General 4 12-18-2003 02:46 AM
hda or hdb - lilo config Assassin Linux - Newbie 4 12-01-2003 09:31 PM
lilo dual boot two linux distros / hda and hdb rioguia Linux - Newbie 2 01-23-2003 01:35 AM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration