LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-08-2003, 12:08 PM   #1
IHateLilo
LQ Newbie
 
Registered: Mar 2003
Distribution: Mandrake 9.0
Posts: 3

Rep: Reputation: 0
LILO gives me 'L 10 10 10 10...'


I know, I've already searched the forums and seen similar posts about LILO, but I think I have a unique problem here. Whenever I boot up my machine cold, LILO displays 'L 10 10 10...' and locks up. If I reboot, LILO works just fine. I'm running a system with 2 hard disks- one with WinME and the other with Mandrake 9.0. I did the novice auto install for Mandrake. For the partitions on the Mandrake drive, I did the auto setting, but I don't remember seeing a boot partition. I hope that's not the problem, as I don't know how to redo the partition table. If I use a boot disk, everything works just fine. Is there a problem here with the linux partitions not being recognized?

~Any help appreciated
 
Old 03-08-2003, 12:51 PM   #2
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
http://www.google.com/search?hl=en&i...=Google+Search

http://ftp.yggdrasil.com/bible/bible...er/node69.html
http://www.tldp.org/HOWTO/Bootdisk-HOWTO/a1483.html

You probably have a bad bit of drive right where LILO resides.
 
Old 03-08-2003, 01:50 PM   #3
Ghwomb
LQ Newbie
 
Registered: Mar 2003
Location: Kumla, Sweden
Distribution: Slackware 9.1, LFS and Win98SE
Posts: 3

Rep: Reputation: 0
The same thing happened to me when installing Lilo. I also have to hard drives and I installed Lilo in the second, the same Debian was installed on but not Windows. The Solution was to install Lilo on MBR of the first hard drive. After that it all worked fine.

The reason that it did not work in the first place, I believe, was that the MBR on the second hard drive was not prepared to be booted from.

If this is not working try another boot manager or use loadlin from DOS.
 
Old 03-08-2003, 06:55 PM   #4
IHateLilo
LQ Newbie
 
Registered: Mar 2003
Distribution: Mandrake 9.0
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the help there. The url's given helped me determine what the error code meant, and I'm thinking I have the same problem that Ghwomb had. I've already tried reinstalling LILO on the same drive, but that hasn't changed anything. Is there a quick and easy way to install LILO to my WinME drive's mbr without worrying about data loss? I'm worried that I may not be able to boot up at all. Also, if I want to take the whimpy way out with a floppy disk boot, can I get rid of LILO with just the 'lilo -u' command?
 
Old 03-08-2003, 07:13 PM   #5
farhan
Member
 
Registered: Feb 2003
Distribution: xNIX
Posts: 121

Rep: Reputation: 15
which linux u r installing i mean which version
try to boot from linux botable cd and type
linux rescue
then go to /etc
then vi /lilo.conf
where there is written linear type there lba32 or vice versa
it happens bcs ur loader is beyond 1024 cylenders so use lba32 to avoid it
 
Old 03-08-2003, 07:21 PM   #6
Ghwomb
LQ Newbie
 
Registered: Mar 2003
Location: Kumla, Sweden
Distribution: Slackware 9.1, LFS and Win98SE
Posts: 3

Rep: Reputation: 0
I start with the last question, the only way I know to remove Lilo is to execute fdisk /mbr, in DOS. I've done that many times and also read in various computer magazines that it would be harmless. But don't hold me responsible if it isn't.

My guess is that if you want to change the place where Lilo is located from the second hard drives MBR to your second drive, you'll have to reinstall Lilo and choose to install to the first drives (hda i suppose) MBR.

To install on another MBR should be harmless unless you have something there already, for example PQBoot or GRUBE.

You could also start Linux by using the loadlin program to start it from DOS.
 
Old 03-08-2003, 10:47 PM   #7
IHateLilo
LQ Newbie
 
Registered: Mar 2003
Distribution: Mandrake 9.0
Posts: 3

Original Poster
Rep: Reputation: 0
Uh oh, I think I have a more serious problem. I noticed that my BIOS is acting up. The BIOS doesn't recognize the linux hard disk on first boot up. If I use a floppy to boot into linux, linux works fine, even though the BIOS doesn't see the linux hd. If I don't use the floppy, I get the 'L' error. When I reboot, the BIOS recognizes the linux hd and LILO goes on its own merry way. I think I might have an issue with my BIOS and hard disk not getting along.

I'm using Mandrake 9.0, and ever since I added the hd and linux, my BIOS setup has been weird. I have my drive controller on auto, and usually when I go to BIOS setup, my drives are shown, along with the manufacturer. However, after loading linux, the drive controller setup info only shows 'auto', and not the drive info. Geez, I have no idea what's going on here. I'm just going to ditch LILO and stick to a boot floppy. Thanks for everyone's help. Next time I will use a dedicated linux machine.
 
Old 03-08-2003, 11:41 PM   #8
jgr220
Member
 
Registered: Feb 2003
Distribution: mandrake9.0
Posts: 100

Rep: Reputation: 15
Get into your bios and look for auto detect for slave drives it's probably disabled.Ooops missed the part where you said that.

Last edited by jgr220; 03-09-2003 at 12:05 AM.
 
Old 03-09-2003, 12:30 AM   #9
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 48
Is your hard drive jumpered with the correct designation (master or
slave), or is it set to cable select? Cable select is notorious for its
faulty behavior, and this may be part of the problem.
 
Old 03-09-2003, 12:06 PM   #10
Ghwomb
LQ Newbie
 
Registered: Mar 2003
Location: Kumla, Sweden
Distribution: Slackware 9.1, LFS and Win98SE
Posts: 3

Rep: Reputation: 0
Don't use floppy, use loadlin instead!

I made a file called L.bat located in c:\. It contains the following:


smartdrv /C

c:\program\linux\loadlin c:\program\linux\vmlinu~1.18- root=/dev/hdb3 vga=9 append="hdc=ide-scsi"


use the same but replace the vmlinuz part with the kernel you have comliped. For that to work you have to complile a kernel, but you probably can use the one that came with your distro. Then copy the kernel to your Windows drive. Unfortunately I can't remember where the kernel is locatet in Linux.

After that replace the path to vmlinuz with the one you are using and the path to the loadlin program with the one you are using.

The next time you want to start Linux, just press F8 during startup and print L, and Linux will start. The documentation for loadlin can help you if you want a start menu in config.sys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 02:15 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 05:50 PM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM


All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration