LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-21-2004, 09:21 PM   #1
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
Question lilo config edit problem


have two hds one with xp and knoppix. 2nd drive has mepis. lilo for knoppix lists xp and knoppix. would like to add mepis to list to avoid using boot floppy for mepis. mepis installed grub but without lising other os's,so grub was removed since i dont know much about grub editting. have tried: other= dev/hdb1 root= /dev/hdb1 label= mepis boot= /dev/hdb1 and get "fatal error 1st sector or /dev/hdb1 doesnt have valid boot sector" have reviewed man pages. probably just need minor change to above script. suggestions welcomed.

Last edited by lestoil; 04-21-2004 at 10:01 PM.
 
Old 04-21-2004, 10:14 PM   #2
dimi
Member
 
Registered: May 2003
Location: Sydney, Australia
Distribution: Debian
Posts: 67

Rep: Reputation: 15
Well even if u have lilo for knoppix, u still need a boot loader to load mepis install on that. Which was the case when i install RH9.0 and Debian on the same machine.

Anyways heres a suggestion, on mepis, reintall grub or lilo, and install it on the first sector of that hd ( in ur case /dev/hdb1) and then add the following entry on ur knoppix lilo.conf

other=/dev/hdb1
label=Mepis

That should do the trick.

Good luck
Di
 
Old 05-03-2004, 04:31 PM   #3
o2madness
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
Question How about to clone drives?

I have been reading all about dual boot but they only mention windows an linux, I have two clone drives and I have made some modifications to one of them but I want to have the option of using one or the other. If I let them to boot without modifying the lilo.conf it will not mount /boot because is conflicting and of course I don't have the option of choosing wich linux install I want to use. How am I supposed to edit the lilo.conf?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO config problem dave111 Slackware - Installation 7 09-01-2004 10:21 PM
Seems like small lilo config problem...maybe more devNul73 Linux - Newbie 2 04-06-2004 07:33 PM
lilo and grub config problem slyguyr3 Linux - Software 3 11-07-2003 01:58 PM
keyboard problem (ABNT2) / l/lilo.config ? jamaso Slackware 0 06-10-2002 06:13 PM
Lilo config problem jackopa Linux - General 2 03-18-2002 11:57 PM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration