LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2004, 05:07 AM   #1
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Lilo.conf problem


I had a strange problem and I'm hoping someone can explain it to me. I was compiling the 2.6.0 kernel so I editted my /etc/lilo.conf file to save my old kernel as backup. I have Lilo installed on the MBR. When I rebooted, I didn't see the new options that I added to /etc/lilo.conf. After playing around I found that by going into the KDE "Boot" menu, which happened to see everything I had entered into that file, and clicking on "Apply", my Lilo was just like I wanted it.

What was keeping Lilo from reading my /etc/lilo.config file? Fortunately I was about to sort it out but I'd like to know what caused it.

Thanks!
 
Old 01-01-2004, 05:14 AM   #2
Y0jiMb0
Member
 
Registered: Jul 2003
Location: Valencia (Spain)
Distribution: slackware 11, FEDORA CORE 4, RHEL3, Gentoo...
Posts: 361

Rep: Reputation: 30
Hi!
I guess you didn't do "/sbin/lilo" after you modified "/etc/lilo.conf"; it is necessary.
Regards
 
Old 01-01-2004, 05:14 AM   #3
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
After editing lilo.conf from a text exitor you have to run

/sbin/lilo

to re-install LILO and the new map file.....
 
Old 01-01-2004, 12:12 PM   #4
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Original Poster
Rep: Reputation: 31
nope, I didn't know that but I won't forget it now! Thanks for the help and Happy New Year!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with lilo.conf Beegie_B Linux - Newbie 2 08-04-2004 01:57 AM
lilo.conf and lilo.conf.anaconda difference blackzone Linux - General 1 07-06-2004 04:15 AM
Problem with lilo.conf Khan Linux - Software 1 04-06-2004 12:30 AM
problem with /etc/lilo.conf running 3 OS:es the_pixies Linux - Newbie 1 04-02-2003 10:07 PM
Problem with Lilo not updating (yes I ran lilo after changing the conf) webguy Linux - General 2 06-24-2001 08:12 PM


All times are GMT -5. The time now is 12:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration