LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-27-2003, 04:42 AM   #1
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Rep: Reputation: 15
Unhappy Lilo


I have installed slakware 8 on my laptop and after the install I received errors with LILO trying to install itself on the master boot record or the on the hda1. The system will not boot unless I boot it with the LILO boot disk.
How can I resolve this in order for the machine to boot itself.
 
Old 05-27-2003, 04:55 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
how about telling us what the errors were.....
 
Old 05-27-2003, 12:28 PM   #3
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
Hello

the error i am getting is:
the error i am getting is
LILO INSTALL ERROR # 1
Sorry but the attempt to install LILO has returned an error, so LILO has not been correctly installed. You will have to use a boot disk to start your machine insted. It should be possible to get LILO working by editing the /etc/lilo.conf file and reinstalling LILO mannually.
After checking the LILO config file i typed LILO on the propmt and the error i get is Table may not be specified near line 40 in file /etc/lilo.conf
 
Old 05-27-2003, 12:31 PM   #4
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
Line 40 on the LILO conf is image = /vmlinuz (which i think is the kernal, do i have the incorrect kernal on the machine?
 
Old 05-27-2003, 12:47 PM   #5
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
Sorry or line 40 may also be table =/dev/hda
 
Old 05-27-2003, 12:50 PM   #6
manthram
Member
 
Registered: Feb 2002
Location: Fairfax, VA
Distribution: RedHat 8, Mandrake9.1, Slack9
Posts: 456

Rep: Reputation: 31
post the whole content of your lilo.conf file and the partition setup of your computer
 
Old 05-27-2003, 01:04 PM   #7
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# DOS bootable partition config begins
other = /dev/hda5
label = DOS
table = /dev/hda
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /vmlinuz
root = /dev/hda1
label = Linux
read-only
# Linux bootable partition config ends
 
Old 05-27-2003, 01:12 PM   #8
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
Partition set up is

1st partition
name = hda1, flags = Boot, Part Type = Primary, FS Type = Linux ext2, Label = , size (MB) = 3487.

2nd partition
name = hda5, flags = , Part Type = Logical, FS Type = win95 FAT32, Label = , size (MB) = 732.05.

3rd partition
name = hda6, flags = , Part Type = Logical, FS Type = Linux swap, Label = , size (MB) = 106.93
 
Old 05-27-2003, 01:16 PM   #9
manthram
Member
 
Registered: Feb 2002
Location: Fairfax, VA
Distribution: RedHat 8, Mandrake9.1, Slack9
Posts: 456

Rep: Reputation: 31
# Linux bootable partition config begins
image = /vmlinuz
root = /dev/hda1
label = Linux
read-only


i think the second line here should be

image = /boot/vmlinuz

other that that everything looks fine. change the line and run 'lilo' and see
 
Old 05-28-2003, 11:57 AM   #10
tailine
Member
 
Registered: Jun 2002
Distribution: Slackware 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks for the help it is sorted now. I wiped the partitions and installed slakware 9 with only two partitions lunix and swap, after this LILO installed without any fuss.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 02:15 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 05:50 PM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration