LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-05-2012, 09:56 PM   #1
ratman1
Member
 
Registered: Oct 2009
Location: Perth, Australia
Distribution: Slackware64 14.0
Posts: 44

Rep: Reputation: 0
Lightdm - cannot figure out how to change default xsession - Debian Wheezy


Hi

I have installed Lightdm as my login manager for debian wheezy. I have three Desktop Environments/Window Managers installed: LXDE, XFCE4 and awesome. As soon as my machine boots, I am presented with the login screen, where I enter my username/password. There is also a drop down box where I can choose which DE/WM to use.

The problem is that the drop down box always defaults to "Default Xsession", which appears to be LXDE. I use XFCE4 most, and therefore I wish to set "Default XSession" to be XFCE4 so that I don't have to change the option with the drop down menu to manually log into XFCE4.

I have tried editing /etc/lightdm/lightdm.conf and changing user-session under [SeatDefaults] to a number of things, such as startxfce4, xfce4-session, xfce-session, xfce4, etc... None of those worked.

How do I change the Default Xsession so that it logs into XFCE4 by default, not LXDE?

Thanks in advance,
James

Last edited by ratman1; 05-05-2012 at 11:47 PM.
 
Old 05-05-2012, 10:16 PM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with Slackware 14.
Posts: 2,581

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
What DE were you sing when you installed it? I think if you installed it when you were in LXDE that would become the default. If this is the case completely remove it and then reinstall it when you are in XFCE.
 
Old 05-05-2012, 10:23 PM   #3
ratman1
Member
 
Registered: Oct 2009
Location: Perth, Australia
Distribution: Slackware64 14.0
Posts: 44

Original Poster
Rep: Reputation: 0
Yeah, I was in LXDE when I installed LightDM.

I will try that and post how it goes

EDIT: Nope, that didn't work. I logged into XFCE and ran the following:
Code:
apt-get remove lightdm
apt-get install lightdm
However it still logs into lxdm by default

Last edited by ratman1; 05-05-2012 at 10:35 PM.
 
Old 05-05-2012, 11:05 PM   #4
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with Slackware 14.
Posts: 2,581

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
Originally Posted by ratman1 View Post
Yeah, I was in LXDE when I installed LightDM.

I will try that and post how it goes

EDIT: Nope, that didn't work. I logged into XFCE and ran the following:
Code:
apt-get remove lightdm
apt-get install lightdm
However it still logs into lxdm by default
Try this instead
Code:
apt-get purge lightdm
apt-get install lightdm
Remove does not remove configurations files, purge does.
 
Old 05-05-2012, 11:20 PM   #5
ratman1
Member
 
Registered: Oct 2009
Location: Perth, Australia
Distribution: Slackware64 14.0
Posts: 44

Original Poster
Rep: Reputation: 0
Unfortunately that did not seem to work either...

I logged into XFCE and ran those two commands. After the second command, I chose lightdm instead of xdm to be my login manager. However, upon a reboot, "Default XSession" always logged me in with LXDE.

I now only have XDM installed, and logging in through that also logs me in with LXDE.
 
Old 05-05-2012, 11:29 PM   #6
ratman1
Member
 
Registered: Oct 2009
Location: Perth, Australia
Distribution: Slackware64 14.0
Posts: 44

Original Poster
Rep: Reputation: 0
I did a bit of googling, and found this command:
Code:
/usr/lib/x86_64-linux-gnu/lightdm/lightdm-set-defaults -s cinnamon
According to the site (a user on the linux mint forums) the above command "will set cinnamon to default in lightdm".

Do you think if I changed the last argument from cinnamon to something xfce related it may work?
If so, what should the final argument be? xfce4-session, xfce4, xfce, startxfce4, or what else?
 
Old 05-05-2012, 11:46 PM   #7
ratman1
Member
 
Registered: Oct 2009
Location: Perth, Australia
Distribution: Slackware64 14.0
Posts: 44

Original Poster
Rep: Reputation: 0
Sorry for my third post in a row, but I found a solution (probably more of a workaround, but hey, that still counts as a solution!)

I went into /usr/share/xsessions and found a file called lightdm-xsession.desktop. I then edited lightdm-xsession.desktop, and found a command "exec".

Simply changing this "exec" from "default" to "startxfce4" meant that when I have "Default XSession" selected at the login screen, it starts xfce4 instead of "default".

Last edited by ratman1; 05-06-2012 at 12:09 AM.
 
Old 05-06-2012, 12:23 AM   #8
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with Slackware 14.
Posts: 2,581

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Well done.
 
Old 07-13-2012, 02:04 PM   #9
anto1945
LQ Newbie
 
Registered: Jul 2012
Location: Europe
Distribution: Debian
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by ratman1 View Post
I went into /usr/share/xsessions and found a file called lightdm-xsession.desktop. I then edited lightdm-xsession.desktop, and found a command "exec".

Simply changing this "exec" from "default" to "startxfce4"
I found another solution.
The Debian manual page [1] says each user can select a different default windows manager using the "exec ..." command in own home folder (in "~/.xsession" file).
And it works form me in Debian Wheezy.

[1] debian.org/doc/manuals/debian-reference/ch07.en.html#_customizing_the_x_session_classic_method
 
Old 05-23-2013, 05:00 AM   #10
noeli
LQ Newbie
 
Registered: May 2013
Location: cascadia, north america
Distribution: debian wheezy w/ openbox
Posts: 2

Rep: Reputation: Disabled
Found a reasonable way to accomplish this

I had a virtually identical challenge with wheezy stable, I switched from LXDE to a plain openbox WM and had to select it manually for each login. To change the default you need to change the symlink at /etc/alternatives/x-session-manager to point at the appropriate session starter (so I needed to point it at /usr/bin/openbox-session).

The easiest way to accomplish this (the way I actually did it) is to use update-alternatives:

# update-alternatives --config x-session-manager

you will get a list of options, select xcfe and you will be set.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Enlightment to be default using LightDM whatsvictory Linux - General 1 12-12-2011 05:09 PM
LXer: Simple LightDM Manager: Change The LightDM Background Or Logo Using A GUI LXer Syndicated Linux News 0 10-05-2011 05:41 PM
Change debian default dhcp client VaZso Linux - Networking 2 11-06-2010 05:13 AM
How to change the default browser in debian? vineet7kumar Linux - Newbie 2 03-03-2009 11:05 AM
Can't figure out how to change SuSE 10.1's horrid default cursor theme kersten78 Suse/Novell 3 10-12-2006 02:00 PM


All times are GMT -5. The time now is 05:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration