LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-21-2003, 07:27 AM   #1
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Rep: Reputation: 30
libttf.so.2


Im trying to install enlightenment but continue to get dependency problems, namely Kpackage is saying that enlightenment needs libttf.so.2.

After doing a rpm search i can only seems to come up with freetype-1.3.1-801.src.rpm and freetype-2.0.1-4.src.rpm, apparently these provide the nesessary libttf.so.2, but when i try to install enlightenment, i "still" get the dependency problem.

What am i doing wrong ?


Gazza
 
Old 10-21-2003, 07:48 AM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Those freetype things are source RPMs. They give the source code to build the libraries but not the libraries themselves. Can you find corresponding RPMs without the 'src' in the name?
 
Old 10-21-2003, 07:58 AM   #3
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Original Poster
Rep: Reputation: 30
no, do you know where i can ?
 
Old 10-21-2003, 08:09 AM   #4
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
Seems to be something on the SuSE web site in

ftp://ftp.suse.com/pub/suse/i386/8.2/suse/i586

Maybe also accessible through http.
 
Old 10-21-2003, 08:20 AM   #5
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Original Poster
Rep: Reputation: 30
This proving quite difficult to get hold of, can only find libtiff-3.5.7-204.i586.rpm, but not the libttf.so.2.rpm................................
 
Old 10-21-2003, 08:30 AM   #6
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
No - you want the freetype RPMs (I tried to cut and past the names from inside Konqueror's FTP window but it didn't work). There is freetype-1.3.1-801.i586.rpm and freetype2-2.1.3-35.i586.rpm in there. When you install these you should get the library you want (if your initial guess about needing freetype was correct).
 
Old 10-21-2003, 08:40 AM   #7
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Original Poster
Rep: Reputation: 30
got and installed the freetype2-2.1.3-35.i586.rpm, but still get the error message

error: failed dependencies:
libttf.so.2 is needed by enlightenment-0.16.5-809
RESULT=1

dunno what to try next .....................
 
Old 10-21-2003, 08:44 AM   #8
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I just did a google on this and apparently libttf is in the other freetype package. You can install both--they don't conflict.
 
Old 10-21-2003, 08:58 AM   #9
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Original Poster
Rep: Reputation: 30
Fantastic ! its installed now, many thanks

cheers
 
Old 10-21-2003, 09:37 AM   #10
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Original Poster
Rep: Reputation: 30
Its installed now but how do i use it ?
 
Old 10-22-2003, 01:09 AM   #11
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
I installed the big E a couple of times in the distant past, and pretty much the same thought occurred to me So I stuck with Windowmaker, and recently switched to KDE.

You could have a look at their website www.enlightenment.org for further, er, enlightenment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libttf.so.2 - missing Kane2002 Slackware 5 02-19-2005 06:03 PM
Eterm libttf.so.2 problem Abe_the_Man Slackware 3 01-08-2004 02:22 PM
Can't start enlightenment...libttf.so.2 not found !! frenchi Linux - Newbie 4 12-26-2003 10:44 AM
Honestly...where's libttf.so? bvc Linux From Scratch 4 04-25-2003 08:44 AM


All times are GMT -5. The time now is 04:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration