LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2004, 09:38 AM   #1
belkins
Member
 
Registered: Apr 2003
Posts: 60

Rep: Reputation: 15
libselinux problems


I've just reloaded FC2 and I'm trying to update the packages.

I first do a "yum check-update" and I receive the following error message:

[root@laptop1 root]# yum update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
....Unable to satisfy dependencies
Package fam-devel needs libselinux-devel, this is not available.
[root@laptop1 root]#

I posted a message yesterday and from the responses I received I downloaded the file:

libselinux-1.11.4-1.i386.rpm

I ran the command: "rpm -ivh libselinux-1.11.4-1.i386.rpm" and I received the following:

[root@laptop1 root]# rpm -ivh libselinux-1.11.4-1.i386.rpm
warning: libselinux-1.11.4-1.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... ########################################### [100%]
package libselinux-1.11.4-1 is already installed

I then ran "yum update" and I received the error message at the top again!!!!

Help! Please!!! What in the world am I doing wrong???!!!
 
Old 10-19-2004, 10:45 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

You need to install the file libselinux-devel-1.11.4-1.i386.rpm

It should be on your installation disks.

Dave
 
Old 10-19-2004, 12:45 PM   #3
belkins
Member
 
Registered: Apr 2003
Posts: 60

Original Poster
Rep: Reputation: 15
Thank you VERY much! That did it!

Shouldn't that file have been installed when I selected the "Everything" install when I was setting up Fedora?
 
Old 10-19-2004, 12:47 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
You would think so, wouldn't you.....
 
Old 10-19-2004, 12:51 PM   #5
belkins
Member
 
Registered: Apr 2003
Posts: 60

Original Poster
Rep: Reputation: 15
Actually, now that I think about it I didn't do an Everything install, I did a Custom install and I must have missed that one package!

All the same, it was a learning experience since I've never installed a RPM before.

Once again, thank you VERY much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rpm: relocation error: /lib/libselinux.so.1 vmattila Linux - Software 4 12-26-2004 10:02 AM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 04:02 PM
Accidently uninstalled libselinux on Fedora Core 2 ktulu1115 Linux - Software 1 05-03-2004 12:35 PM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 02:20 AM
Problems, problems, problems. Lets start with the ES 1868 AudioDrive Kre8ive Linux - Newbie 1 08-06-2003 08:04 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration