LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   libogg not installing, make and make install don't give errors, but fail (http://www.linuxquestions.org/questions/linux-newbie-8/libogg-not-installing-make-and-make-install-dont-give-errors-but-fail-769132/)

lilmike 11-14-2009 01:07 PM

libogg not installing, make and make install don't give errors, but fail
 
1 Attachment(s)
Hi,
I am trying to install libogg for an icecast server, and it does not seem to give me any errors, but it does not install.
I know this because when I try to install libvorbis, which I also need, it says ogg is not installed, and must be before libvorbis will work.
The output from make and make install is attached.
Any idea why this is happening?
Thanks,
-Michael.

bathory 11-14-2009 01:20 PM

Hi,

libogg is installed under /usr/local/, that's why the ./configure script for libvorbis cannot find it. You can use the following to configure libvorbis:
Code:

LDFLAGS="-L/usr/local/lib" CPPFLAGS="-I/usr/local/include" ./configure --other-options
Regards

lilmike 11-14-2009 03:50 PM

Hi,
It gives me this error:
Quote:

configure: error: unrecognized option: --other-options
Try `./configure --help' for more information.
I think the one we want might be something like --libogg=dir where libogg is installed, or something.
Thanks,
-Michael.

bathory 11-14-2009 04:39 PM

What I mean with "--other-options" is that you can put any other options you want to use when configuring libvorbis after the LDFLAGS, CPPFLAGS and ./configure.

lilmike 11-14-2009 04:49 PM

Hi,
Ok, I did that, and it seems to have the same error:
Quote:

configure: error: must have Ogg installed!
Thanks,
-Michael.

bathory 11-14-2009 05:10 PM

Try to run the following before the above command :
Code:

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
export PKG_CONFIG_PATH=/usr/local/lib//pkgconfig:$PKG_CONFIG_PATH


lilmike 11-14-2009 08:33 PM

Thanks,
It worked like a dream.
-Michael.


All times are GMT -5. The time now is 01:00 PM.