LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-11-2009, 09:58 AM   #1
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Rep: Reputation: 33
libGL.so.1


I had a little game that I made on Slackware. I'm using Debian now. I get this when I try to run my program:

icecube@97-91-179-182:~/Desktop/demo2$ ./project5
./project5: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

That is with Debian freshly installed from the a CD I made with the disc 1 iso.

libGL.so.1 is in /usr/lib

I added /usr/lib to /etc/ld.so.conf and then as root I ran ldconfig. It didn't help.

I tried updating to the best video driver with these instructions:
http://www.mepis.org/docs/en/index.p...ian/Nvidia_way

I guess I updated my driver and enabled 3D hardware acceleration and stuff but I still get that libGL.so.1 error. I don't get it.
 
Old 07-11-2009, 10:17 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
That file should be part of your fglrx driver package. I guess your using an ATI Radeon type vidoe card, yes?
cheers,
jdk
 
Old 07-11-2009, 10:23 AM   #3
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
No. It's an NVidia GeForce 8600GT.

I did what that link I posted above told me to do in order to have the best driver. Like I said, I think that enabled my video card to work at full capacity rather than use whatever drivers came with the initial install of Debian. But I still get that same error.
 
Old 07-11-2009, 11:07 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
OK, I'm just wondering if it has to do with "diversions" of the library in question. In the fglrx packages that I use a diversion is installed to deal with issues involving exactly that library.
/usr/lib/fglrx/diversions/libGL.so.1.2
Who knows?
jdk
 
Old 07-11-2009, 11:10 AM   #5
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
Hey and for some reason if I follow the directions from that link they don't work at first. It won't find nvidia-kernel-common. At some point, I can't remember when I added "contrib non-free" to /etc/apt/sources.list and then I ran "atp-get update" and then after that it could find mvidia-kernel-common. I can't remember where I found out how to do that. Also I definitely had to run "atp-get update" before it could find it. Just adding "contrib non-free" wasn't enough.
 
Old 07-11-2009, 11:24 AM   #6
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
Hey and I'm trying to play Doom3. (That's the whole reason I tried a different OS, whatever xorg server that is in Slackware 12.2 has a bug. Xorg fixed it but it won't show up in Slackware until version 13 is out. The mouse moves everything too jumpy in the game.)

Look at this:
icecube@97-91-179-182:~$ doom3
./doom.x86: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
icecube@97-91-179-182:~$ su
Password:
97-91-179-182:/home/icecube# find / -name libX11.so.6
/usr/lib/libX11.so.6

Annoying.
 
Old 07-11-2009, 11:36 AM   #7
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Yes, annoying indeed. I'm no expert on games but there is a forum devoted to games on LQ called Linux - Games. Why not ask there? Post a thread like "Doom3 - how to install?" and you may get a quick result.
Good luck,
jdk
 
Old 07-11-2009, 11:39 AM   #8
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
Okay. I'm wondering if it has something to do with the switch to 64 bit? This is AMD64 Debian. I think I'm going to try i386 Debian and see what happens.

Last edited by icecubeflower; 07-11-2009 at 12:23 PM.
 
Old 07-11-2009, 12:32 PM   #9
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
I couldn't say. Maybe posting the thread I mentioned with the title "Doom3 with amd64?" might bring enlightenment. Sorry to say I'm not a gamer so I haven't a clue.
cheers,
jdk
 
Old 07-11-2009, 12:49 PM   #10
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Quote:
Originally Posted by icecubeflower View Post
Hey and I'm trying to play Doom3. (That's the whole reason I tried a different OS, whatever xorg server that is in Slackware 12.2 has a bug. Xorg fixed it but it won't show up in Slackware until version 13 is out. The mouse moves everything too jumpy in the game.)

Look at this:
icecube@97-91-179-182:~$ doom3
./doom.x86: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory
icecube@97-91-179-182:~$ su
Password:
97-91-179-182:/home/icecube# find / -name libX11.so.6
/usr/lib/libX11.so.6

Annoying.
Are you using the evdev driver in xorg.conf ?
 
Old 07-11-2009, 01:57 PM   #11
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
I don't know. xorg.conf was completely empty. After updating my nvidia driver with the link at the top I did an "apt-get install nvidia-settings" and then a "apt-get install nvidia-xconfig" and then I ran nvidia-xconfig as root and restarted X.

I never checked xorg.conf after that. It was whatever nvidia-xconfig decided it should be.

I was already playing around with loading new OS's, my stuff is backed up elsewhere so I just installed Debian i386. It works so far. It runs my little game after I apt-get all the libraries. It's really slow, I haven't gotten the nvidia drivers yet but it works. It's not telling it's missing libraries that I know damn well are there.

I think the whole problem was something related to the new 64-bit OS's that are all the rave. Something about the libraries becoming incompatable or something, I don't know. i386 seems to be working for me. I think doom3 will work too, I'll know soon. I'll give 64-bit a try a few years from now I guess.
 
Old 07-11-2009, 03:21 PM   #12
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
Yup, doom3 works flawlessly now. Something about the new 64 bit OS's and libraries. Beats me.
 
Old 07-11-2009, 03:55 PM   #13
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
Quote:
I think the whole problem was something related to the new 64-bit OS's that are all the rave
You needed to install the ia32-libs package to run x86 games such as Doom3 in Debian x86_64.
Debian has officially supported AMD64 since the release of Etch in 2007.
 
Old 07-11-2009, 07:19 PM   #14
icecubeflower
Member
 
Registered: Mar 2008
Location: USA
Distribution: Slackware 13.1
Posts: 304

Original Poster
Rep: Reputation: 33
Oh. Well, too late now. I'm back in the 32 bit dark ages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No libGL hylke Linux - Newbie 2 10-07-2005 03:40 AM
libGL.so.1 ET TuxFreak Linux - Games 11 08-22-2005 01:33 PM
libGL.la art3mis Linux - Software 5 12-22-2004 09:50 AM
libGL.so.1(LIBGL) for SuSE 9.1? darkmatter333 SUSE / openSUSE 1 12-17-2004 11:23 PM
libgl trpn Linux - Hardware 0 03-05-2003 10:21 PM


All times are GMT -5. The time now is 01:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration