LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2009, 10:53 PM   #1
shibu_sp
Member
 
Registered: Aug 2007
Posts: 57

Rep: Reputation: 15
libgcc upgrade problem?


Hi
OS: RHAS 4
When try to install oracle application server 10g release 2.
I met a problem in the pre-requestion level.

When i am try to install gcc-3.4.6-3.i386.rpm (old version gcc uninstall using Yum command) via Yum command i am getting the following error

Code:
[root@mail acclsys]# yum install gcc-3.4.6-3.i386.rpm
Setting up Install Process
Setting up repositories
rpmforge                  100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
Examining gcc-3.4.6-3.i386.rpm: gcc - 3.4.6-3.i386
Marking gcc-3.4.6-3.i386.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gcc.i386 0:3.4.6-3 set to be updated
--> Running transaction check
--> Processing Dependency: libgcc >= 3.4.6-3 for package: gcc
--> Finished Dependency Resolution
Error: Missing Dependency: libgcc >= 3.4.6-3 is needed by package gcc
[root@mail acclsys]#
So I uninstall the my old libgcc using yum. It take nearly 15 minutes to clear all the links and finally said to restart and which i done the same.
when i try to install the New version Libgcc im getting long error. Please help how to solve my issue.

Code:
[root@mail Desktop]# rpm -Uvh libgcc-4.4.6-3.1.x86_64.rpm
error: Failed dependencies:
        libgcc_s.so.1 is needed by (installed) libstdc++-3.4.3-9.EL4.i386
        libgcc_s.so.1 is needed by (installed) db4-4.2.52-7.1.i386
        libgcc_s.so.1 is needed by (installed) gmp-4.1.4-3.i386
        libgcc_s.so.1 is needed by (installed) aspell-0.50.5-3.fc3.i386
        libgcc_s.so.1 is needed by (installed) brltty-3.2-7.i386
        libgcc_s.so.1 is needed by (installed) groff-1.18.1.1-3.i386
        libgcc_s.so.1 is needed by (installed) lftp-3.0.6-3.i386
        libgcc_s.so.1 is needed by (installed) libwvstreams-3.75.0-2.i386
        libgcc_s.so.1 is needed by (installed) iptstate-1.3-4.i386
        libgcc_s.so.1 is needed by (installed) wvdial-1.54.0-3.i386
        libgcc_s.so.1 is needed by (installed) cups-1.1.22-0.rc1.9.i386
        libgcc_s.so.1 is needed by (installed) redhat-lsb-1.3-5.2.i386
        libgcc_s.so.1 is needed by (installed) mysql-4.1.7-4.RHEL4.1.i386
        libgcc_s.so.1 is needed by (installed) Omni-0.9.1-7.1.i386
        libgcc_s.so.1 is needed by (installed) ttmkfdir-3.0.9-14.i386
        libgcc_s.so.1 is needed by (installed) hpoj-0.91-9.i386
        libgcc_s.so.1 is needed by (installed) hpijs-1.6-2.i386
        libgcc_s.so.1 is needed by (installed) compat-libstdc++-33-3.2.3-47.3.i386
        libgcc_s.so.1 is needed by (installed) flac-1.1.0-7.i386
        libgcc_s.so.1 is needed by (installed) libmusicbrainz-2.0.2-11.i386
        libgcc_s.so.1 is needed by (installed) dvd+rw-tools-5.21.4.10.8-4.i386
        libgcc_s.so.1 is needed by (installed) pilot-link-0.11.8-8.i386
        libgcc_s.so.1 is needed by (installed) openjade-1.3.2-14.i386
        libgcc_s.so.1 is needed by (installed) qt-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) arts-1.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) xorg-x11-Mesa-libGLU-6.8.1-23.EL.i386
        libgcc_s.so.1 is needed by (installed) vnc-server-4.0-8.1.i386
        libgcc_s.so.1 is needed by (installed) gstreamer-plugins-0.8.5-1.EL.0.i386
        libgcc_s.so.1 is needed by (installed) dia-0.94-5.i386
        libgcc_s.so.1 is needed by (installed) openoffice.org-libs-1.1.2-18.6.EL4.i386
        libgcc_s.so.1 is needed by (installed) openoffice.org-1.1.2-18.6.EL4.i386
        libgcc_s.so.1 is needed by (installed) pwlib-1.6.5-11.i386
        libgcc_s.so.1 is needed by (installed) openh323-1.13.4-7.i386
        libgcc_s.so.1 is needed by (installed) gnomemeeting-1.0.2-8.i386
        libgcc_s.so.1 is needed by (installed) sound-juicer-0.5.14-2.EL.i386
        libgcc_s.so.1 is needed by (installed) gpdf-2.8.0-7.i386
        libgcc_s.so.1 is needed by (installed) xorg-x11-6.8.1-23.EL.i386
        libgcc_s.so.1 is needed by (installed) kdelibs-3.3.1-3.2.i386
        libgcc_s.so.1 is needed by (installed) kdebase-3.3.1-5.5.i386
        libgcc_s.so.1 is needed by (installed) kdepim-3.3.1-2.1.i386
        libgcc_s.so.1 is needed by (installed) k3b-0.11.14-2.i386
        libgcc_s.so.1 is needed by (installed) kdemultimedia-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdegraphics-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) xpdf-3.00-11.1.i386
        libgcc_s.so.1 is needed by (installed) thunderbird-1.0-0.2.rc1.EL4.i386
        libgcc_s.so.1 is needed by (installed) festival-1.4.2-25.i386
        libgcc_s.so.1 is needed by (installed) dasher-3.2.11-5.i386
        libgcc_s.so.1 is needed by (installed) libgnat-3.4.3-9.EL4.i386
        libgcc_s.so.1 is needed by (installed) doxygen-1.3.9.1-1.i386
        libgcc_s.so.1 is needed by (installed) boost-1.32.0-1.rhel4.i386
        libgcc_s.so.1 is needed by (installed) swig-1.3.21-6.i386
        libgcc_s.so.1 is needed by (installed) libgcj-3.4.3-9.EL4.i386
        libgcc_s.so.1 is needed by (installed) oprofile-0.8.1-11.i386
        libgcc_s.so.1 is needed by (installed) ddd-3.3.9-1.i386
        libgcc_s.so.1 is needed by (installed) xorg-x11-sdk-6.8.1-23.EL.i386
        libgcc_s.so.1 is needed by (installed) tetex-2.0.2-21RH4.1.i386
        libgcc_s.so.1 is needed by (installed) mozilla-1.7.3-18.EL4.i386
        libgcc_s.so.1 is needed by (installed) devhelp-0.9.2-2.i386
        libgcc_s.so.1 is needed by (installed) autorun-3.14-2.i386
        libgcc_s.so.1 is needed by (installed) htdig-3.2.0b6-3.i386
        libgcc_s.so.1 is needed by (installed) kdeadmin-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdeartwork-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdenetwork-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdeaddons-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdeutils-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) arts-devel-1.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) sip-4.1-1.i386
        libgcc_s.so.1 is needed by (installed) PyQt-3.13-1.i386
        libgcc_s.so.1 is needed by (installed) qt-devel-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) qt-designer-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) kdbg-1.2.9-6.i386
        libgcc_s.so.1 is needed by (installed) kdelibs-devel-3.3.1-3.2.i386
        libgcc_s.so.1 is needed by (installed) kdepim-devel-3.3.1-2.1.i386
        libgcc_s.so.1 is needed by (installed) kdesdk-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdesdk-devel-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdevelop-3.1.1-2.i386
        libgcc_s.so.1 is needed by (installed) miniChinput-0.0.3-58.i386
        libgcc_s.so.1 is needed by (installed) iiimf-server-12.1-10.EL.i386
        libgcc_s.so.1 is needed by (installed) compat-libstdc++-296-2.96-132.7.2.i386
        libgcc_s.so.1 is needed by (installed) octave-2.1.57-7.i386
        libgcc_s.so.1 is needed by (installed) unixODBC-kde-2.2.9-1.i386
        libgcc_s.so.1 is needed by (installed) gnome-games-2.8.0-4.i386
        libgcc_s.so.1 is needed by (installed) mysql-server-4.1.7-4.RHEL4.1.i386
        libgcc_s.so.1 is needed by (installed) qt-MySQL-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) qt-ODBC-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) tora-1.3.14.1-2.i386
        libgcc_s.so.1 is needed by (installed) nmap-3.70-1.i386
        libgcc_s.so.1 is needed by (installed) vnc-4.0-8.1.i386
        libgcc_s.so.1 is needed by (installed) doxygen-doxywizard-1.3.9.1-1.i386
        libgcc_s.so.1 is needed by (installed) gettext-devel-0.14.1-13.i386
        libgcc_s.so.1 is needed by (installed) gperf-3.0.1-4.i386
        libgcc_s.so.1 is needed by (installed) ImageMagick-c++-6.0.7.1-5.i386
        libgcc_s.so.1 is needed by (installed) ecj-2.1.3-5.i386
        libgcc_s.so.1 is needed by (installed) qt-config-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) qt-PostgreSQL-3.3.3-9.3.i386
        libgcc_s.so.1 is needed by (installed) mozilla-devel-1.7.3-18.EL4.i386
        libgcc_s.so.1 is needed by (installed) mozilla-dom-inspector-1.7.3-18.EL4.i386
        libgcc_s.so.1 is needed by (installed) mozilla-mail-1.7.3-18.EL4.i386
        libgcc_s.so.1 is needed by (installed) htdig-web-3.2.0b6-3.i386
        libgcc_s.so.1 is needed by (installed) kdegames-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdeaddons-atlantikdesigner-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdeaddons-xmms-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) kdenetwork-nowlistening-3.3.1-2.i386
        libgcc_s.so.1 is needed by (installed) pwlib-devel-1.6.5-11.i386
        libgcc_s.so.1 is needed by (installed) xojpanel-0.91-9.i386
        libgcc_s.so.1 is needed by (installed) firefox-1.0-12.EL4.i386
        libgcc_s.so.1 is needed by (installed) iiimf-x-12.1-10.EL.i386
        libgcc_s.so.1 is needed by (installed) iiimf-le-chinput-0.3-16.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) libstdc++-3.4.3-9.EL4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) db4-4.2.52-7.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gmp-4.1.4-3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) aspell-0.50.5-3.fc3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) brltty-3.2-7.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) groff-1.18.1.1-3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) lftp-3.0.6-3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) iptstate-1.3-4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) wvdial-1.54.0-3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) cups-1.1.22-0.rc1.9.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) Omni-0.9.1-7.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) ttmkfdir-3.0.9-14.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) hpoj-0.91-9.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) hpijs-1.6-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) compat-libstdc++-33-3.2.3-47.3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) flac-1.1.0-7.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) libmusicbrainz-2.0.2-11.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) pilot-link-0.11.8-8.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) openjade-1.3.2-14.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) qt-3.3.3-9.3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) xorg-x11-Mesa-libGLU-6.8.1-23.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) vnc-server-4.0-8.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gstreamer-plugins-0.8.5-1.EL.0.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) openoffice.org-libs-1.1.2-18.6.EL4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) pwlib-1.6.5-11.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) openh323-1.13.4-7.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gnomemeeting-1.0.2-8.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) sound-juicer-0.5.14-2.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gpdf-2.8.0-7.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) xorg-x11-6.8.1-23.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdelibs-3.3.1-3.2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdemultimedia-3.3.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdegraphics-3.3.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) xpdf-3.00-11.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) festival-1.4.2-25.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) dasher-3.2.11-5.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) libgnat-3.4.3-9.EL4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) boost-1.32.0-1.rhel4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) swig-1.3.21-6.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) libgcj-3.4.3-9.EL4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) oprofile-0.8.1-11.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) ddd-3.3.9-1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) xorg-x11-sdk-6.8.1-23.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) tetex-2.0.2-21RH4.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) devhelp-0.9.2-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) autorun-3.14-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdenetwork-3.3.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdeaddons-3.3.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) PyQt-3.13-1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) qt-devel-3.3.3-9.3.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdesdk-3.3.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) kdevelop-3.1.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) miniChinput-0.0.3-58.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) iiimf-server-12.1-10.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) octave-2.1.57-7.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) unixODBC-kde-2.2.9-1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gnome-games-2.8.0-4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) mysql-server-4.1.7-4.RHEL4.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) tora-1.3.14.1-2.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) nmap-3.70-1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) vnc-4.0-8.1.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gettext-devel-0.14.1-13.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) gperf-3.0.1-4.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) ImageMagick-c++-6.0.7.1-5.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) ecj-2.1.3-5.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) pwlib-devel-1.6.5-11.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) xojpanel-0.91-9.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) iiimf-x-12.1-10.EL.i386
        libgcc_s.so.1(GCC_3.0) is needed by (installed) iiimf-le-chinput-0.3-16.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) libstdc++-3.4.3-9.EL4.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) brltty-3.2-7.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) lftp-3.0.6-3.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) wvdial-1.54.0-3.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) Omni-0.9.1-7.1.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) compat-libstdc++-33-3.2.3-47.3.i386
        libgcc_s.so.1(GCC_3.3) is needed by (installed) libgcj-3.4.3-9.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) libstdc++-3.4.3-9.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) db4-4.2.52-7.1.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) libwvstreams-3.75.0-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) compat-libstdc++-33-3.2.3-47.3.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) libmusicbrainz-2.0.2-11.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) qt-3.3.3-9.3.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) vnc-server-4.0-8.1.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) gstreamer-plugins-0.8.5-1.EL.0.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) openoffice.org-libs-1.1.2-18.6.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) pwlib-1.6.5-11.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) openh323-1.13.4-7.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) gnomemeeting-1.0.2-8.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) sound-juicer-0.5.14-2.EL.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) xorg-x11-6.8.1-23.EL.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdelibs-3.3.1-3.2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdebase-3.3.1-5.5.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdepim-3.3.1-2.1.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) k3b-0.11.14-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdemultimedia-3.3.1-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdegraphics-3.3.1-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) thunderbird-1.0-0.2.rc1.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) dasher-3.2.11-5.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) libgnat-3.4.3-9.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) libgcj-3.4.3-9.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) oprofile-0.8.1-11.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) xorg-x11-sdk-6.8.1-23.EL.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) mozilla-1.7.3-18.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdeutils-3.3.1-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) qt-devel-3.3.3-9.3.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) kdesdk-3.3.1-2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) compat-libstdc++-296-2.96-132.7.2.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) mysql-server-4.1.7-4.RHEL4.1.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) ecj-2.1.3-5.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) mozilla-mail-1.7.3-18.EL4.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by (installed) firefox-1.0-12.EL4.i386
[root@mail Desktop]#
please help me solve this issue.

shibu
 
Old 03-04-2009, 10:30 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,933

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by shibu_sp View Post
Hi
OS: RHAS 4
When try to install oracle application server 10g release 2.
I met a problem in the pre-requestion level.

When i am try to install gcc-3.4.6-3.i386.rpm (old version gcc uninstall using Yum command) via Yum command i am getting the following error

So I uninstall the my old libgcc using yum. It take nearly 15 minutes to clear all the links and finally said to restart and which i done the same.
when i try to install the New version Libgcc im getting long error. Please help how to solve my issue.

please help me solve this issue.

shibu
First, since you have RedHat support, I'd contact them if you have in-depth questions. You're paying for their support, so take advantage of it.

You might also want to try "yum update <package name>", rather than an uninstall/reinstall. The update should get all the dependencies, too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Folder $(gcc -print-libgcc-file-name) doesn't exist. 5.7 clonas Linux From Scratch 8 10-24-2008 08:08 PM
RH 8.0 and libgcc 3.3 killroy2000 Red Hat 1 01-12-2007 02:47 PM
trying to install mspgcc, make says libgcc.S has errors mandrakemikael Linux - Software 0 11-03-2004 04:13 PM
Installing GCC, binutils, libgcc, etc. jcai Linux - Newbie 5 09-14-2004 04:57 PM
libgcc syslinks messed up, help please ertmann|CPH Debian 3 05-01-2004 06:43 PM


All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration