LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2013, 12:57 AM   #1
Sharath Ravi
Member
 
Registered: Jun 2012
Posts: 37

Rep: Reputation: Disabled
libcurl.so.3


Hi,

when trying to install
php-common-5.3.1-1.i386.rpm
php-cli-5.3.1-1.i386.rpm on Centos 6.4 32 bit

it shows error: Failed dependencies:
libcurl.so.3 is needed by php-common-5.3.1-1.i386

Can some please help me find libcurl.so.3.. Trying very hard to find seems impossible.

Thanks in advance..
Sharath
 
Old 11-16-2013, 01:46 AM   #2
Spect73
Member
 
Registered: Aug 2013
Distribution: Slackware 14.1
Posts: 128

Rep: Reputation: Disabled
Try in /usr/lib. Should be the library and a symlink to it.

Coordially
 
Old 11-16-2013, 01:49 AM   #3
Sharath Ravi
Member
 
Registered: Jun 2012
Posts: 37

Original Poster
Rep: Reputation: Disabled
hey,

i can only see libcurl.so.4 in /usr/lib/

Unable to libcurl.so.3 which is required for php.
 
Old 11-16-2013, 03:55 AM   #4
Lennie
Member
 
Registered: Aug 2012
Location: Sweden
Distribution: LFS, built with pacman
Posts: 332

Rep: Reputation: 63
You have a newer version of curl. Are you trying to install php from the repo, or did you download the rpm? php should be in the repo (of most distros) and linked against the version of curl that's also in the repo. Which distro are you running?
 
Old 11-16-2013, 05:54 AM   #5
murugesan
Member
 
Registered: May 2003
Posts: 151

Rep: Reputation: 28
As per my search:
Related to Centos 6
Quote:
wget "ftp://ftp.pbone.net/mirror/ftp5.gwdg.de/pub/opensuse/repositories/home:/wvengen:/lgi/CentOS_CentOS-6/noarch/lgipilot-0.3-14.1.noarch.rpm"
which
Provides :
config(lgipilot)
bundled(libcrypto.so.0.9.7(x86-32))
bundled(libssl.so.0.9.7(x86-32))
bundled(libcurl.so.3(x86-32))
bundled(libidn.so.11(x86-32))
lgipilot
 
Old 11-16-2013, 05:59 AM   #6
murugesan
Member
 
Registered: May 2003
Posts: 151

Rep: Reputation: 28
I tried installing php in my machine
Quote:
$ cat /etc/redhat\-release
CentOS release 5.5 (Final)
$ uname -m
x86_64

Handling erros in my machine:

Quote:
$ wget ftp://rpmfind.net/linux/remi/enterpr...emi.x86_64.rpm


$ sudo rpm -ivh php-common-5.3.9-1.el4.remi.x86_64.rpm
warning: php-common-5.3.9-1.el4.remi.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 00f97f56
error: Failed dependencies:
libcrypto.so.4()(64bit) is needed by php-common-5.3.9-1.el4.remi.x86_64
libssl.so.4()(64bit) is needed by php-common-5.3.9-1.el4.remi.x86_64


$ wget ftp://ftp.muug.mb.ca/mirror/centos/5...8.2.x86_64.rpm


$ sudo rpm -ivh openssl097a\-0.9.7a\-11.el5_8.2.x86_64.rpm
Sudo invoked by [root] on [msdc] - Cmd run as root - Password for user root:
Preparing... ########################################### [100%]
1: openssl097a ########################################### [100%]


$ sudo rpm -ivh php-common-5.3.9-1.el4.remi.x86_64.rpm
warning: php-common-5.3.9-1.el4.remi.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 00f97f56
Preparing... ########################################### [100%]
WARNING : These php-* RPM are not official Fedora/Redhat build and
overrides the official ones. Don't file bugs on Fedora Project nor Redhat.
Use dedicated forums http://forums.famillecollet.com/
1: php-common ########################################### [100%]

Last edited by murugesan; 11-16-2013 at 06:04 AM. Reason: /bin/echo -ne "For Changing face options \n :o :p \nwith characters" | /bin/sed 's/:o/: o/;s/:p/: p/'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] libcurl manaila Linux - Software 6 10-12-2011 02:20 AM
libcurl for solaris 10 ddegif Solaris / OpenSolaris 5 05-02-2011 03:27 AM
libcurl.so.2 liljhand Linux - Newbie 3 01-24-2005 08:17 PM
Why is libcurl not being found? maestro52 Fedora 7 12-23-2004 01:19 PM
libcurl.so.2 in FC3 robyduck Fedora 3 12-08-2004 03:22 AM


All times are GMT -5. The time now is 09:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration