LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-01-2004, 04:36 AM   #1
mandrakemikael
Member
 
Registered: Aug 2004
Distribution: gentoo <3
Posts: 39

Rep: Reputation: 15
lib that is installed but ./configure can't find


i'm trying to install gthumb -2.4.1 to a newly installed mdk10.0. the installation stops at libgnomeprint-2.2 with an error:

Package libgnomeprint-2.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnomeprint-2.2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnomeprint-2.2' found

$ locate libgnomeprint-2.2
/usr/share/locale/fi/LC_MESSAGES/libgnomeprint-2.2.mo

$ locate libgnomeprint
/usr/share/doc/libgnomeprint-2.4.2
/usr/share/doc/libgnomeprint-2.4.2/ChangeLog
... (many lines clipped) ...
/usr/share/libgnomeprint/2.4.2
/usr/share/libgnomeprint/2.4.2/models
...
/usr/lib/libgnomeprint/2.4.2
/usr/lib/libgnomeprint/2.4.2/modules
...

$ locate pkgconfig
/usr/share/doc/pkgconfig-0.15.0
...
/usr/lib/pkgconfig
/usr/lib/pkgconfig/gnome-mime-data-2.0.pc
...
(libgnomeprint*.* is missing from this path)

$ echo $PKG_CONFIG_PATH
/usr/lib/pkgconfig:

what is the libgnomeprint-2.2 (or 2.4.2) .pc file? where can i get it?

Last edited by mandrakemikael; 09-01-2004 at 04:43 AM.
 
Old 09-01-2004, 04:57 AM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
I did this once - and I'm not sure exactly how I did it - but basically, it's like this:

pkg-config needs to realize that this lib is installed. Do a man pkg-config, and see what it says.
You should find that .pc file somewhere in that dir (/usr/share/doc/libgnomeprint-2.4.2)
Once you have it, you have to run a command to add it to pkg-config. It's not as simple as editing a file if I remember right.
Anyway, you run the command, point it to the .pc file, and it will update the config file for you.
Do a ./configure again, and you should be good to go.
 
Old 09-01-2004, 06:52 AM   #3
Enrico81
Newbie
 
Registered: Aug 2004
Location: Italy
Posts: 16

Rep: Reputation: 0
Re: lib that is installed but ./configure can't find

Quote:
Originally posted by mandrakemikael
i'm trying to install gthumb -2.4.1 to a newly installed mdk10.0. the installation stops at libgnomeprint-2.2 with an error:

Package libgnomeprint-2.2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnomeprint-2.2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnomeprint-2.2' found

$ locate libgnomeprint-2.2
/usr/share/locale/fi/LC_MESSAGES/libgnomeprint-2.2.mo

$ locate libgnomeprint
/usr/share/doc/libgnomeprint-2.4.2
/usr/share/doc/libgnomeprint-2.4.2/ChangeLog
... (many lines clipped) ...
/usr/share/libgnomeprint/2.4.2
/usr/share/libgnomeprint/2.4.2/models
...
/usr/lib/libgnomeprint/2.4.2
/usr/lib/libgnomeprint/2.4.2/modules
...

$ locate pkgconfig
/usr/share/doc/pkgconfig-0.15.0
...
/usr/lib/pkgconfig
/usr/lib/pkgconfig/gnome-mime-data-2.0.pc
...
(libgnomeprint*.* is missing from this path)

$ echo $PKG_CONFIG_PATH
/usr/lib/pkgconfig:

what is the libgnomeprint-2.2 (or 2.4.2) .pc file? where can i get it?

You must pass the correct path of the libraries to ./configure.
Try ./configure --help for knowledge how to pass the correct path, usually "-with-path_libraries" it works.
 
Old 09-01-2004, 04:31 PM   #4
Not now, John!
Member
 
Registered: Jul 2004
Distribution: LFS 5.1
Posts: 161

Rep: Reputation: 30
Try typing (as root): ldconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
making ./configure find installed software poiuytrewq Linux - Software 16 05-15-2005 02:11 AM
ardour wont configure: configure: error: C preprocessor "/lib/cpp" fails sanity check disciple061 Linux - Software 4 01-22-2005 01:35 PM
GTK installed, yet ./configure can't find it Micro420 Mandriva 12 08-13-2004 05:27 AM
Lib Packages Not Installed? Please Help! DozenEggs Linux - Software 8 07-19-2004 07:47 AM
can't find installed libxml2 during ./configure progressdll Linux - Software 2 09-23-2003 10:52 AM


All times are GMT -5. The time now is 02:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration