LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 01-29-2005, 02:38 PM   #16
solutionseeker
Member
 
Registered: Jan 2005
Location: US
Distribution: Debian for now
Posts: 43

Original Poster
Rep: Reputation: 15

did the above and says file exists ..
 
Old 01-29-2005, 03:57 PM   #17
solutionseeker
Member
 
Registered: Jan 2005
Location: US
Distribution: Debian for now
Posts: 43

Original Poster
Rep: Reputation: 15
If I want to setup the classpath and add this file in it then where shld I do it ?
 
Old 01-29-2005, 04:11 PM   #18
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
if it says it's already there, then you should just be ableto upgrade glibc. run "strings /lib/libpthreads.so.0 | grep GLIBC_2" and see if the require function is in there or not... obviously it shouldn't be. current verion of the glibc is 2.3.4 afaik, so being up to date would include 2.3.2 no problem.
 
Old 01-29-2005, 04:30 PM   #19
solutionseeker
Member
 
Registered: Jan 2005
Location: US
Distribution: Debian for now
Posts: 43

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
if it says it's already there, then you should just be ableto upgrade glibc.

run "strings /lib/libpthreads.so.0 | grep GLIBC_2" and see if the require function is in there or not... obviously it shouldn't be. current verion of the glibc is 2.3.4 afaik, so being up to date would include 2.3.2 no problem.
I did strings /lib/libpthreads.so.0 | grep GLIBC_2
It didnt see anything nor any errors...

I downloaded the latest version of glibc.tar.gz now.. where do I put it and say tar -zxvf *.tsr.gz ? in /usr/lib?
 
Old 01-29-2005, 05:13 PM   #20
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,345

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
don't download source, if you're on debina, use apt-get to install the newst version. I thought we'd already got past updating glibc though, seeing as that was my very first suggestion....
 
Old 01-29-2005, 06:03 PM   #21
solutionseeker
Member
 
Registered: Jan 2005
Location: US
Distribution: Debian for now
Posts: 43

Original Poster
Rep: Reputation: 15
I am not sure how we already installed it ?

We installed GLIBC_2 ?

What abt grep GLIBC_2.3 ? I didnt download anything from anywhere so how can I have installed it ? Do you mean GLIB newer versions are already on my machine ?

I downloaded GLIBC_2.3 since the error message is asking for it...

If have the new GLIB2.3 's tar.gz file can I still use "apt-get install GLIBC_2.3.tar.gz" <-- in this way from /root?
 
Old 01-29-2005, 09:02 PM   #22
solutionseeker
Member
 
Registered: Jan 2005
Location: US
Distribution: Debian for now
Posts: 43

Original Poster
Rep: Reputation: 15
I did a apt-get install on the new glib2.3 file....

and this still doesnt work........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
version GLIBC_2.3 not found error when cross compiled executable is run on targert sateeshgalla Programming 3 05-14-2008 10:42 AM
libpthread.so.0(GLIBC_2.3.2) feathersmcgraw Linux - Newbie 4 02-17-2005 02:09 AM
/usr/lib/libstdc++.so.5: version 'GLIBCPP_3.2.2' not found vidi Linux - Software 1 06-10-2004 09:26 AM
xauth: /lib/i686/libc.so.6: version 'GLIBC_2.3.2' not found yigald Linux - Newbie 0 02-20-2004 11:52 PM
version 'GLIBC_2.3' not found BadGuy Linux - Software 2 02-24-2003 07:50 AM


All times are GMT -5. The time now is 07:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration