LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ldap_bind: Invalid credentials (http://www.linuxquestions.org/questions/linux-newbie-8/ldap_bind-invalid-credentials-764898/)

olasamuel 10-27-2009 09:16 PM

Ldap_bind: Invalid credentials
 
Hi ALL,

I am new to Ldap and possibly linux. But I have been trying to use the Ladpadd of open ldap by following all the examples I found on the internet including the one that was given on the open ldap webpage but I keep on getting the same error which is ldap:bind invalid credential (49).

I have used the rootpw as secret and I have used the encrypted one using the slappasswd but I keep on getting the same error over and over again. Can somebody help me with this.

This is my slapd.conf file may be I am doing something wrong

#
###### SAMPLE 1 - SIMPLE DIRECTORY ############
#
# NOTES: inetorgperson picks up attributes and objectclasses
# from all three schemas
#
# NB: RH Linux schemas in /etc/openldap
#
include /usr/local/etc/openldap/schema/core.schema
include /usr/local/etc/openldap/schema/cosine.schema
include /usr/local/etc/openldap/schema/inetorgperson.schema

pidfile /var/run/slapd/slapd.pid
argsfile /var/run/slapd/slapd.args

access to *
by * read

# NO SECURITY - no access clause
# defaults to anonymous access for read
# only rootdn can write

# NO REFERRALS

# DON'T bother with ARGS file unless you feel strongly
# slapd scripts stop scripts need this to work
#pidfile /var/run/slapd.pid

# enable a lot of logging - we might need it
# but generates huge logs
loglevel -1

# MODULELOAD definitions
# not required (comment out) before version 2.3
moduleload back_bdb.la

# NO TLS-enabled connections

# backend definition not required

#######################################################################
# bdb database definitions
#
# replace example and com below with a suitable domain
#
# If you don't have a domain you can leave it since example.com
# is reserved for experimentation or change them to my and inc
#
#######################################################################
database bdb
suffix "dc=example,dc=com"
rootdn "cn=Manager,dc=example,dc=com"
rootpw {SSHA}W2yV9/xW15MSALHJlEPNAybcYvCNK1vr
directory /usr/local/var/openldap-data

##rootpw "{SHA}5en6G6MezRroT3XKqkdPOmY/BfQ="

bathory 10-28-2009 11:57 AM

What is the exact ldapadd command you use?
Try something like:
Code:

ldapadd -vx -D "cn=Manager,dc=example,dc=com" -W -f somefile.ldif


All times are GMT -5. The time now is 01:58 AM.