LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2013, 04:14 AM   #1
yashfire007
Member
 
Registered: Jan 2013
Distribution: CentOS, RHEL 6.4
Posts: 79

Rep: Reputation: Disabled
LDAP error:::Invalid credentials (49)


Dear all,

I have installed openldap in my system (CentOS 5.9)..

While adding an user in .ldif file and entered the password it is showing as the error
Enter LDAP Password:
ldap_bind: Invalid credentials (49)
.


[root@localhost openldap]# ldapsearch -x -b 'dc=unotechtest,dc=com' '(objectclass=*)'
# extended LDIF
#
# LDAPv3
# base <dc=unotechtest,dc=com> with scope subtree
# filter: (objectclass=*)
# requesting: ALL
#

# search result
search: 2
result: 32 No such object

# numResponses: 1



please suggest....



#vim /etc/openldap/slap.conf

database bdb
suffix "dc=unotechtest,dc=com"
rootdn "cn=admin,dc=unotechtest,dc=com"
# Cleartext passwords, especially for the rootdn, should
# be avoided. See slappasswd(8) and slapd.conf(5) for details.
# Use of strong authentication encouraged.
# rootpw secret
rootpw {SSHA}UpKdzwM4uocKMefZjJ+cnu/+91W3xAeL

Last edited by yashfire007; 05-18-2013 at 04:29 AM.
 
Old 05-19-2013, 07:11 PM   #2
gdizzle
Member
 
Registered: Jul 2012
Posts: 234

Rep: Reputation: Disabled
Show us your
Code:
ldapadd
or
Code:
ldapmodify
command syntax.

Make sure you have no whitespace or garbled characters in your ldif file.

Also to be sure reset your LDAP password, with
Code:
slappasswd
again and place the hash again in your
Code:
slapd.conf
and a
Code:
service slapd restart
to check
 
Old 05-19-2013, 10:23 PM   #3
gdizzle
Member
 
Registered: Jul 2012
Posts: 234

Rep: Reputation: Disabled
Actually:

Code:
vim /etc/openldap/slap.conf
Should be your database backend: e.g. /etc/openldap/slapd.d/olcDatabase={2}bdb.ldif


And this should have the

Code:
olcRootPW: {SSHA}UpKdzwM4uocKMefZjJ+cnu/+91W3xAeL
entry then :

Code:
service slapd restart

Now try the credentials
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] getting error while adding account in LDAP "ldap_bind: Invalid credentials (49)" csravi88 Linux - Server 6 10-14-2013 08:43 AM
Ldap error "ldap_sasl_interactive_bind_s: Invalid credentials (49)" knockout_artist Linux - Newbie 1 10-30-2009 04:56 PM
invalid credentials (LDAP) MonsieurLeBoulet Linux - Server 2 06-15-2009 04:50 AM
ldap invalid credentials finsh Linux - Server 4 12-12-2007 01:11 PM
ldap: invalid credentials johond Debian 0 12-14-2004 05:00 AM


All times are GMT -5. The time now is 10:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration