LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2006, 11:53 AM   #1
dhaus111
LQ Newbie
 
Registered: Feb 2006
Posts: 26

Rep: Reputation: 15
Lazy Mouse and Incooperative USB


I'm having a problem with my mouse since I upgraded my kernel to 2.6.17RC3. I needed to have the BCM43XX driver support so
I need to have this kernel working. Everything works pretty good except my mouse sometimes* doesn't work at boot. It works after I unplug the USB connector and plug it back in. It worked fine in the previous kernel's. Below is my dmesg output.



uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 500000
drivers/usb/input/hid-core.c: input irq status -75 received

#the prvious 2 lines were repeated about 1900 times and would keep going until I unplugged the mouse.

uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
usbhid 2-1:1.0: retrying intr urb
usbhid 2-1:1.1: retrying intr urb
uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
usbhid 2-1:1.0: retrying intr urb
usbhid 2-1:1.1: retrying intr urb
uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
uhci_hcd 0000:00:1d.0: uhci_result_common: failed with status 440000
hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0002
uhci_hcd 0000:00:1d.0: port 1 portsc 008a,00
hub 2-0:1.0: port 1, status 0100, change 0003, 12 Mb/s
usb 2-1: USB disconnect, address 2
usb 2-1: usb_disable_device nuking all URBs
usb 2-1: unregistering interface 2-1:1.0
usb 2-1:1.0: uevent
usb 2-1: unregistering interface 2-1:1.1
usb 2-1:1.1: uevent
usb 2-1: unregistering device
usb 2-1: uevent
hub 2-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x100
uhci_hcd 0000:00:1d.0: suspend_rh (auto-stop)
hub 1-0:1.0: state 7 ports 6 chg 0000 evt 0002
ehci_hcd 0000:00:1d.7: GetStatus port 1 status 001403 POWER sig=k CSC CONNECT
hub 1-0:1.0: port 1, status 0501, change 0001, 480 Mb/s
hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x501
ehci_hcd 0000:00:1d.7: port 1 low speed --> companion
uhci_hcd 0000:00:1d.0: wakeup_rh (auto-start)
ehci_hcd 0000:00:1d.7: GetStatus port 1 status 003002 POWER OWNER sig=se0 CSC
hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0002
uhci_hcd 0000:00:1d.0: port 1 portsc 01a3,00
hub 2-0:1.0: port 1, status 0301, change 0001, 1.5 Mb/s
hub 2-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x301
usb 2-1: new low speed USB device using uhci_hcd and address 3
usb 2-1: skipped 1 descriptor after interface
usb 2-1: skipped 1 descriptor after interface
usb 2-1: default language 0x0409
usb 2-1: new device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-1: Product: Microsoft Wireless Optical Desktop® 1.00
usb 2-1: Manufacturer: Microsoft
usb 2-1: uevent
usb 2-1: device is bus-powered
usb 2-1: configuration #1 chosen from 1 choice
usb 2-1: adding 2-1:1.0 (config #1, interface 0)
usb 2-1:1.0: uevent
usbhid 2-1:1.0: usb_probe_interface
usbhid 2-1:1.0: usb_probe_interface - got id
input: Microsoft Microsoft Wireless Optical Desktop® 1.00 as /class/input/input4
input: USB HID v1.11 Keyboard [Microsoft Microsoft Wireless Optical Desktop® 1.00] on usb-0000:00:1d.0-1
usb 2-1: adding 2-1:1.1 (config #1, interface 1)
usb 2-1:1.1: uevent
usbhid 2-1:1.1: usb_probe_interface
usbhid 2-1:1.1: usb_probe_interface - got id
input: Microsoft Microsoft Wireless Optical Desktop® 1.00 as /class/input/input5
input: USB HID v1.11 Mouse [Microsoft Microsoft Wireless Optical Desktop® 1.00] on usb-0000:00:1d.0-1
drivers/usb/core/inode.c: creating file '003'


any help would be appreciated
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic mouse pointer with wireless USB mouse jomax Fedora 0 01-04-2005 04:38 AM
Cannot change USB mouse back to PS/2 mouse under Mandrake 10 RedUcer Linux - Hardware 11 10-27-2004 02:40 AM
How do you configure to mouses, a laptop mouse and a Logitc USB Mouse dbratton Linux - Hardware 8 03-06-2004 06:02 PM
PS/2 mouse did not work after temp removal of USB mouse edwardp Linux - Hardware 1 09-06-2003 05:57 PM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 10:43 AM


All times are GMT -5. The time now is 10:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration