LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2012, 02:29 PM   #1
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Rep: Reputation: 31
Latex doesn't accept one accent on one word but accepts the same accent on othe words


Hi!
I get an error message than says:
Quote:
(/usr/share/texmf-texlive/tex/latex/psnfss/omsptm.fd)
! Missing $ inserted.
<inserted text>
$
l.8
la Pragmatique Sanction de 1438 réserve le tiers des bénéfices au.
I tested the whole thing and the word that makes problème is "". The word is in the middle of a normal sentence. I can see that the problem is the accent because if I change
Quote:
\usepackage[french]{babel}
\usepackage[latin1]{inputenc}
into
Quote:
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[frenchb]{babel}
I don't have the Problem anymore but I then have problems with my German words! Yes, I use different languages.
What I do not understand is: I haven't had any problem until now and the same word with the same accents appear in some other parts of the text and Latex doesn't make any trouble. So I don't understand what I am supposed to change.


The other strange thing is the output: the "é" become "@", "ê" become "Ã" and so on.
But this happens only on one tex file all other tex files from the same document (I use "include") work fine. What is the problem then?

I'd be thanksful for any advice.

Last edited by xpucto; 12-04-2012 at 02:41 PM.
 
Old 12-04-2012, 03:24 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
I can't help here. But since you speak German, I would recommend to post this to the newsgroup de.comp.text.tex which in my experience is the most knowledgeable LaTeX community around.

Markus

Last edited by markush; 12-04-2012 at 03:25 PM.
 
Old 12-04-2012, 05:03 PM   #3
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,385
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by xpucto View Post
Hi!
I get an error message than says:

I tested the whole thing and the word that makes problème is "". The word is in the middle of a normal sentence. I can see that the problem is the accent because if I change


into

I don't have the Problem anymore but I then have problems with my German words! Yes, I use different languages.
What I do not understand is: I haven't had any problem until now and the same word with the same accents appear in some other parts of the text and Latex doesn't make any trouble. So I don't understand what I am supposed to change.


The other strange thing is the output: the "é" become "@", "ê" become "Ã" and so on.
But this happens only on one tex file all other tex files from the same document (I use "include") work fine. What is the problem then?

I'd be thanksful for any advice.
I lokked it up in mir langenscheidt Dictionary-
If this word you menioned is used as an adverb it's heraus (not indoors)
Or drauBen (not at home) Other wise the last definition is nicht zu Hause (not alright)

I also looked up vowels and irregular verbs and didn't find ou'in the German dictionary either-
This wiki page says the translation in French
http://wiki.answers.com/Q/What_does_ou_la_la_mean
It can mean 'where is" on this webpage:
http://wiki.answers.com/Q/What_does_..._elle_nee_mean

Anyway; I tried; hope this helps
 
Old 12-05-2012, 02:28 AM   #4
xpucto
Member
 
Registered: Sep 2005
Location: Vienna, Austria
Distribution: Mint 13
Posts: 522

Original Poster
Rep: Reputation: 31
I found the reason: it is an encoding problem. My files are latin1 and vim has UTF-8 as default encoding. I hadn't any problem until now because I only worked on files that already existed, so vim could automatically recognize that it is latin1. As I created a new tex file, vim then switched into UTF-8 and I got all my problems.

I first tried to change the vim configuration in vimrc:
Quote:
set encoding=latin-1
But then vim wouldn't write any accent correctly anymore (things like "é" or "è"...). So I switched back to the default configuration. Then I converted my file in latin1:
Quote:
iconv -cs -f UTF-8 -t ISO-8859-1 file > newfile
It works fine now but I'm not satisfied with the solution because I don't want to have to convert each new file I create!

I will see my thread as solved though and create a new one for this new problem.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to remove accent characters kitonia Linux - Newbie 2 06-07-2013 05:43 PM
doing a cat on grave accent sjo Linux - Newbie 5 11-10-2010 02:09 AM
Accent on US keyboard Daniel Camara Linux - Hardware 4 02-24-2007 07:06 PM
Accent marks gilman824 Linux - Newbie 0 01-08-2006 05:38 PM
convert accent... os2 Programming 1 03-04-2005 10:03 AM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration