LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-08-2010, 06:05 PM   #1
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 270

Rep: Reputation: 27
Latest X doesn't work on my Thinkpad A30p


I upgraded to the new packages that came out in early March.

Since then I can't run X. If I use a depth greater than 8
my system locks up: blank screen, no response to keyboard
or mouse. If I use depth 8 most of the colors on the screen
are black, making it effectively unusable. I can exit with
ctl-alt-backspace though. I rolled back to the previous
versions of the X packages and have no problem. I use 'radeon'
video with the ATI drivers.

I can't start X with the VGA, VESA, or FBDEV drivers: it reports
'undefined symbol: resVgaShared'

I have a Thinkpad A30p with ATI Radeon Mobility M6 LY (AGP) (ChipID =
0x4c59). I build my own kernel. I'm on 2.6.33. I have 512 MB
RAM. All other software comes from Slackware packages and are up-to-date.
 
Old 03-08-2010, 07:38 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Please show us the full /var/log/Xorg.0.log file with the radeon driver.

Adam
 
Old 03-09-2010, 12:53 AM   #3
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 270

Original Poster
Rep: Reputation: 27
Xorg.0.log

When I start with depth>8 Xorg.0.log is random nonsense fetched from the disk. The most recent event it's the header from the package description for xset followed by a few hundred hex 0s. I don't have a copy when I start with depth=8. I would have to install a bunch of packages to get one. Should I?
 
Old 03-09-2010, 11:11 AM   #4
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Please post the log, it looks like you managed to download a testing version (There have been a few of these questions knocking about over the last few days) and will need to rollback
 
Old 03-09-2010, 11:31 PM   #5
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 270

Original Poster
Rep: Reputation: 27
Xorg.0.log for depth > 8

attached.
Attached Files
File Type: txt Xorg.0.log.txt (2.1 KB, 3 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does the latest gnucash really work?? Bill_Hwy Linux - Software 3 10-25-2007 12:23 PM
thinkpad trackpoint doesn't work aquilolumen Linux - Laptop and Netbook 3 07-27-2007 11:38 PM
Multiple Monitors on Thinkpad T43 w/ latest Ubuntu lupusyonderboy1 Linux - Hardware 1 09-24-2006 09:50 PM
xfce latest versione don't work... silvio2003 Slackware 2 03-15-2004 07:21 PM
Latest Java JRE doesn't seem to work kurt165749 Linux - Software 5 01-30-2004 01:37 PM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration