LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-05-2008, 02:56 PM   #1
santa001
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Rep: Reputation: 0
Unhappy Last 10% of uImage content is changing each time i build kernel image


Hi all,
I am working on SH4 architecture. I observed one strange thing. Each time i build my kernel image (uImage) the last 10% of the uImage content is changing. I compared uImages using diff command and with Beyond Compare tool, which i did using binary as well as rule based comparison with time stamp comparison disabled. I observed that every time when i build the kernel image the lower 10% of the uImage differ from the previously build uImage (build with in 20 min before the last one). Can any one help me to know the reason behind this behavior? I want to know more about the format of uImage and what exactly the lower 10% contains? i searched in various sites and referred the documentation of U-boot. But i dint get the reason for this behavior. I did the same comparison with vmlinux and vmlinux.bin and i observed that each time i build these vmlinux and vimlinux.bin they differ from the previous images (which i build 20 min before the last one ) by a max of 10 lines.
When i opened two vimlinux images (which i build with in a time gap of 20 min)using the readelf command. I observed that the last byte of some of the address are different in the two vmlinux images. why it is so?
Please help me to understand this.

Thanks,
Santa
 
Old 10-06-2008, 09:21 AM   #2
mk27
Member
 
Registered: Sep 2008
Distribution: fedora, gentoo, ubuntu
Posts: 148

Rep: Reputation: 23
I bet if you ask this question on http://cboard.cprogramming.com you will get an answer.

The kernel seems very complex to me, perhaps this is not surprising.
 
Old 10-20-2008, 08:08 AM   #3
santa001
LQ Newbie
 
Registered: Oct 2007
Posts: 2

Original Poster
Rep: Reputation: 0
i posted the questions in the forum http://cboard.cprogramming.com but dint get any solution. Can any one help me in to get the solution for this issue?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to build kernel RPM without rebuilding the whole thing every time JoeyAdams Fedora 2 06-22-2008 09:15 PM
Unable to build the NVIDIA kernel module(linux-image-2.6.21-2-686) Mathsniper Debian 5 08-04-2007 03:53 AM
OK, time to build my first kernel but... aquaboot Debian 13 12-29-2006 06:56 PM
Custom kernel image on custom slack build using CUSS nykey Slackware 2 07-15-2006 04:05 AM
image file of Debian 3.0 Woody base build on kernel 2.6 harlemno1 Linux - Software 1 03-09-2005 05:37 PM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration