LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2008, 03:48 PM   #1
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Rep: Reputation: 44
Unhappy Laptop kicking my butt ;(


Ladies & Gents,

Laptop 2 rbees 0

I am trying to set up Debian Lenny on a laptop and it seams to be winning. I did get a successful install and all that and it runs fine. But on two fronts it seams to be winning.

The most annoying first. Disabling the touchtap thing.

I have edited xorg.conf to contain the same info that is in my laptop which has that tap thing disabled yet this laptop refuses to yield to my changes. When I run 'synclient -l' I get "Can't access shared memory area. SHMConfig disabled?"

I double double quad checked that entry in xorg.conf and it is correct.

Option "SHMConfig" "on"

Form what I have read I have come to two conclusions. 1 the touchpad in this laptop is not compatible with the synaptics driver. So how do I identify this touch pad. I have not found any commands to run via google. lspci and lsusb don't show it. If I could identify it I might be able to find more relevant instruction via google.

2. The touchpad is not assigned the standard /dev/psaux device file. If this is the case then SMHConfig could not find it to talk to it. Hench, how do I find out where the system sees the touchpad so that I can change xorg.conf to reflect where it really is.

Pointers and or links would be much appreciated.

On to the second problem.

This laptop does not have built in wireless and so uses a Trendnet TEW-421PC :B1 card. I have followed the directions and installed the ndiswrapper and driver with success. I can activate the card with 'modprobe ndiswrapper' and all seams to be fine with it, but I can't get it to connect to the wireless service. For some reason it will not pick up an ip. This card is working fine in xp. I have made an entry in /etc/network/interfaces for my local wireless with no success. I have setup a config in the kde control panel for my local network yet nothing seams to be working.

KWiFiManager will scan and report that my wireless service is available but I can't connect to it. I seam to be missing something.

I have done the whole un/reinstall thingy with the driver and wrapper. I did see at one point that there is a native driver, alpha I think, but have not been able to locate that page again.

If anyone could help me with either one of these problems I am sure the owner would be very thankful.

Thanks for your assistance
 
Old 12-14-2008, 04:28 PM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
I don't know about the touchpad thing, but for the network:

1. what type wireless encryption are you using?
- none
- WEP (another name for 'none')
- WPA2

What's your interfaces entry look like? (without any secret information)
 
Old 12-14-2008, 04:34 PM   #3
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
none.

The area i live in is remote. In order for someone to piggy back onto me they would have to park out it the front yard where I could see them. On top of that at this time of the year with 2 feet of snow It would get quite cold for them.

So I have no need of encription. But thanks I hadn't thought of that. Any ideas are better than what I have at the moment.
 
Old 12-14-2008, 09:38 PM   #4
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
OK I have the touch tap thingy fixed. It seams that logging out does not completely kill the gui somehow. I rebooted the machine and of course I had some errors in xorg.conf relating to the 'screen' identifier and when I got those fixed and the gui booted up the that tap thingy was disabled.

I still have the problem with the wireless card though.
 
Old 12-14-2008, 11:06 PM   #5
marcia
LQ Newbie
 
Registered: Mar 2006
Posts: 18

Rep: Reputation: 1
Quote:
Originally Posted by rbees View Post
OK I have the touch tap thingy fixed. It seams that logging out does not completely kill the gui somehow. I rebooted the machine and of course I had some errors in xorg.conf relating to the 'screen' identifier and when I got those fixed and the gui booted up the that tap thingy was disabled.

I still have the problem with the wireless card though.
If you still need help on your wireless maybe this link will help:

https://help.ubuntu.com/community/Wi...1_(ndiswrapper)

I hope you get it working soon.

Sincerely,

Marcia
 
Old 12-14-2008, 11:17 PM   #6
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
I think I have discovered the reason behind that problem too. It seams that my wireless access point has died. I set a static ip on the card and it seamed to connect. Then the boy got home and he was not able to connect with his vista and he has been having toruble for the past few days. I reset the router then there was no wireless at all. In fact the blue indicator light does not even light.

Thanks to all.

I will look at that link though marcia
 
Old 12-15-2008, 08:42 PM   #7
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
Thanks Ladies & Gents,

There is one issue with the wireless card yet. That is gettin it to auto load the driver when I plug in the card. I have tried 'modprobe -m' I think it is and that came back as a depriceated option and the driver does not load unless I run 'modprobe ndiswrapper'. (The commands may not be right as I am not looking at them at the moment.) I plan on taking the laptop to a place where I can check to see if the wireless is actually working tomorrow.

Once again thanks.
 
Old 12-16-2008, 06:48 AM   #8
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
Unhappy still kicking my butt

So OK we are back to square 2. The score is now

laptop .75 rbees 1.25

Hear is where I am to recap.

The touchtap thingy required a correct xorg.conf file and a complete reboot of the xserver. Somehow just logging out through the kde K button does not accomplish this and a ctrl+alt+backspace or comp restart will.

The wireless. I have the ndisswrapper installed and it is working mostly correctly. If I set the /etc/network/interfaces entry for this card to be something like

# wlan
iface wlan0 inet static
allow hot-plug wlan0
address 192.168.0.20
netmask 255.255.255.0
wireless-essid NETGEAR

it appears to connects just fine. However I have no internet access. I am able to ping the router and other machines on my network.

If I set it to use dhcp I can't get it to connect to anything.

I still have two issues relating to the wireless.

1 I have to manually load the ndiswrapper. I need this to be automated

2 I have to use a static ip. This is beyond the owner and it to needs to be automated.

> modprobe ndiswrapper -m as instructed by the tutorial to auto-load the driver returns : invalid option -m

The file (both my laptop[using it for comparison using same os except 64] and the one I am working on) located in /etc/modporbe.d/ndiswrapper contains the line that the tutorial linked to above by marcia says that the 'modprobe ndiswrapper -m' command is suppose to put in it. However the dirver still does not autoload after a reboot

Don't know if it matters but this card is a removable pcmica card.

If I remove the card and reinsert it without a reboot this show up in dmesg | tail

(manually entered)
ADDRCONF(NETDEV_UP): wlan0: link is not ready

At the moment I am at a loss as to what to try next.

Thanks
 
Old 12-16-2008, 07:30 AM   #9
SkinnerC
Member
 
Registered: Dec 2007
Location: New England, USA
Distribution: Ubuntu 8.04 LTS, Slackware 12.2
Posts: 138
Blog Entries: 1

Rep: Reputation: 20
Make sure you have your default gateway set "route add default gw <address>" Then make sure you have your DNS servers set. (forget how to set them, sorry)
 
Old 12-16-2008, 12:28 PM   #10
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
Thanks SkinnerC

The router is the gateway. The other machines on my net are all working fine. Also if I plug in a network cable the Iceweasel works just fine.
 
Old 12-16-2008, 05:14 PM   #11
lakedude
Member
 
Registered: Jun 2005
Distribution: Puppy, Sabayon
Posts: 141

Rep: Reputation: 16
Are you running any kind of wireless security like WEP or WPA?

If so these need to be set up and it can get confusing.

For example I had trouble with my wireless because a setting got changed (somehow) from ascii to passphrase.

WEP has 3 options Hex, ASCII, and Passphrase, you gotta use the same kind on both ends or it don't work...
 
Old 12-16-2008, 05:19 PM   #12
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
none see post #3
 
Old 12-16-2008, 05:34 PM   #13
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 874

Original Poster
Rep: Reputation: 44
Ok, I came across this
Quote:
7. To load the module at boot time

Code:
> echo "ndiswrapper" >> /etc/modules.autoload.d/kernel-<version>
but it relates to FC3 and I don't have this in my file system. What is the Debian equivalent?

Scratch that above. All I had to do was add a line in /etc/modules that says ndiswrapper. Now the card is functioning automatically when plugged in, as far as the driver goes.

That leaves getting it to access my wireless network. I don't know if this is what is happening but this is how it appears to me. I am not a programmer so keep that in mind.

It seams to me that I have a package missing. What that package does is make the connection between the manual/auto configuration on the bottom and the gui on top.

Now I can't ping anything. I don't know what is different from before but...

So it seams that my manual config is not worth anything.

I connected a cable to it and yes it has access that way.
 
Old 12-16-2008, 05:55 PM   #14
pentode
Member
 
Registered: Dec 2005
Location: Oregon
Distribution: Debian Testing
Posts: 488

Rep: Reputation: 38
Are you sure DHCP is running on your router?

In your interfaces file, try putting auto wlan0 before the iface stanza and of course change static to dhcp - see if that helps. You'll to do an ifdown wlan0 and then ifup wlan0 to test it.

If that still doesn't work, try running dhclient from the command line (as root) after the ifup.
 
Old 12-16-2008, 06:13 PM   #15
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,090
Blog Entries: 3

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
well the touch pad can be set in bios to use the pad or ps2 or usb. cursers. or it can be set to all. while you in there set bios to none operating system no windows or what ever the new bios ask for anyway none os controlled. this let.s linux read the bios and load the irq. as the super user make sure your /etc/rc.d/rc.inet1 is set to executable. if it is not kde will never get it set in the control sent a auto dhcpcd will not happen at but. or it will not know to load the device. this is the same for /etc/rc.d/rc.inet2. while your in there the /etc/rc.d/rcinit1.conf make sure
itIPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes" <----.
DHCP_HOSTNAME[0]=""
if you have a ether card built in. the eth0 will be the ether card.
the next one eth1 this invokes the /etc/rc.d/rc.inet2.
so if you go to your /etc/rc.d/rc.m and read down you will see how it loads. theses are all bugs I have found out of the box on many different distro's. last but not least make sure your /usr/sbin/network_manager is also set to executable..
here is why I have found that during some crashes. like ndiswrappers hanging up it corrupts the rc.m file. put a little dot. <-- in front of the scripts. do not ask me how this happens. but it does.
Now if all that checks out. ifconfig ethX or wlanX what ever you have mine is ifconfig eth0 up then go type dmesg and read the out put.
Last but not least if you can find a linux driver for the card uses it.Build etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis 6 is kicking my butt, help! lenny45 MEPIS 10 09-07-2006 11:22 AM
Linux saved my butt again. /bin/bash LinuxQuestions.org Member Success Stories 2 10-01-2005 01:20 AM
Linux Scripting Issue Kicking my Butt !!! steve_f60 Linux - General 1 04-29-2005 05:00 PM
Samba Is Kicking My Butt!! pentax9380 Linux - Networking 7 09-28-2004 06:57 PM
My PC becoming a real sore in the butt schatoor General 2 12-26-2002 03:05 AM


All times are GMT -5. The time now is 02:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration