LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2011, 07:34 PM   #1
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Rep: Reputation: 4
Laptop's Screen Resolution changes after boot


Well, this has happened numerous times before when I had other distros, Ubuntu, Mint,and even Fedora, and then it didn't bother me because I had a GUI and a Desktop Manager, but now it's become a bit of a problem. I can read it okay, but I'd like to have it full resolution again. I'll post a link below

http://s1229.photobucket.com/albums/...op_Problem.jpg

Not easy to see what I typed, but I've tried adding "vga=773" to my kernel line but it didn't help. What do I do? *I hope I'm not being incoherent*
 
Old 06-02-2011, 07:36 PM   #2
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Another thing, I noticed that whenever UDev was doing it's thing, immediately afterwards the screen's resolution changed again. Is there a way to configure UDev?

---------- Post added 06-02-11 at 07:36 PM ----------

Also, I'm using Arch Linux
 
Old 06-02-2011, 11:35 PM   #3
tailinlinux
Member
 
Registered: Oct 2010
Location: Paudpod, Botolan, Zambales, Philippines
Distribution: Mandriva, Ubuntu, Mint, Open Suse, Meego
Posts: 390
Blog Entries: 3

Rep: Reputation: 25
Quote:
Originally Posted by theif519 View Post
Another thing, I noticed that whenever UDev was doing it's thing, immediately afterwards the screen's resolution changed again. Is there a way to configure UDev?

---------- Post added 06-02-11 at 07:36 PM ----------

Also, I'm using Arch Linux
Im a mandriva user maybe this one help.
Try to go in linux control panel (Configure your Computer)
type root password then enter.

go to hardware tab then select set up graphical server.
May be this one help also.
http://wiki.mandriva.com/en/Drakx11

Last edited by tailinlinux; 06-02-2011 at 11:39 PM.
 
0 members found this post helpful.
Old 06-03-2011, 02:46 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Quote:
Originally Posted by tailinlinux View Post
Im a mandriva user maybe this one help.
Try to go in linux control panel (Configure your Computer)
type root password then enter.

go to hardware tab then select set up graphical server.
May be this one help also.
http://wiki.mandriva.com/en/Drakx11
I doubt that the OP will find the Mandriva control panel in his Arch install.

@theif519: The behavior you describe is cause by kernel mode setting (KMS). You should be able to specify the resolution you want with a kernel parameter like video=1024x768.
Just add that to your kernel line in Grub.
 
Old 06-03-2011, 06:25 AM   #5
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by TobiSGD View Post
I doubt that the OP will find the Mandriva control panel in his Arch install.

@theif519: The behavior you describe is cause by kernel mode setting (KMS). You should be able to specify the resolution you want with a kernel parameter like video=1024x768.
Just add that to your kernel line in Grub.
Someone else told me to use vga=773 or whatever the specific number, but neither of them worked, neither did video. I think I can tell the resolution is too small because of the letters running on into the next line when on a Virtual Machine it doesn't. I added vga=773 to /boot/grub/menu.lst and it didn't work. I also tried video. Is there another file I have to configure? Also, it's not that much of a problem, but I want the cool bootsplash that Arch Linux has
 
Old 06-03-2011, 06:38 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Arch Linux doesn't have a boot splash by default, which bootsplash are you referring to?
 
Old 06-03-2011, 10:39 AM   #7
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,945

Rep: Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693
Quote:
Originally Posted by tailinlinux View Post
Im a mandriva user maybe this one help. Try to go in linux control panel (Configure your Computer) type root password then enter.

go to hardware tab then select set up graphical server. May be this one help also.
http://wiki.mandriva.com/en/Drakx11
Why would posting information for Mandriva, help someone that doesn't use Mandriva, but uses Arch instead????. If you're going to respond to a post, read the OP's question and situation, and answer with something that has relevance to the situation.

OP, why don't you try removing the "vga=xxx" from the boot totally?? I know on my screen (openSUSE 11.4), it is vga=1314, but if I remove it, it changes my boot resolution only. Doesn't affect my X settings.
 
Old 06-03-2011, 03:26 PM   #8
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
http://www.youtube.com/watch?v=RjTTl...feature=relmfu

That one, but is it only available for Virtual Machines only? The one I installed in the Virtual Machine a while back looked a lot different from the current one on my laptop. Is it possible to get the arch logo or the tux penguin logo like that one?
 
Old 06-03-2011, 03:43 PM   #9
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Sorry, but I didn't see a boot splash in that video.
 
Old 06-03-2011, 04:04 PM   #10
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by TobiSGD View Post
Sorry, but I didn't see a boot splash in that video.
Maybe I'm confusing it with something else. The Google Image Searchs I'm looking at show many different things, but what I want is the penguin/Arch Logo whenever I boot. At 1:44 it shows the logo at the top. I want to know how to get it. It shows up in a Virtual Machine, but I can't get it to show up on my laptop *Could also be the resolution problems as well*
 
Old 06-03-2011, 04:24 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
This logo shows up if you use a framebuffer console. I have set up my workstation (with LILO as bootloader) to change to the native resolution of my monitor (1680x1050x24) at boot, using the parameter vga=0x0369. This way I get one penguin per core at boot time. I don't know if this will also work with grub, but I think it should.
 
Old 06-03-2011, 09:04 PM   #12
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by TobiSGD View Post
This logo shows up if you use a framebuffer console. I have set up my workstation (with LILO as bootloader) to change to the native resolution of my monitor (1680x1050x24) at boot, using the parameter vga=0x0369. This way I get one penguin per core at boot time. I don't know if this will also work with grub, but I think it should.
None of the VGA codes work at all... Well, not saying I've tried EVERY single combination, but after I add it to the end of the kernel line, it still doesn't change the frame buffer. It's not a huge deal, but it does get annoying though, and I'd love to figure out how to fix.
 
Old 06-04-2011, 05:17 AM   #13
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
I have tried this on my laptop, it doesn't work. Seems to be dependent on the video-card, since I have almost identical setups on my machines.
 
Old 06-04-2011, 08:57 PM   #14
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
I'm sorry guys, I feel like an idiot. Instead of adding it to the Kernel line, I added it to the init.d instead, and since the resolution was originally so low on it, I thought the kernel line ran on into the next. I fixed it, though. Thanks for the advice guys. vga=773 worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop screen resolution jahanzeb1982 Linux - Hardware 1 03-17-2008 08:21 AM
Laptop Screen Resolution Munk *BSD 3 06-02-2006 08:45 AM
IBM G40 Laptop + SuSE 9.2 = Boot screen resolution problem lamberpeople Linux - Software 6 01-06-2005 10:50 AM
IBM G40 Laptop + SuSE 9.2 = Boot screen resolution problem lamberpeople Linux - Hardware 0 12-29-2004 12:03 PM
laptop screen resolution zeppedled Linux - Laptop and Netbook 1 12-09-2004 08:08 AM


All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration