LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2006, 02:36 PM   #1
SoCalNewbie
LQ Newbie
 
Registered: Nov 2004
Posts: 13

Rep: Reputation: 0
Question Kubuntu Timezone Problem


Hello,

I've been trying to convince kubuntu that Los Angeles is my local timezone. If I set the computer to LA timezone, the clock gets the time right, but displays Los Angeles instead of the date below the time. If I switch to "local timezone" it displays the time and date the way I want it to, but it uses the UTC time, ignoring the fact that I don't live in Greenwich, England.

Can Anybody help me convince my computer that I live where I actually live?

I'm using kubuntu 5.10, in case that matters.

Regards,
SoCalNewbie
 
Old 03-25-2006, 08:16 AM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
You need to reconfigure your timezone. You can do this by right clicking on the clock and then selecting to reconfigure time. If you make the right changes, your local time should always be set to LA.
 
Old 03-25-2006, 11:46 AM   #3
SoCalNewbie
LQ Newbie
 
Registered: Nov 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I don't have a "reconfigure time". I've tried selecting "adjust date & Time" which (after raising my hopes by making me input the root password) doesn't work. I change the local timezone to PST (Pacific Standard Time) which is correct, and it changes the clock in that window, but the clock at the bottom corner never changes off UTC. When I close the window, the clock stays on UTC. When I re-open the window, it's back on UTC.

Can somebody please help me?

SoCalNewbie
 
Old 03-25-2006, 01:00 PM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Your system time seems to be set to UTC so you need to reconfigure the system time from the "adjust date & time". When you have set the system time to PST, right click on the clock -> Show timezone -> local. If thats ticked, then only the local timezone is shown on the clock.

Quote:
I've tried selecting "adjust date & Time" which (after raising my hopes by making me input the root password) doesn't work
What exactly does not work? Give precise details.
 
Old 04-02-2006, 01:00 PM   #5
SoCalNewbie
LQ Newbie
 
Registered: Nov 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I select "adjust date & time", then I give the root password, then I select America/Los Angeles as the time zone and hit apply. The "Current Timezone: " changes to PDT, which is right. Then I hit Okay. I go to the clock, right click and select "choose timezone" and "local timezone". It changes to show UCT, not PDT.

When I open up the "adjust date & time" again, it shows UCT in the "Current Timezone: " box.

So I tell it to change the time zone, and it ignores me.

SoCalNewbie
 
Old 04-02-2006, 03:38 PM   #6
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Solus
Posts: 2,254

Rep: Reputation: 47
The reason for this is because your hardware clock is set to UTC, so selecting 'local time zone" shows that. You can reconfigure that, but I don't know for sure which config file contains the time zone data in Ubuntu/Debian systems. If you can find the file, change "UTC" to "Localtime" and it should work for you the way you want.
 
Old 04-02-2006, 06:12 PM   #7
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Either use tzselect or setup a symbolic link that points from /etc/localtime to the time zone file in /usr/share/zoneinfo. Also add a TZ variable to the /etc/profile. Most setups use the symbolic link method which makes it easier to read what time zone the system is actually using. Also read the man pages on tzset and hwclock.

The above information is for every Linux distribution assuming these utilities are installed.
 
Old 04-02-2006, 10:07 PM   #8
SoCalNewbie
LQ Newbie
 
Registered: Nov 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Thank You Electo, it worked like a charm.

I am now a happy little kubuntu-er once more.


SoCalNewbie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
timezone problem Mathsniper Linux - Newbie 9 06-08-2005 01:55 PM
Evolution 2 / Multisync / WinCE Timezone problem on sync david.skinner Linux - Software 0 04-29-2005 10:58 PM
timezone problem Lord Zoltar Linux - General 5 09-13-2004 11:38 PM
Timezone funny problem. ]un]ie Solaris / OpenSolaris 10 07-21-2004 11:08 PM
How do I get rid of UTC (timezone problem) Baldrick65 Mandriva 2 10-02-2003 08:48 AM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration