LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-14-2007, 09:30 AM   #1
minchina
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Rep: Reputation: 0
Kubuntu only 640x480


I have kubuntu 6.06 running on a via epia SP13000 with openchrome drivers. Everything works great except for the resolution. I am only running the s-video out (although I don't think that it matters) and I can't get resolution above 640x480. In general I wouldn't care about this, but the resolution is so small that many programs bleed off the bottom of the screen. Since they don't have scroll bars, it makes them more or less unusable. This board runs higher resolution in windows, and it has also run a higher resolution when I was running a different distro on it, so I am pretty sure that it is technically capable of it.

How can I fix this resolution problem? The display tab in system settings only has the 640x480 option on the slider bar. My xorg.conf file looks like a fairly standard kubuntu one as far as I can tell, but I have tacked it onto the bottom of this post. What are my options?

Thanks

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "via"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "HP vs17"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "HP vs17"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 02-14-2007, 10:13 AM   #2
redwing57
Member
 
Registered: Jan 2005
Location: Yorktown, VA
Distribution: CentOS, Ubuntu, MEPIS
Posts: 30

Rep: Reputation: 15
I think you should fill in some info on the monitor in xorg.conf. From the HP support pages, for your monitor:

Recommended resolution 1280 x 1024 @ 60Hz
Horizontal scan range 30-83 KHz
Vertical scan range 50-76 Hz

Back up xorg.conf (cp xorg.conf xorg.conf.bk1).
Modify xorg.conf, the monitor section, as follows:

Section "Monitor"
Identifier "HP vs17"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

This will allow acceptable video modes for your monitor, and prevent your system from eliminating video resolutions that don't result in acceptable values for HorizSync and VertRefresh.

Since you want 1280 x 1024, I would eliminate all other modes from xorg.conf, but this isn't necessary. Since your DefaultDepth is 24, you really only need a short entry in the Screen section, like this:

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "HP vs17"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

The above is the minimum entry for this section. You should first try leaving the screen section alone. If you need to do further troubleshooting, or just like simplicity, you can use the minimal screen section above.

This should result in your system running in 1280 x 1024 resolution at the proper colordepth. If the picture is not correctly sized or located for your screen, use the monitor controls to adjust it. If that fails, you may need to add a modeline to xorg.conf. If that seems to be the case, you will need more help.

Rob
 
Old 02-14-2007, 06:15 PM   #3
minchina
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Rob,

Thank you so much for the specific help. I followed your directions and there was a change, but it did not quite get there. First, I just changed the monior section as per your instructions. That resulted in just about the same resolution, except widescreen and slightly overscanned (spilling over the edge of the TV, which is actually very good for me). When I tried to change the resolution in kubuntu's systen setting -> monitor screen the slider had disappeared and it was replaceed with an error message that the "module Display could not be loaded" and then some information about possible reasons - both referring to old modules.

I decided to ignore that and make your second change to the 'screen' section. Upon reboot, that appeared to have no impact whatsoever.

So right now I have a slightly better situation (widescreen), but still the resolution that is so low that many programs bleed off the screen. I have attached my new xorg.conf file to the end of this. Any ideas of how to fix this, or on where to look for more information, would be greatly appreciated.

thanks

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "via"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "HP vs17"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "HP vs17"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
 
Old 02-14-2007, 08:06 PM   #4
IndyGunFreak
Senior Member
 
Registered: Aug 2003
Location: Indpls
Distribution: Desktop- Debian Lenny, Laptops- Ubuntu 8.10, Debian Lenny UMPC- Ubuntu 8.10
Posts: 1,297

Rep: Reputation: 55
http://www.linuxquestions.org/questi...d.php?t=495248

Follow Redeye2's instructions..

IGF
 
Old 02-15-2007, 03:22 AM   #5
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Your first post:
Quote:
I am only running the s-video out
Your second post:
Quote:
spilling over the edge of the TV
Woah!
I don't think an ordinary TV is capable of 1280 x 1024 resolution! You should use the VGA output of your card, and a monitor capable of 1280 x 1024.
 
Old 02-15-2007, 05:13 AM   #6
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
i never had to change the document with the resolutions-i just rebooted once and it kinda re-appeared. but i think redeye2 was the one who actually got it working.
 
Old 02-15-2007, 02:14 PM   #7
redwing57
Member
 
Registered: Jan 2005
Location: Yorktown, VA
Distribution: CentOS, Ubuntu, MEPIS
Posts: 30

Rep: Reputation: 15
Tredegar has a good point. I was too interested in your xorg.conf to think about the hardware factors.

Your xorg.conf is set up for a specific monitor with the right capability (1280x1024), so an important question is whether your connection and video card can support the mode. Furthermore, if you are not using the HP monitor that xorg.conf is set up for, there is a risk of damaging another monitor if the horizontal and vertical frequency ranges exceed its capability.

Rob
 
Old 02-15-2007, 04:08 PM   #8
minchina
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Original Poster
Rep: Reputation: 0
I may not have been clear earlier. When I originally set up this computer, I used a monitor that happened to be sitting around the house. That monitor is now long gone (many states away). The only way that I interface with the computer is by connecting the S-video output to a tv. The TV is 16:9. Before I made the change, kubuntu outputted a 4:3 image. After the change above, it changed to a 16:9 (I can tell because things that required scrolling in the kicker bar to see - the 'K' or the trash can - can now be seen at the same time). But it was not just regulate 16:9, instead it was slightly magnified so 3-5% of the desktop was not on the screen. This is not a big deal at all to me. In fact it actually may have some benefits.

However, when it changed to 16:9 it kept basically the same resolution (I have no idea what the numbers change to in order to make 640x480 widescreen, but the take home message is that most programs are too large to be on the desktop). I want to scale up (down?) the resolution so that when a program window launches it is all on the desktop - as it would be when you changed a desktop from 640x480 to 1280x1020 - icons get smaller and the like.

The hardware is a via epia mini card that has drivers that are within adept but are not installable by default.


Sorry for the length of this post, but I would really love to get this fixed. To sum up:

I don't care what monitor kubuntu thinks it is outputting to, because there is no monitor. All I want to do is make the desktop larger by increasing the resolution of what is being output by way of the s-video output. If this is not controlled in xorg.conf, please let me know if there is something else that I can throw up here that might help.

Thank you again for all of the help.
 
Old 02-15-2007, 09:02 PM   #9
redwing57
Member
 
Registered: Jan 2005
Location: Yorktown, VA
Distribution: CentOS, Ubuntu, MEPIS
Posts: 30

Rep: Reputation: 15
Oh... Well, I was on the wrong track, and I don't have an easy answer. It will require some experimentation to find out how to get the best picture out of your tube.

Refering to your xorg.conf, all those modes should be available for you to switch to. Specifically,
"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
Since I just fix up my xorg.conf for one mode and leave it alone, I haven't done any switching in a long time. I have a dim memory of a hot key combination that you could do it quickly with, and you should be able to do it with the gui. So here is a suggestion, switch modes until you find the one you think is your best chance for getting a picture like you want. It may be a lower resolution mode that matches the scan rate of the TV. Then if possible adjust the picture to fit the screen using the controls on the TV. If that isn't an option, I don't have another idea for you.

Perhaps reading this will help:
http://www.extron.com/technology/arc...sp?id=scanconv

Good luck,
Rob
 
Old 02-16-2007, 12:08 PM   #10
tredegar
Guru
 
Registered: May 2003
Location: London, UK
Distribution: Ubuntu 10.04, mostly
Posts: 6,007

Rep: Reputation: 366Reputation: 366Reputation: 366Reputation: 366
Quote:
I have a dim memory of a hot key combination that you could do it quickly with
<CTRL><ALT> and either <+> or <-> on the numeric pad will cycle forwards / backwards through the resolutions listed in xorg.conf

Edit: I don't know if this applies to the S-video output as well.

Last edited by tredegar; 02-16-2007 at 12:09 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
640x480! kilikk Linux - Laptop and Netbook 3 02-06-2006 06:22 AM
640x480 HEEEEEEELP ton31 Linux - Newbie 0 01-05-2005 01:32 PM
Not going above 640x480 pal_no_1 Fedora 2 12-30-2004 10:58 PM
Slakcware @ 640x480??? tranquil.au Slackware 4 01-09-2004 01:38 AM
640x480? carlgulliver100 Linux - Newbie 34 12-17-2003 04:14 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration