LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2008, 10:21 AM   #1
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Rep: Reputation: 16
Knows how to set/update the time permanently?


I've install Debian and noticed that the time is a not correct. Setting it in KDE will change it, but the time will again be incorrect upon reboot.


Time in Malaysia is +8 hours.Thinking that the timezone setting is not properly configured, I set it to Singapore which is in the same time zone, the "problem" still persist.


Time out from konsole
Quote:
date -u
Mon Apr 7 23:04:10 UTC 2008

date
Tue Apr 8 07:04:11 SGT 2008
Time indicate in website http://www.worldtimeserver.com/current_time_in_UTC.aspx
Quote:
2:04 PM
Monday, April 07, 2008
Standard Time +0000 UTC
Any knows how to set/update the time permanently?
 
Old 04-07-2008, 10:46 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,117

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
There are some things you can do. First check the hardware clock setting in your BIOS. It is maintained by an onboard battery on most systems. If this is an older machine, and it is drifting, it may be time to replace the battery.

Second, install NTP. It is available for most distos. Here is a sample of what to install.

http://linuxreviews.org/howtos/ntp/

Once installed, your system can be configured to sync with an atomic clock. Most governments have one. Of course you need internet connectivity for it to sync.
 
Old 04-07-2008, 11:02 AM   #3
lazylogic
Member
 
Registered: Aug 2006
Posts: 151

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by camorri View Post
There are some things you can do. First check the hardware clock setting in your BIOS. It is maintained by an onboard battery on most systems. If this is an older machine, and it is drifting, it may be time to replace the battery.

Second, install NTP. It is available for most distos. Here is a sample of what to install.

http://linuxreviews.org/howtos/ntp/

Once installed, your system can be configured to sync with an atomic clock. Most governments have one. Of course you need internet connectivity for it to sync.
Noted.

As I am using a brand new computer, the battery isn't the issue.

Any other option besides syncing with NTP?
 
Old 04-07-2008, 11:10 AM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,117

Rep: Reputation: 494Reputation: 494Reputation: 494Reputation: 494Reputation: 494
I have had several problems with the time staying to local time, with several versions of Mandrake and Mandriva. Things went silly with day light savings here in North America. NTP has fixed all my issues.

I know there were some code fixes, so make sure you are up to date. Beyond that, no other suggestions, other than make sure your BIOS hardware clock is set right, and not drifting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set path? permanently AVD_ZM Ubuntu 5 03-06-2007 05:41 PM
set a background permanently in fluxbox Vincent Slackware 10 01-16-2004 01:32 PM
How to set path permanently for a particular user Sifvion Slackware 14 10-16-2002 12:02 PM
How to set PATH permanently chandhru Linux - Newbie 3 09-24-2002 01:43 AM
bsetbg, set background permanently nutshell Linux - General 2 06-13-2002 04:07 AM


All times are GMT -5. The time now is 03:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration