-   Linux - Newbie (
-   -   Knoppix - "poor man's"/98se ...dualboot? (same hd) (

OceanDead 04-28-2004 04:28 PM

Knoppix - "poor man's"/98se ...dualboot? (same hd)
Not only am I a total newb when it comes to Linux, I'm also an idiot. After downloading and burning a Knoppix live CD, I checked it out and I'm really liking this whole Linux "thing" ;) . I liked it so much that, after a day or so of messing around with it and getting the display to function correctly and the sound to work, I decided to do a poor man's install. After partitioning the drive I copied the Knoppix folder from the CD to my D: (hda5) partition...then I could boot it using a bootfloppy or the CD.

Anyway, I decided that I didn't want to have to use the CD or the bootfloppy in order to boot I decided to make it a dualboot. Unfortunately, loadlin.exe could not boot knoppix, the kernel panicked, the system crashed...and my config.sys file went back to what it was before I changed it (by itself !).

Setup, info and questions follow:

Toshiba 2100CDT
AMD K6-2 @ 400MHz
4GB HD - Two partitions, both FAT32
C: (hda1) partition - 2GB - Windows 98se + apps, etc.
D: (hda5) partition - 2GB - Knoppix folder, swap file, configs, \boot\ dir with bootfloppy contents + loadlin.exe and loadlin.par

Ok, so I wanted to make it a dualboot system I changed the 98se config.sys file to let me choose which one I wanted to boot.

The modified config.sys file looked like this:
MenuItem=Win98, Windows 98 (second edition)
MenuItem=KNX, Knoppix 3.3 (debian based linux)

Shell=D:\boot\loadlin.exe @D:\boot\loadlin.par


loadlin.par looked like this:
d:\boot\vmlinuz initrd=c:\linux\miniroot.gz myconfig=scan
#1: Did I leave anything out of loadlin.par that should be there? Such as "ramdisk_size=#" and/or "init=/etc/init" (after vmlinuz)
1a: If not, how do I make a dualboot using my config.sys file with the poor man's install (and 98se)?

#2: Even though I have Knoppix running off the HD (after using the cd to boot it, or a bootfloppy) seems to run slower than when I just run it off of the cd. Why?
2a: Is it because I have the swap file on the same partition as the Knoppix folder?
2b: Is it because it's a FAT32 partition?

When replying please keep in mind that I'm still basically an idiot m$ user any instructions and how to's need to be detailed and written in the simplest terms.

Thank you in advance for your help, your patience and your time.


OceanDead 04-29-2004 12:07 PM

I decided to start over. I deleted the contents of my d: partition then re-copied Knoppix to d:\knoppix\. I then placed loadlin.exe, loadlin.par, vmlinuz and miniroot.gz into the root dir of d:\

The config.sys file looks pretty much as it did (except to reflect the location change of loadlin and loadlin.par).

the loadlin.par now looks like this:
d:\vmlinuz ramdisk_size=45760 init=/etc/init initrd=d:\miniroot.gz myconfig=scan

However, I keep getting the same error(s).
FAT: bogus logical sector size # (the number changes each time)
Kernel panic: VFS: Unable to mount root fs on 01:01

What am I doing wrong here?

homey 04-29-2004 12:22 PM

It may be a lot less bother if you remove those attempts, boot up with the knoppix cdrom and run the command knx-hdinstall . That will give you an oportunity to create the partitions and install the linux boot loader.

noobtesting 04-29-2004 12:38 PM

I would have to agree with Homey on that matter. If I were you I would boot off the CD and then open a console and switch to root then run knoppix-installer and follow the instructions from there.

OceanDead 04-29-2004 03:50 PM

I don't have enough space to do a real install :(
I'm just gonna have to deal with the boot floppy/cd. Oh well, I tried.

3.1416 05-01-2004 02:42 PM

Here's where to find the installation procedure.

There are a few others that you can find by doing a Google search for 'knoppix hard drive'

All times are GMT -5. The time now is 03:10 PM.