LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2006, 03:24 PM   #1
alienmagic
Member
 
Registered: Feb 2006
Distribution: Slackware 10.2, (2.6.16.16), FC 5
Posts: 109

Rep: Reputation: 15
KMix auto loads after logon. How can I stop it?


I just installed SuSe 10, and so far I like it better than Red Hat, which is what i'm most famiar with.

For some reason, if I sign out and back in using KDE, or if I login using KDE after a reboot, KMix always autostarts. How do I keep this from happening?
 
Old 02-26-2006, 04:11 PM   #2
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
Hum? curious.
I'd have thought that YaST would have some way of switching it off. Though I'm thinking along the lines, that normally, if you shut down a service/app and then end the session, kde usually remembers that and only starts the services that you had open/available at the shutdown/end session.

Can't say for certain because I'm using Mandriva, and I'd normally enable services in the MCC - there might be something for you to look at in the kde control centre though, or in YaST.

Sorry I can't be more specific.

regards

john
 
Old 02-27-2006, 09:18 AM   #3
alienmagic
Member
 
Registered: Feb 2006
Distribution: Slackware 10.2, (2.6.16.16), FC 5
Posts: 109

Original Poster
Rep: Reputation: 15
Hmm, I've looked through both the control center and in YaST, but so far I haven't found a setting for autostarting KMix.
 
Old 02-27-2006, 12:25 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
You may have KDE set to start with "Restore previous session", or even "Restore previously saved session", when the previous session had Kmix running.

Check this at K->Configure your desktop->Components->Session Manager. Either set it to "Start with an empty session", or "Restore manually saved session". If the latter, close down apps you do not want at login, start apps you do want running when you login, then do K->Save Session. Then logout & back in again.

That should fix it.

HTH
 
Old 02-27-2006, 06:56 PM   #5
alienmagic
Member
 
Registered: Feb 2006
Distribution: Slackware 10.2, (2.6.16.16), FC 5
Posts: 109

Original Poster
Rep: Reputation: 15
That was exactly what I was looking for. Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kmix PCM volume problem (auto. set to 0 at every new track) Grisha8 Linux - Software 2 12-01-2005 03:48 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 01:02 PM
Mouse and Keyboard stop working when X loads BrigitteT Linux - General 7 04-12-2004 02:21 AM
Setting up auto-loads ifm Linux - Software 3 06-09-2002 06:41 PM
Auto Logon and Auto Run OKCHelpDesk Linux - General 0 05-03-2002 03:02 PM


All times are GMT -5. The time now is 01:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration