LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-03-2006, 02:17 PM   #1
itsjustarumour
LQ Newbie
 
Registered: May 2006
Location: UK
Distribution: Ubuntu, Mint, Fedora
Posts: 19

Rep: Reputation: 0
Smile KMail and Evolution problems


Hello Ladies and Gentlemen,

I'm a total Linux newbie and this is my first post, so please bear with me if I don't sound too clever with these things! But I converted from Win XP a few days back and I'm having some trouble with the email programs Kmail and Evolution.

First things first, heres what I'm running:

Suse Linux 10.1 with KDE 3.4.2
Kmail 1.8.2
Evolution 2.4.0
Athlon 64 3400 on Socket 754, Gigabyte K8NS Pro motherboard,1GB RAM, Nvidia 6800LE
2 MB ADSL connection with USR9108 gateway (ethernet cable, not hooked up to wireless)

OK, my first issue is with Kmail. I've got everything set up and working fine to poll my POP3 account (******@gmail.com) My only niggle is with the message headers – the message default is to include “All Headers”, so it inserts text like this at the top of each email:


X-Gmail-Received: 90e878b939392c8974e3f3c7bb6cdf1d16d9e4f2
Received: by 10.65.225.20 with HTTP; Mon, 1 May 2006 19:57:04 -0700 (PDT)
Message-ID: <2937e3400605011957q330c0736pcb26a6e788eba25b@mail.gmail.com>
Date: Tue, 2 May 2006 03:57:04 +0100
From: "Ian ******" <***********@gmail.com>
To: blahblahblah@googlemail.com
Subject:
MIME-Version: 1.0
Content-Type: multipart/alternative;
* boundary="----=_Part_30047_8751399.1146538624716"
Delivered-To: ********@gmail.com
Status: R
X-Status: NC
X-KMail-EncryptionState:
X-KMail-SignatureState:
X-KMail-MDN-Sent:

I find this a bit annoying as I want to show the “Fancy Headers” as standard. I know I can open an individual message and go to “View”, “Headers”, “Fancy Headers” to set this manually, but is there any way I can just select this as a default so it automatically applies to all messages?

My second problem is with Evolution. I've set this up with the same settings as Kmail to poll my POP3 Gmail account. I can send OK, but not receive. When I click on the “Send/Receive” button, I get the “Send/Receive Mail” dialogue box, which shows:

Server: pop.gmail.com, Type: pop
Waiting...
Server: smtp.gmail.com, Type: smtp
Complete.

After a while this times out, and I get this message:

“Error while fetching mail.
Could not connect to pop.gmail.com.
Connection timed out.”

I've tried deleting the account and re-adding it, also going into “File”, “Forget passwords” to reset these. Could the problem be something to do with stored passwords, or maybe authentication types? I've tried all the options - “Login”, “Password”, APOP, CRAM-MD5 etc. Maybe the Gmail account is timing out, but if so then why does it work perfectly in Kmail but not Evolution? I've tried 3 different walk-throughs from various “Help sites” for setting up Evolution but none of them seem to cover this problem.

Anyway, if anyone out there can help or offer any words of wisdom I would be very grateful!

Best wishes to all,

Ian
 
Old 05-04-2006, 07:39 AM   #2
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
Quote:
Originally Posted by itsjustarumour
Hello Ladies and Gentlemen,

I'm a total Linux newbie and this is my first post, so please bear with me if I don't sound too clever with these things!
No worries -- I was one once too.

Quote:
OK, my first issue is with Kmail. My only niggle is with the message headers ? the message default is to include "All Headers"... I find this a bit annoying as I want to show the "Fancy Headers" as standard. I know I can open an individual message and go to "View", "Headers", "Fancy Headers" to set this manually, but is there any way I can just select this as a default so it automatically applies to all messages?
I use KMail every day, and as far as I know, if you change the View/Headers option from the menus on the main window, it will keep that setting for all messages from then on. Separate message windows that you already have open won't be affected immediately, but any opened subsequently will be


I'm afraid I don't really know Evolution all that well, so I can't answer your other question. (I tried it a few years ago, when it was still fairly new, and it mangled my mail folders, so I never went back)
 
Old 05-04-2006, 09:31 AM   #3
notiones
Member
 
Registered: Feb 2005
Location: Kansas
Distribution: RHEL 4, FC6, Ubuntu 6.06
Posts: 46

Rep: Reputation: 15
Try disabling POP3 extensions in Evolution. This would be my best guess without further details.
 
Old 05-04-2006, 10:35 AM   #4
Freestone
Member
 
Registered: Jan 2003
Location: Brighton, Michigan
Distribution: FC5
Posts: 114

Rep: Reputation: 15
itsjustarumour,

I may be able to help with one issue and thats receiving mail. I have a gmail account and what worked for me is this:
Make sure that your POP server port is set to 995.
Make sure that your SMTP outgoing port is set to 587.

I use Thunderbird for my gmail account and it took me a few days. If you're unsure, log into your gmail accout via web browser,
click 'Settings' in the upper right corner of the page once your in your inbox, on the next page in the center towards the top, click
'Forwarding and POP' and Number 3 in the POP Download section will give detailed instructions for different email clients.

Hope that helps. Good luck.
 
Old 05-04-2006, 08:12 PM   #5
itsjustarumour
LQ Newbie
 
Registered: May 2006
Location: UK
Distribution: Ubuntu, Mint, Fedora
Posts: 19

Original Poster
Rep: Reputation: 0
Hi Spudley,


Quote:
Originally Posted by Spudley
I use KMail every day, and as far as I know, if you change the View/Headers option from the menus on the main window, it will keep that setting for all messages from then on. Separate message windows that you already have open won't be affected immediately, but any opened subsequently will be
Thanks for taking the time to reply to my post. Yes, thats the way I thought it would work, seemed logical - but it definitely wasn't holding on to my settings. HOWEVER having read your reply and gone back for another tinker, I've found a strange workaround that cured my own problem! In the option to configure the main toolbar with different buttons, there was a button I could add called "Fancy Headers". I added this, depressed the button and all the headers became "fancy", just like I wanted. But heres the strange bit! I deleted the button afterwards, and the headers all still stayed as "fancy" - and not only that, but from now on whatever type of header I select in View/Headers, it sets it as default and keeps that setting just you said it should. A bit odd - but anyway its working now so I'm happy!

Just need to get Evolution working properly now!

Thanks again,

Ian
 
Old 05-04-2006, 08:19 PM   #6
itsjustarumour
LQ Newbie
 
Registered: May 2006
Location: UK
Distribution: Ubuntu, Mint, Fedora
Posts: 19

Original Poster
Rep: Reputation: 0
Hi Notiones,

Quote:
Originally Posted by notiones
Try disabling POP3 extensions in Evolution. This would be my best guess without further details.

Thanks for the reply. I've just tried what you suggested... and it didn't work!

Thanks anyway.

Ian
 
Old 05-04-2006, 08:25 PM   #7
itsjustarumour
LQ Newbie
 
Registered: May 2006
Location: UK
Distribution: Ubuntu, Mint, Fedora
Posts: 19

Original Poster
Rep: Reputation: 0
Hi Freestone,

Quote:
Originally Posted by Freestone
itsjustarumour,

I may be able to help with one issue and thats receiving mail. I have a gmail account and what worked for me is this:
Make sure that your POP server port is set to 995.
Make sure that your SMTP outgoing port is set to 587.

I use Thunderbird for my gmail account and it took me a few days. If you're unsure, log into your gmail accout via web browser,
click 'Settings' in the upper right corner of the page once your in your inbox, on the next page in the center towards the top, click
'Forwarding and POP' and Number 3 in the POP Download section will give detailed instructions for different email clients.

Hope that helps. Good luck.
Thanks for the help - you've fixed my problem! I got the correct settings from the Gmail site on your advice. It wasn't actually the port numbers that were wrong, but I had "Use Secure Connection" set to "Whenever Possible" rather than "Always". For the record, if anyone else gets the same problem the settings for Gmail/Evolution from the site are:

Incoming Mail (POP3) Server - requires SSL: pop.gmail.com
Use SSL: Yes
Port: 995
Outgoing Mail (SMTP) Server - requires TLS: smtp.gmail.com (use authentication)
Use Authentication: Yes
Use STARTTLS: Yes (some clients call this SSL)
Port: 465 or 587
Account Name: your Gmail username (including '@gmail.com')
Email Address: your full Gmail email address (username@gmail.com)
Password: your Gmail password

Anyway, thanks again (and to everyone else who read my post). I now have 2 fine new email clients to play with!

Ian
 
Old 05-04-2006, 08:48 PM   #8
Freestone
Member
 
Registered: Jan 2003
Location: Brighton, Michigan
Distribution: FC5
Posts: 114

Rep: Reputation: 15
itsjustarumour,

Sorry I didn't help you the way I thought I would. I was rather verbose in my response to your post.
I totally forgot about SSl and TSL settings.

Glad you've got 2 email clients to play with now.
Have fun!
 
Old 08-28-2006, 02:37 PM   #9
Garey
LQ Newbie
 
Registered: Aug 2006
Posts: 1

Rep: Reputation: 0
I tried all smtp settings suggested and ended up having to use the 'Check what the server supports' link and ended up with:

host: smtp.gmail.com
port: 25 (not ideal I know but it works!)
security: TLS + PLAIN

Now I can receive AND send gmail with KMail

K.
 
  


Reply

Tags
evolution, pop3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Converting from Evolution to KMail cmckay Linux - Software 11 09-10-2010 11:18 AM
Connecting Kmail/Evolution to Exchange? matux Linux - Software 4 12-08-2005 11:14 PM
evolution to kmail? anacharya Linux - Software 1 06-04-2005 10:56 PM
Reading Hotmail with Evolution/Kmail astrosapiens Linux - Software 3 03-19-2004 03:38 PM
how to uninstall kmail and install evolution santasballz Linux - Newbie 1 03-01-2004 08:05 PM


All times are GMT -5. The time now is 05:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration