LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-17-2006, 12:38 AM   #1
leiw
Member
 
Registered: Apr 2006
Posts: 131

Rep: Reputation: 15
Klamav: Qt error during configure


Centos 4.3, Klamav-0.37

#rpm -qa | grep qt
qt-3.3.3-10.RHEL4
qt-devel-3.3.3-10.RHEL4


The following error during ./configure
..........................
..........................
checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!

I don't know what dose that mean .

Thanks
 
Old 12-17-2006, 07:25 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
Find the location of qt.h on your system. Then:
$ ./configure --with-qt-prefix=

An example:

# find /usr/lib/. -name "qt.h"
/usr/lib/./qt3/include/qt.h

$ ./configure --with-qt-prefix=/usr/lib/qt3
 
Old 12-17-2006, 10:58 PM   #3
leiw
Member
 
Registered: Apr 2006
Posts: 131

Original Poster
Rep: Reputation: 15
Thank for your reply,

After ./configure can run smoothly, but have another problem

in "make" :


klamav_run.cpp:20: error: `setEnableExternalBrowser' was not declared in this scope
klamav_run.cpp:20: warning: unused variable 'setEnableExternalBrowser'
In file included from klamav_run.cpp:46:
klamav_run.moc:101:26: warning: no newline at end of file
make[3]: *** [klamav_run.o] Error 1
make[3]: Leaving directory `/root/klamav-0.37-source/klamav-0.37/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/klamav-0.37-source/klamav-0.37/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/klamav-0.37-source/klamav-0.37'
make: *** [all] Error 2


The setEnableExternalBrowser mean I need have a firefox during

make process ?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure fails with: libz... configure: error: not found. erpe Linux - Software 17 10-11-2006 05:56 PM
KlamAv drake_101 Linux - Software 7 01-06-2006 09:32 PM
Error when installing KlamAV Thakowbbery Linux - Software 0 10-13-2005 12:00 PM
KlamAV ./configure Error keithieopia Linux - Software 1 03-21-2005 05:06 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration