LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-03-2007, 03:53 PM   #1
Mustafa^Qasim
Member
 
Registered: Dec 2005
Location: Lahore, PK
Distribution: Fedora 14
Posts: 105

Rep: Reputation: 16
Kingston Memory Stick Filesystem


M facing trouble in mounting my Kingston 256MB Flash memory. after pluging it i can see it through fdisk .

[root@mustu ~]# fdisk -l /dev/sda

Disk /dev/sda: 512 MB, 512753664 bytes
16 heads, 63 sectors/track, 993 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 994 500704+ b W95 FAT32
Partition 1 has different physical/logical endings:
phys=(992, 15, 63) logical=(993, 8, 24)

but when i try to mount it ask for filesystem .... when i ghave vfat it didn't accept it....

[root@mustu ~]# mount /dev/sda /mnt/flash -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


..what to do now..??? It works fine in Windows....
 
Old 06-03-2007, 04:45 PM   #2
Mustafa^Qasim
Member
 
Registered: Dec 2005
Location: Lahore, PK
Distribution: Fedora 14
Posts: 105

Original Poster
Rep: Reputation: 16
Resolved

OK .. My problem is resolved .... my FC6 has auto installed it ....
 
Old 06-03-2007, 05:54 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
FYI: You need to mount the filesystem on the partition.
mount /dev/sda1 /mnt/flash -t vfat
Use sda1 instead of sda.
I would also recommend some options so that you have access:
-o fmask=0111,dmask=0000,noatime

Or for exclusive access:
-o uid=<yourusername>,gid=<yourgroup>,fmask=0117,dmask=0007,noatime

The noatime option means that the access times aren't updated, which can be important for memory sticks. However for a vfat partition that may not be necessary because these access times may not exist on the physical filesystem.

Since the system automounted it for you you might want to look at the options the system used:
mount
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB memory, Compact Flash, Memory Stick energiza Linux - Hardware 2 08-22-2006 09:29 PM
Missing memory in USB stick, flash memory, removable hd etc bamboo_spider Linux - Newbie 3 06-14-2006 05:39 PM
mount does not detect a vfat filesystem in my usb stick ernesto_cgf Linux - Hardware 3 12-07-2005 07:19 AM
Philips Key008 USB camera/memory stick filesystem problem Iskendar Linux - Hardware 0 07-13-2004 08:41 AM
memory stick / CF memory card reader X-dazed Linux - Newbie 1 01-21-2003 12:32 AM


All times are GMT -5. The time now is 01:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration