LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Kingston Memory Stick Filesystem (http://www.linuxquestions.org/questions/linux-newbie-8/kingston-memory-stick-filesystem-558880/)

Mustafa^Qasim 06-03-2007 03:53 PM

Kingston Memory Stick Filesystem
 
M facing trouble in mounting my Kingston 256MB Flash memory. after pluging it i can see it through fdisk .

[root@mustu ~]# fdisk -l /dev/sda

Disk /dev/sda: 512 MB, 512753664 bytes
16 heads, 63 sectors/track, 993 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 994 500704+ b W95 FAT32
Partition 1 has different physical/logical endings:
phys=(992, 15, 63) logical=(993, 8, 24)

but when i try to mount it ask for filesystem .... when i ghave vfat it didn't accept it....

[root@mustu ~]# mount /dev/sda /mnt/flash -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so


..what to do now..??? It works fine in Windows....

Mustafa^Qasim 06-03-2007 04:45 PM

Resolved
 
OK .. My problem is resolved .... my FC6 has auto installed it ....

jschiwal 06-03-2007 05:54 PM

FYI: You need to mount the filesystem on the partition.
mount /dev/sda1 /mnt/flash -t vfat
Use sda1 instead of sda.
I would also recommend some options so that you have access:
-o fmask=0111,dmask=0000,noatime

Or for exclusive access:
-o uid=<yourusername>,gid=<yourgroup>,fmask=0117,dmask=0007,noatime

The noatime option means that the access times aren't updated, which can be important for memory sticks. However for a vfat partition that may not be necessary because these access times may not exist on the physical filesystem.

Since the system automounted it for you you might want to look at the options the system used:
mount


All times are GMT -5. The time now is 12:39 AM.