LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2003, 10:16 PM   #1
jabberwock486
Member
 
Registered: Jul 2003
Posts: 74

Rep: Reputation: 15
killing X


i need to shut down X so i can install the nvidia drivers. How do I shut down X and go into the prompt( like shutting down win98 into MS-DOS mode)
note i DONT want to change boot files and stuff like that.
Also could I force the file to install?

please I need help with this. If u dot have any real information Dont say anything. I hate BS so dont use it on me.

I am useing suse 8.2
 
Old 07-02-2003, 10:55 PM   #2
pifly
LQ Newbie
 
Registered: Jul 2003
Distribution: Redhat 9.0
Posts: 4

Rep: Reputation: 0
I installed the same drivers no more than 10 minutes ago.
I killed X by editing my /etc/inittab file
There was an option there with the default loader was the X option
I changed it to single user mode and followed the instructions from the NVIDIA README file to a T.
Once I had everything installed, I changed the option in the inittab file back to the X option and rebooted by giving the command `shutdown -r now`
After the computer restarted, everything worked A-ok.

I honestly don't know if there's an easier way to do it, but this worked well for me.

pifly
 
Old 07-02-2003, 11:47 PM   #3
pbaumgar
Member
 
Registered: Feb 2003
Distribution: gentoo, ubuntu
Posts: 43

Rep: Reputation: 15
You can boot into single user mode without editing any files. I use RH and GRUB. Here's a link for a howto:

http://www.redhat.com/docs/manuals/l...ng-single.html
 
Old 07-03-2003, 03:57 AM   #4
cmoloney
Member
 
Registered: May 2003
Distribution: RedHat 8.0
Posts: 30

Rep: Reputation: 15
try ctl+alt+F1
 
Old 07-03-2003, 04:08 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,023

Rep: Reputation: Disabled
Quote:
Originally posted by cmoloney
try ctl+alt+F1
That gives you just a terminal without X, but doesn't shut down X. You can either do CTRL+ALT+Backspace (kills X) or use the normal SuSE shutdown button, which brings you to the login menu in the first step. There you find (on SuSE 8.1) a drop down menu which lets you stop X. This is also the level (KDE shut down orderly) where you try the CTRL+ALT+Backspace.

After that you can do your tricks...

Last edited by JZL240I-U; 07-03-2003 at 06:53 AM.
 
Old 07-03-2003, 06:43 AM   #6
LizardMan
Member
 
Registered: Jun 2003
Location: California, USA
Distribution: Zenwalk & Slackware
Posts: 42

Rep: Reputation: 15
Correct me if Im wrong, but wouldnt typing "init 3" in a console window do the trick also? Im not sure if that kills X or just has the same result as Ctrl+Alt+F1 (terminal with no X, but X still running)
 
Old 07-03-2003, 06:53 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,023

Rep: Reputation: Disabled
Dunno. You could find out, using a terminal (shell window) running X (or KDE) typing that command. Remember that KDE is then not properly shut down (possible loss of new changes).
 
Old 09-10-2003, 11:59 AM   #8
dvs
LQ Newbie
 
Registered: Sep 2003
Distribution: SuSE 8.2, Mandrake 9.1 and Gentoo
Posts: 11

Rep: Reputation: 0
Easy way to not load X

The way that I installed the nVidea drivers under SuSE 8.2 was by booting the "failsafe" option in Grub. Make sure that you have all of the required packages installed to install the drivers also. After I had logged in as root, I ran the .run file using the "sh" command and it was installed but not enabled. I still needed to run "sax2" and enable the hardware 3D acceleration option. After saving quitting "sax2" I logged in under my normal user account and typed “startx” and was up and running (and gamming). If you are running Mandrake or a few other distributions you will need to edit the “XF86Config” or “XF86Config-4” file as directed in the nVidea install guid.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Killing a process by its name rabeea Linux - Networking 3 03-17-2005 05:30 AM
This is killing me UncleEricB Linux - Networking 2 02-01-2005 09:41 PM
Killing the checksums antares Linux - Networking 1 08-21-2004 08:53 AM
killing synaptic ehdwuld Linux - Software 6 10-07-2003 03:38 PM
Killing X ? sp0t Linux - Newbie 7 08-17-2002 07:53 AM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration