LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-28-2007, 05:45 PM   #1
khairilthegreat
LQ Newbie
 
Registered: Nov 2006
Distribution: Kubuntu
Posts: 25

Rep: Reputation: 15
kill program which use /dev/dsp


I got another OS in my ubuntu dapper box using VMware. My problem is sometimes VMware cannot produce sound because /dev/dsp is busy. Strange thing is I don't play any sound at that time in my ubuntu box. I've disable artsd from Ubuntu system settings.

I tried this command

# ps -A | grep /dev/dsp

and

# fuser /dev/dsp

but this two command doesn't show any process using /dev/dsp.

What command should I type to find and kill any process that is using /dev/dsp so VMWare can use that device.
 
Old 07-28-2007, 06:32 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531
You can use
Code:
lsof|grep "/dev/dsp"
 
Old 07-29-2007, 05:03 AM   #3
khairilthegreat
LQ Newbie
 
Registered: Nov 2006
Distribution: Kubuntu
Posts: 25

Original Poster
Rep: Reputation: 15
i'ts no work

I've try the command

# lsof|grep "/dev/dsp"

But its not showing me what process using /dev/dsp.

Actually what do I expect with the

# fuser /dev/dsp
and
# lsof|grep "/dev/dsp"

I read that it will show which process using /dev/dsp. I try to play xmms in my box but this two command show nothing.
 
Old 07-29-2007, 09:42 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,598

Rep: Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531Reputation: 1531
If lsof shows nothing, then there is nothing that uses /dev/dsp. So your problem has something to do with the way vmware uses /dev/dsp. Perhaps this post will help you.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no /dev/dsp nor /dev/mixer on 2.6.9 amuro_ray Slackware 9 08-03-2009 03:54 PM
/dev/audio, /dev/dsp and /dev/mixer missing in Debian Etch 1337_penguin Debian 2 04-11-2007 12:33 PM
devfs and devfsd don't create /dev/dsp or /dev/sound/dsp ? behmjose Linux - Hardware 2 10-02-2006 01:27 PM
No /dev/dsp /dev/mixer etc david.skinner Linux - Software 2 05-19-2005 03:28 AM
kill artsd PERMINANTLY! (i dont use it, but it hogs /dev/dsp) qwijibow Linux - Software 7 04-23-2004 08:38 AM


All times are GMT -5. The time now is 09:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration