LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2007, 03:17 PM   #1
linux_geek
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Rep: Reputation: 0
keys interchanged!!


hi friends,

I had been using suse 10.1(gnome) and due to some problem yesterday i installed suse 10.2(kde). everything is running fine but some of the keys got interchanged, like @ and " . its fine as long as i can locate these but the real problem is that my PIPE is missing because of which i am not able to do any useful shell programing. instead of PIPE , i get ~ . so what may be the problem, is there any settings to be done to restore the original ones back?
 
Old 03-14-2007, 04:03 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Go to the KDE Control Center and select Regional & Accessibility --> Keyboard layout and ensure the correct layout for your country is selected. Sounds lie you have a US keyboard selected right now.
 
Old 03-15-2007, 01:19 PM   #3
linux_geek
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
hi.....
im still facing the same problem. i've tried all the settings in the control centre as u told me.
 
Old 03-15-2007, 02:52 PM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
Which country are you in? To give you an example of what I do:
  1. Go to the keyboard settings as above
  2. Check the box against "Enable keyboard layouts"
  3. Highlight the default US entry to the right hand side
  4. Click <<Remove
  5. Select UK from the left hand side
  6. Click >>Add
    [Optional Step]Log off and log on again
  7. Success!
 
Old 03-17-2007, 02:18 AM   #5
linux_geek
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
hi,
its not working either. i tried all the options. is there any other alternatives like someone told me that u can make use of ascii values to get it printed. please let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Keys in bind -p or inputrc, what do these keys translate to? muha Linux - Newbie 0 03-06-2006 06:52 AM
YUM requires public keys, how do I get public keys? GNUROCKS Linux - Newbie 3 05-29-2005 08:50 AM
with keys is the keys that change languages? AKAKAK Fedora 2 01-25-2005 10:11 AM
Configuring SSH to accept only keys (already have keys) fr0st Linux - Security 3 11-04-2003 03:31 AM
FN keys... joel112 Linux - Laptop and Netbook 0 10-25-2003 11:12 AM


All times are GMT -5. The time now is 09:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration