LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-20-2005, 09:02 PM   #1
jamiem
LQ Newbie
 
Registered: Jun 2005
Location: California
Distribution: SuSE 8.2 Personal
Posts: 15

Rep: Reputation: 0
Keyboard is swapping keys


I have a big question and a little question.

1. I'm running Linux SuSE 8.2 Personal and am having problems with my keyboard. It is set to English (US) which is correct, but some keys are swapped.

For instance Z & Y are swapped every time I start the OS. I have to go into the control center and accept the English setting if I wish for the keyboard to correct the aforementioned, and I also have problems with the following keys at each startup as well:

-
/
.


All that I have to do is accept the English setting and everything works fine - it's just that I shouldn't have to, right?

2. Also, what does "X" stand for? I see it everywhere - does it simply refer to a version of an OS?

Thanks,

Jamie
 
Old 06-20-2005, 09:29 PM   #2
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
I'm not sure about the first question, but "X" stands for "X Window System," and is, in simple terms, the graphical part of Linux. It can be XFree86 or X.Org.
 
Old 06-20-2005, 10:48 PM   #3
jamiem
LQ Newbie
 
Registered: Jun 2005
Location: California
Distribution: SuSE 8.2 Personal
Posts: 15

Original Poster
Rep: Reputation: 0
I see, thanks jrdioko.

And thanks for the links as well!

Now if I can just figure this keyboard issue out...

Jamie

Last edited by jamiem; 06-20-2005 at 10:49 PM.
 
Old 06-20-2005, 11:18 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
is it happening only in X, or in the terminal before starting X, too?

and what desktop are you using? kde i believe has some sort of keyboard configuration applet. there should be a flag in the taskbar system tray, you can right click and select a default keyboard. there's probably something similar in gnome. it sounds like what you have now is defaulting to german or something.

if you're not using kde/gnome, you can change the default keyboard in /etc/X11/xorg.conf. where it says Option "XkbLayout" "[country]", change the country to "us". not 100% sure b/c i've never had the problem, but that ought to do it, i think.
 
Old 06-21-2005, 06:22 PM   #5
jamiem
LQ Newbie
 
Registered: Jun 2005
Location: California
Distribution: SuSE 8.2 Personal
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by synaptical
is it happening only in X, or in the terminal before starting X, too?

and what desktop are you using? kde i believe has some sort of keyboard configuration applet. there should be a flag in the taskbar system tray, you can right click and select a default keyboard. there's probably something similar in gnome. it sounds like what you have now is defaulting to german or something.
Thanks for the reply synaptical.

I will have to check to see if it is starting at the terminal.

I'm using the kde desktop. I don't see a flag in the taskbar, but I do see an icon with a British flag and a keyboard in YaST. That is where I always accept the English (US) layout. Funny thing is, I don't have to select it, I simply have to accept it - and then the keys behave normally. But it's really becoming a pain... having to do it every time I start SuSE.

I cannot find a fix for it at the SuSE site either. I may have to reinstall as I did have some issues with this particular install that had previously never occurred.

Jamie
 
Old 06-22-2005, 07:47 AM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
Quote:
Originally posted by jamiem
Thanks for the reply synaptical.

I will have to check to see if it is starting at the terminal.

I'm using the kde desktop. I don't see a flag in the taskbar, but I do see an icon with a British flag and a keyboard in YaST. That is where I always accept the English (US) layout. Funny thing is, I don't have to select it, I simply have to accept it - and then the keys behave normally. But it's really becoming a pain... having to do it every time I start SuSE.

I cannot find a fix for it at the SuSE site either. I may have to reinstall as I did have some issues with this particular install that had previously never occurred.

Jamie
there might be a yast configuration file with that option, i've never used yast. but a reinstall seems extreme to fix such a problem.

in kde, if there's no tray icon, then you can check in the control center applet. there are options somewhere in there to set both the default keyboard and the country. setting one or the other might fix your problem. i think they're under "regional" or "accessibility." you can also right click the taskbar and add the keyboard applet and access that part of it from there if you want.

sorry for such poor KDE advice from an XFCE4 user. you'd think with all the KDE users and how everyone raves about KDE someone would have a good answer for your question, but sometimes you just have to be patient and hope someone will chime in. i really hope you don't think you have to reinstall your whole system just to fix a problem like that, though.

gl
 
Old 06-23-2005, 07:41 PM   #7
jamiem
LQ Newbie
 
Registered: Jun 2005
Location: California
Distribution: SuSE 8.2 Personal
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by synaptical


in kde, if there's no tray icon, then you can check in the control center applet. there are options somewhere in there to set both the default keyboard and the country. setting one or the other might fix your problem. i think they're under "regional" or "accessibility." you can also right click the taskbar and add the keyboard applet and access that part of it from there if you want.

gl
Once again, you were correct in your instructions - thank you.

The keys that were swapped still occur in the terminal, but are okay once SuSE loads. I have a 108-Key keyboard whose manufacturer isn't supported - that explains the swap. I wish that I could find a solution that would fix the problem at the terminal as well, but I won't get picky.

Thanks again!

Jamie
 
Old 06-23-2005, 08:50 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
after doing a little research, i think the command to use is the loadkeys command (man loadkeys). so for example, if you wanted to switch to US qwerty keyboard, the command would be:

# loadkeys /usr/share/kbd/keymaps/i386/qwerty/us.map.gz

or it seems that with most of the common keymaps, you can just do loadkeys and the country code: loadkeys us, loadkeys uk, etc. i tried it with loadkeys dk and it changed to danish (it looked like), so that should work.


p.s. note that's only for in the console. in X it seems to be overridden by xorg.conf. but if you already have X/KDE going to US (or whatever you want) that should do it.

Last edited by synaptical; 06-23-2005 at 08:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some keys in keyboard do NOT work bmccorm2 Linux - Newbie 1 11-08-2005 10:16 AM
Keyboard and it's shortcut keys ZakuSage Linux - Hardware 4 06-13-2005 02:11 PM
swapping " and @ keys on mac keyboard alcibiades Linux - Newbie 3 04-23-2005 08:03 AM
mapping keyboard keys fedetxf Linux - Newbie 1 03-23-2004 08:49 PM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 09:36 PM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration