LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-30-2004, 03:55 PM   #1
janosh
LQ Newbie
 
Registered: Sep 2003
Location: Oslo, Norway
Distribution: Debian
Posts: 8

Rep: Reputation: 0
Question Keyboard dead on console login - Gentoo new install (FIXED)


I've just installed Gentoo Linux, and at last everything seems to work. But i have one major problem. When my home configured kernel is done loading, and alle the INIT scripts have returned [OK]. I'm given a login promt, but my keyboard is dead.

I'm using Gento Kernel 2.6.7 - r11.
It's posible that i havent selected my keyboard driver, but i've walked trough menuconfig several times, and cannot find annything wrong.
(are there any generic PS/2 keybord drivers? i haven't found any )

My keyboard is PS/2
And it works when i run Knoppix Live CD with their 2.6 kernel.

The problem could also be in some of the init scripts, so I'm wondering if i can safely remove all scripts, and still get to login? Or are there some scripts that i need to get to the login prompt? (I will of course backup all scripts before i remove them)

Last edited by janosh; 07-31-2004 at 05:21 AM.
 
Old 07-30-2004, 04:38 PM   #2
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
Have you tried single-user boot (run-level 1). Does your kbd work in X?
 
Old 07-31-2004, 05:09 AM   #3
janosh
LQ Newbie
 
Registered: Sep 2003
Location: Oslo, Norway
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
I haven't tried single-user, i will do that.
I can't login, so i can't get to x
 
Old 07-31-2004, 05:20 AM   #4
janosh
LQ Newbie
 
Registered: Sep 2003
Location: Oslo, Norway
Distribution: Debian
Posts: 8

Original Poster
Rep: Reputation: 0
I found the solution.

I have an Phoenix-Award BIOS, and in the Keyboard and Mouse USB settings, I had to switch from BIOS to OS.
I don't know why, but i works now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Ubuntu on Toshiba Satellite A70 keyboard dead warnetgm Linux - Laptop and Netbook 3 09-08-2005 08:39 AM
dead MS keyboard under X 4.3 [SID] kev^ Linux - General 1 04-25-2004 01:46 PM
keyboard dead with kernel 2.6.4 matrixfx Linux - Hardware 2 03-26-2004 11:06 PM
gentoo install, change keyboard layout mvbv-linux Linux - Distributions 2 12-12-2003 12:11 AM
cant login (keyboard dead) fwee Slackware 8 10-13-2003 12:40 AM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration