LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-15-2005, 06:14 PM   #1
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Rep: Reputation: 0
Keyboard and moust not working in linux after configure sound card


Hi, I have a computer running windows 2000 server and linux red hat. The first problem is the sound card is not detect could not hear. But when I start in both windows and linux, the keyboard and mouse is working properly. After I have download the driver of sound card and configure the sound working properly in windows, then I restart in linux, at the login screen I could not type anything. My keyboard and mouse could not type or movement. But I remember that the first boot to linux after I configure the sound in windows, linux ask me to remove or keep the configuration of the PS/2 mouse. Then I choose keep the configuration. Can anyone give me a good solution to restore to the original state of linux??? Because I need to learn linux everyday. For windows everything is working very fine (sound, keyboard, mouse...). But the problem is occure in linux. Can any one help me???
 
Old 01-15-2005, 06:42 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
Re: Keyboard and moust not working in linux after configure sound card

1. what kind of sound card is it?
2. does the sound work in linux?
3. my mice have always worked with IMPS/2, you might try changing that in /etc/xorg.conf
 
Old 01-15-2005, 08:01 PM   #3
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you very much for your reply, here are my answer:

1. No, the sound card is not working. My sound card is ESS Technology P1868. Both in windows and linux. So I turn off my computer and take out my sound card, then clean it and plug it again. After that I go to windows and it still not working, so I try to upgrade the driver for my sound card. After that it is working (i can listen to the music...). When I restart to linux, it face the problem as the previous post.

2. Before the keyboard and mouse is working properly, the sound card is not working. It also display some error message relate to my sound, but I did not write it down (sorry).

3. My mouse is PS/2. Both keyboard and mouse are working very well in windows, but could not working in linux. I think there would be make change to any configuration file in linux to make it work properly, but I don't know how to do that. I'm new to redhat linux. I could remember that when redhat boot up it ask me to press Y to check the system integrity. When I press Y i found that my keyboard is still working. The system is running it check, but when it boot to redhat login interface, my keyboard and mouse is not working. I don't know who to fix the problem. I don't know how to chage the /etc/xorg.conf because i could not type anything at the logging screen of linux. If it could not then, it is fine because I could use the console and know some operation to do.......??????

Any suggestion would be great to save me from this problem.
 
Old 01-15-2005, 10:03 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
okay, i'm going to assume you know nothing and start from there:

for the sound card to work in linux, you have to have the chipset drivers compiled into the kernel. you'll have to find out what are the right kernel options for that sound card and build them in if they're not already (i did a google, but i didn't come up with anything for ESS Technology P1868). installing the drivers in windows won't make it work in linux (sorry if that's an insult, it kind of looked like you were thinking that, but if not no offense intended ).

if i read you right that you can type at the console, do "xf86config" and reset your mouse and keyboard options. if you don't want to mess up an existing config file, you can either temporarily move it, e.g.:

mv /etc/X11/XF86Config /etc/X11/XF86Config.orig

generate the new one with the xf86config command, then add the stuff you want into the old one and then move the old one back again, overwriting the new one. or else you could edit it by hand if you know what to add.

to edit it by hand and test changing the mouse, go to /etc/X11, open XF86Config with vim, then change the PS/2 option in the mouse section to IMPS/2 and see if that works (even if a mouse is PS/2, IMPS/2 can work ). check the keyboard entry too, it should say something like:
Code:
Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"
if it doesn't say that, post what's in the whole section (and the mouse section, too) so we can sort it out.

Last edited by synaptical; 01-15-2005 at 10:08 PM.
 
Old 01-16-2005, 12:00 AM   #5
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
Ok, thank you very much for your information. But I wonder one point. My redhat linux when it boot up it go to the graphical user interface that allow us to login (here is the place that I could not type anything). Does any other way that I could login to the linux (redhat) using text mode??? Because in text mode, I could type my keyboard normally. I know some command in linux to copy, move, check the file content...

Like in windows 98 if you don't press key F8 you will boot to graphic mode. But if you press key F8 you will have an opportunity to boot with difference method. That include boot using the command prompt also. Here is the question that I want to know, does linux allow use to press any key to the text mode???

Last edited by 012633023; 01-16-2005 at 12:06 AM.
 
Old 01-16-2005, 01:10 PM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
Quote:
Originally posted by 012633023
Ok, thank you very much for your information. But I wonder one point. My redhat linux when it boot up it go to the graphical user interface that allow us to login (here is the place that I could not type anything). Does any other way that I could login to the linux (redhat) using text mode??? Because in text mode, I could type my keyboard normally. I know some command in linux to copy, move, check the file content...

Like in windows 98 if you don't press key F8 you will boot to graphic mode. But if you press key F8 you will have an opportunity to boot with difference method. That include boot using the command prompt also. Here is the question that I want to know, does linux allow use to press any key to the text mode???
i could be wrong, but i don't think it does. what you need to do is edit your /etc/inittab file to change the runlevel. you could boot to knoppix to access the file, i think you should be able to edit it from there. knoppix should mount your partitions, or just mount them yourself. then go to /etc (not the knoppix /etc, but your mounted system /etc) and open the inittab file with vim. you should see a line that says:

id:x:initdefault:

where x is the runlevel you are set to (probably 5). change that to 3 ( id:3:initdefault: ) and reboot to your system (dont' forget to take out the knoppix CD - i always forget ). that should boot you to a terminal where you can run the xf86config.

post back on your progress. i'll keep looking for what sound card option to use, but i'm not having any luck so far. you might have to try to get more info on your card. maybe there's something printed on it that could be useful. or if worse comes to worse, boot into windows and see if you can find any more info there, with device manager, sisoft sandra, pctree, etc.
 
Old 01-17-2005, 02:51 AM   #7
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you very much for your help. Well, I many CD of linux that could run from the CDROM. Such as knoppix, mandrak move, suse 9.2 (both kde and gnome), morphix, slax and also UNIX such as NetBSD, FreeBSD and FrezzyBSD. But what I prefer is SLAX linux. I like to work it with.

Back to your suggestion, I have on more thing to ask you. When I come to the terminal command in I could change the directory to /etc. But you told me to go to /etc of redhat on the hard drive. But this piont I don't know, I see /etc but I don't know this folder is on the CDROM or on the hard drive. Could you tell me how to change the directory from the CDROM to red hat linux partition??? If I could past this obstacle, then I will proceed the task as you previous instruction.
 
Old 01-17-2005, 06:46 PM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
cd to /etc in the /mnt directory folder that's the partition of your system, e.g., /mnt/hda1/etc/
 
Old 01-17-2005, 08:45 PM   #9
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you very much for your help, I will try this at the lunch and let you know at this evening.
 
Old 01-22-2005, 07:55 PM   #10
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
I'm sorry for late reply, when I use the command that you provide, I could not see the partition of linux redhat. But I could see the partition of my windows 2000 server and the CDROM drive.

Then I decide to reinstall windows and linux again, because i have to study it in a strictly schedule. During the time that I install linux redhat, it ask me the install type (personal, workstation, server or custom) then I choose custome. When the dialog show me the component that I need to select or remove, then i did not make any change because i think it is the default setting then I go ahead. But after I install linux and start it, it did not guide me to the login screen interface. I have to login in the command line. I'm sure that I did not select any interface component (kde, gnome or x windows system interface) during the time that I install. Now I could access to the CDROM and find a lot of RPMS on it but I don't know which RPM that I should be install to have the interface to work with. Now I'm on the prgress of reading "Beginning RedHat Linux 9.0".

Do you have any command or suggestion???
 
Old 01-24-2005, 10:44 AM   #11
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 47
yes, my suggestion is to dump Redhat and use something else, preferably Arch linux. it's very easy and you will not likely have those problems.

if it were me in your situation and i had to use RH, i would install a console browser like lynx or links from the CD, and then download the other rpms i needed from somewhere on the internet to make sure i was getting recent versions. i don't know what is installed by default in a custom install, however, so i can't comment on what you need and what you don't. i'd assume some sort of base system was installed, but as far as X, gui, apps, etc. it's impossible to say. otherwise, as a last resort i guess you could just reinstall and make sure everything you wanted was checked, or select personal or workstation so it would most likely install at least a gui and a few apps. it sounds like a nightmare to me compared to much easier ways to do it with other distros, even including a base debian install and then apt-getting what you need.

redhat 9 is no longer even supported i believe, and is fairly outdated compared to more recent distributions. aside from arch (the easiest linux, in my experience) ubuntu and maybe yoper are also possibly good choices. slackware is a good choice if you have a lot of time and want to download and configure everything yourself. i would stay away from the latest mandrake, as it seems to be getting more bloated and more problems as the releases progress, same with fedora, but the advantage is that those would probably install and pre-configure a lot of stuff for you, and there are large communities to help. i have tried most of the major distros, and a lot of the smaller ones, and i have found arch linux to be the best for ease of use, speed, and helpful community. but it's up to you, gl with whatever you choose. sorry i couldn't help you out more.


Last edited by synaptical; 01-24-2005 at 10:46 AM.
 
Old 01-25-2005, 10:57 AM   #12
012633023
LQ Newbie
 
Registered: Nov 2004
Location: Cambodia
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you very much for your help. I will try to find the right RPMS that could be install GUI for red hat linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SonicVibes Sound card not working in Slackware 10.1.0 Linux 2.6.10 GCC 3.4.3 sherman22 Linux - Hardware 5 03-05-2005 06:52 PM
Can't configure my sound card! fahdaziz Linux - Hardware 2 03-18-2004 10:17 PM
can't configure sound card in Red Hat Linux 8.0 Help Me!! manjula_rajan Linux - Hardware 1 03-17-2004 02:52 PM
The cheapest sound card you got working with linux.. LinuxBAH Linux - Hardware 1 01-21-2004 11:42 AM
Need help getting Philips AcousticEdge 5.1 sound card working in linux dissolved soul Linux - Hardware 4 09-02-2003 09:40 AM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration