LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2005, 09:26 PM   #1
nathanfrenk
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
keyboard and desktop manager problems


Hi! I'm completely new to linux, and I have some issues, so, if you could help me, I would really appreciate it...
Firstly, I've installed Debian and the boot takes me directly to the desktop manager (where I can choose between Gnome and KDE). How can I change it so it doesn't start the Xserver automatically, only when i choose so?
Secondly, I speak Portuguese and use an international keyboard (standard - 104 keys), while my Debian system was installed in English... However, while both in Gnome and KDE, I can't write, for example "ç" and " ã" . While in Windows that could be solved by setting the keyboard language to portuguese and its layout to international, here I just can't do that, because the brazilian layouts are not the ones my keyboard has and I can find no option to change the language of the keyboard (even changing the core language of KDE, for example, didn't work). However, the keyboard works perfectly outside the windows managers (in the black screen of the "real" terminals, not the ones I can open through the windows manager such as "Gnome terminal".

Thanks a lot
Nathan
 
Old 09-22-2005, 10:07 PM   #2
fincher69
Member
 
Registered: Jan 2005
Location: Tallahassee, FL
Distribution: Kubuntu 13.04
Posts: 69

Rep: Reputation: 15
not sure about the keyboard issue, but if you edit /etc/inittab you should see a line that says

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

and if you change that to

id:3:initdefault:

that should boot you to command line instead of graphical.
 
Old 09-23-2005, 12:16 AM   #3
mcmillan
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 489

Rep: Reputation: 30
For the keyboard in Gnome there's probably a listing in the menu for setting keyboard preferences. In ubuntu it's system>preferences>keyboard, I think it was slightly different when I used gnome with Mandriva, so it could be different for you but it would be something similar to that most likely. From there there's a tab for layout, which lets you add different keyboard layouts and set a default.

I don't know enough about KDE to point you towards something specific.
 
Old 09-23-2005, 08:45 AM   #4
nathanfrenk
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for answering!
I'll try the init configuratio, but I've tried the keyboard configuration tools of both Gnome and KDE and they only show me layout options, but that's not enough, since my keyboard does have the international, 104 keys layout listed, it's something to do with the language configuration, I'd guess (as I've explained by what I did in Windows).

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using window manager or desktop... henrikanttonen Debian 4 04-25-2005 03:09 PM
Keyboard shortcut manager/tool? 3.14159 Linux - Software 1 12-16-2004 04:55 AM
problems running xhost with no windows or desktop manager iagranat Linux - Newbie 0 10-25-2004 01:58 PM
change the desktop manager. kmistry Linux - General 2 09-29-2002 11:47 AM
debian 3.0 desktop manager [cacheflow] Linux - Distributions 0 08-29-2002 04:30 PM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration