LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-20-2008, 01:40 AM   #1
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Rep: Reputation: 0
kernel update


hi everyone,im using fedora 9 ,
im trying to update my kernel via yum update, but after the downloading process and the package installing, the yum update holds on without any error message... which is a bit a PITA just if im doing ctrl-c i get the message about a script error.

thats what im doing
>telinit 3
>yum update

how to do a kernel update without yum update?
and how i can remove the packages i downloaded via yum update?

sorry im a newbie

thx for help
greetz
ditus
 
Old 06-20-2008, 02:27 AM   #2
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
First do a:

Quote:
yum update yum
If there is a bug in yum that is your best chance of fixing it.

Then instead of a general update try a specific update:

Quote:
yum update kernel
You do realize you need to be root to do this?
 
Old 06-20-2008, 10:59 AM   #3
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
thx for your reply.

but still the same, yum is holding on after...

...
/usr/LIB64/LiBNASH.so.6.0.52 (nashAGetPathBySpec+0x73) [blabla]
/sbin/nash [blabla]
/sbin/nash [blabla]
/sbin/nash [blabla]
/lib64/libc.so.6(__libc_start_main+0xfa) [blabla]
/sbin/nash [0x404509]

and here it stops.

if im breaking the process (by pressing ctrl+c)... im getting the error

error:%post(kernel-2.6.25.6-55.fc9.x86_64) Scriplet failed, signal 2

installed: kernel.x86_64 0:2.6.25.6-55.fc9
complette!

but the kernel isnt updated.


thanks for help

greetz
ditus
 
Old 06-20-2008, 01:32 PM   #4
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
You do know that you have to reboot before a kernel update takes effect?

Cut and paste(back here) exactly what you are doing, becuase what you are posting should not be coming from a yum update kernel.
 
Old 06-20-2008, 02:25 PM   #5
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
ok that i have done.

1. i reinstalled fedora
2. i was login as root
3. yum update yum
4. yum update kernel
5. bang (error)
6. reboot
7. no effect
8. yum install kernel-headers
9. yum install kernel-devel
10. i done some entries in the bootloader menu.lst

so now im on this state at the moment >

menu.lst
Code:
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,6)
#          kernel /boot/vmlinuz-version ro root=/dev/sda7
#          initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,6)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25-14.fc9.x86_64)
	root (hd0,6)
	kernel /boot/vmlinuz-2.6.25-14.fc9.x86_64 ro root=UUID=e3c205fa-7c26-4ebf-b3df-7a31c10fe02d
	initrd /boot/initrd-2.6.25-14.fc9.x86_64.img
title Fedora-base (2.6.25.6-55.fc9.x86_64)
	root (hd0,6)
#	kernel /boot/vmlinuz-2.6.25.6-55.fc9.x86_64 ro root=/dev/sda
	kernel /boot/vmlinuz-2.6.25.6-55.fc9.x86_64 ro root=/dev/sda7

title Other
	rootnoverify (hd0,0)
	chainloader +1
but i get this error message yet after i try to boot with the new kernel ->

VFS:Cannot open root device
any partitions are displayed...
and this -> kernel panic - not syncing:VFS:unable to mount root fs on unknown-block(0,0)

its a bit a PITA

i think everything depends on that error by installing the new kernel.

Last edited by ditus; 06-20-2008 at 02:35 PM.
 
Old 06-20-2008, 02:31 PM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
If you do not post back exactly what you did and the exact error nobody is going to be able to help you. Here is an example of what we need:

Quote:
[root@localhost ~]# yum update kernel
Loading "protectbase" plugin
Loading "protect-packages" plugin
Loading "priorities" plugin
Loading "skip-broken" plugin
updates-source 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 740 kB 00:01
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 258 kB 00:02
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
primary.sqlite.bz2 100% |=========================| 3.8 MB 00:06
freshrpms 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 106 kB 00:00
0 packages excluded due to repository protections
Setting up Update Process
Could not find update match for kernel
No Packages marked for Update
[root@localhost ~]#
Notice that the command prompt is included on BOTH ends so we know we are seeing the entire transaction.
 
Old 06-20-2008, 03:15 PM   #7
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
thanks for helping...

so here is what im doing including the error message >

Code:
[root@localhost ~]# yum update yum
Geladene Plugins: refresh-packagekit
fedora                                                   | 2.4 kB     00:00    
primary.sqlite.bz2                                       | 7.6 MB     00:29     
updates                                                  | 2.3 kB     00:00    
primary.sqlite.bz2                                       | 1.7 MB     00:06     
Einrichten des Aktualisierungsprozess
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket yum.noarch 0:3.2.16-2.fc9 gesetzt um aktualisiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

=============================================================================
 Paket                   Arch       Version          Repository        Größe
=============================================================================
Aktualisieren:
 yum                     noarch     3.2.16-2.fc9     updates           705 k

Transaktionszusammenfassung
=============================================================================
Installieren        0 Pakete(e)         
Aktualisieren       1 Pakete(e)         
Enfernen          0 Paket(e)         

Gesamte Downloadgröße: 705 k
Ist dies richtig? [j/N] :j
Lade Pakete herunter:
(1/1): yum-3.2.16-2.fc9.noarch.rpm                       | 705 kB     00:02     
Führe rpm_check_debug durch
Führe Verarbeitungsstest durch
Verarbeitungstest beendet
Transaktionstest erfolgreich
Führe Verarbeitung durch
  Aktualisie: yum                          ######################### [1/2] 
  Aufräumen : yum                          ######################### [2/2] 

Aktualisiert: yum.noarch 0:3.2.16-2.fc9
Komplett!
[root@localhost ~]# yum update kernel
Geladene Plugins: refresh-packagekit
Einrichten des Aktualisierungsprozess
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket kernel.x86_64 0:2.6.25.6-55.fc9 gesetzt um installiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

=============================================================================
 Paket                   Arch       Version          Repository        Grösse
=============================================================================
Installieren:
 kernel                  x86_64     2.6.25.6-55.fc9  updates            18 M

Transaktionszusammenfassung
=============================================================================
Installieren          1 Pakete(e)         
Aktualisieren       0 Pakete(e)         
Enfernen               0 Paket(e)         

Gesamte Downloadgrösse: 18 M
Ist dies in Ordnung? [j/N] :j
Lade Pakete herunter:
(1/1): kernel-2.6.25.6-55.fc9.x86_64.rpm                 |  18 MB     01:00     
Führe rpm_check_debug durch
Führe Verarbeitungsstest durch
Verarbeitungstest beendet
Verarbeitungstest erfolgreich
Führe Verarbeitung durch
  Installieren   : kernel                                            [1/1] 
nash received SIGSEGV!  Backtrace (21):
/sbin/nash[0x40d093]
/lib64/libc.so.6[0x7f0ec338d2a0]
/lib64/libc.so.6(strncpy+0x11)[0x7f0ec33dc201]
/usr/lib64/libnash.so.6.0.52(nashDmDevGetType+0x96)[0x627bbe]
/usr/lib64/libnash.so.6.0.52[0x629abc]
/usr/lib64/libnash.so.6.0.52[0x629b84]
/usr/lib64/libnash.so.6.0.52[0x629d23]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_process_bdev+0x95)[0x628a44]
/usr/lib64/libnash.so.6.0.52[0x628cfb]
/usr/lib64/libnash.so.6.0.52[0x628e0d]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_add_sysfs_dir+0x3e)[0x628c76]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_populate_from_sysfs+0x1c)[0x628ea5]
/usr/lib64/libnash.so.6.0.52(nashBdevIterNewPoll+0x7d)[0x62462a]
/usr/lib64/libnash.so.6.0.52[0x624989]
/usr/lib64/libnash.so.6.0.52(nashFindFsByUUID+0x24)[0x624b24]
/usr/lib64/libnash.so.6.0.52(nashAGetPathBySpec+0x73)[0x624c60]
/sbin/nash[0x4088a1]
/sbin/nash[0x40cf49]
/sbin/nash[0x40d576]
/lib64/libc.so.6(__libc_start_main+0xfa)[0x7f0ec337932a]
/sbin/nash[0x404509]
^Cerror: %post(kernel-2.6.25.6-55.fc9.x86_64) scriptlet failed, signal 2

Installiert: kernel.x86_64 0:2.6.25.6-55.fc9
Komplett!
[root@localhost ~]#
greetz
ditus
 
Old 06-20-2008, 04:30 PM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Ok, this seems to be a conflict with packagekit running while yum is running. Under Sessions/Startup Programs there is an entry called "PackageKit Update Applet". You should be able to shut it off there. You MAY have to reboot in order for the shut off to take effect.
 
Old 06-20-2008, 05:11 PM   #9
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
its not working that way, still the same

Code:
[root@localhost ~]# 
[root@localhost ~]# yum update kernel
Geladene Plugins: refresh-packagekit
Einrichten des Aktualisierungsprozess
Löse Abhängigkeiten auf
--> Führe Transaktionsprüfung aus
---> Paket kernel.x86_64 0:2.6.25.6-55.fc9 gesetzt um installiert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

=============================================================================
 Paket                   Arch       Version          Repository        Grösse
=============================================================================
Installieren:
 kernel                  x86_64     2.6.25.6-55.fc9  updates            18 M

Transaktionszusammenfassung
=============================================================================
Installieren          1 Pakete(e)         
Aktualisieren       0 Pakete(e)         
Enfernen               0 Paket(e)         

Gesamte Downloadgrösse: 18 M
Ist dies in Ordnung? [j/N] :j
Lade Pakete herunter:
(1/1): kernel-2.6.25.6-55.fc9.x86_64.rpm                 |  18 MB     01:03     
Führe rpm_check_debug durch
Führe Verarbeitungsstest durch
Verarbeitungstest beendet
Verarbeitungstest erfolgreich
Führe Verarbeitung durch
  Installieren   : kernel                                            [1/1] 
nash received SIGSEGV!  Backtrace (21):
/sbin/nash[0x40d093]
/lib64/libc.so.6[0x3477e322a0]
/lib64/libc.so.6(strncpy+0x11)[0x3477e81201]
/usr/lib64/libnash.so.6.0.52(nashDmDevGetType+0x96)[0x347ae0fbbe]
/usr/lib64/libnash.so.6.0.52[0x347ae11abc]
/usr/lib64/libnash.so.6.0.52[0x347ae11b84]
/usr/lib64/libnash.so.6.0.52[0x347ae11d23]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_process_bdev+0x95)[0x347ae10a44]
/usr/lib64/libnash.so.6.0.52[0x347ae10cfb]
/usr/lib64/libnash.so.6.0.52[0x347ae10e0d]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_add_sysfs_dir+0x3e)[0x347ae10c76]
/usr/lib64/libnash.so.6.0.52(nash_dev_tree_populate_from_sysfs+0x1c)[0x347ae10ea5]
/usr/lib64/libnash.so.6.0.52(nashBdevIterNewPoll+0x7d)[0x347ae0c62a]
/usr/lib64/libnash.so.6.0.52[0x347ae0c989]
/usr/lib64/libnash.so.6.0.52(nashFindFsByUUID+0x24)[0x347ae0cb24]
/usr/lib64/libnash.so.6.0.52(nashAGetPathBySpec+0x73)[0x347ae0cc60]
/sbin/nash[0x4088a1]
/sbin/nash[0x40cf49]
/sbin/nash[0x40d576]
/lib64/libc.so.6(__libc_start_main+0xfa)[0x3477e1e32a]
/sbin/nash[0x404509]
^Cerror: %post(kernel-2.6.25.6-55.fc9.x86_64) scriptlet failed, signal 2

Installiert: kernel.x86_64 0:2.6.25.6-55.fc9
Komplett!
[root@localhost ~]#
 
Old 06-20-2008, 05:23 PM   #10
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
is it possible,i had first vista on the pc running, i was using the vista partition reducing tool to get some space free for a empty partition,
could be that be the reason for?

is it normal that the root device in the menu.lst file looks like this?

Code:
title Fedora (2.6.25-14.fc9.x86_64)
	root (hd0,6)
	kernel /boot/vmlinuz-2.6.25-14.fc9.x86_64 ro root=UUID=6c80cb34-779b-497d-8bff-034287632e04 rhgb quiet
	initrd /boot/initrd-2.6.25-14.fc9.x86_64.img
if you think that could be the reason, im going to format the whole hd

or i read something about a corrupt ram, that could do some problems. but the rams seems to be ok on my machine.
 
Old 06-20-2008, 06:00 PM   #11
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
You can test the ram with memtest86+ ( just google it). It is extremely unlikely that the only time there would be a ram issue is while using yum.

You are still showing that you are using packagekit.

Unless you are out of space on the /boot/ I doubt using vista to shuffle partitions for space would be the issue (assuming you mean BEFORE you installed linux).
 
Old 06-20-2008, 06:56 PM   #12
ditus
LQ Newbie
 
Registered: Jun 2008
Posts: 12

Original Poster
Rep: Reputation: 0
yeah thx 1000 times, it works now.

i needed to remove the whole packagekit function not just the checkbox.

thx for your time
best wishes
ditus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
update -u Did Not Update Kernel Packages cmnorton Red Hat 1 03-15-2008 09:09 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 10:27 AM
YaST Online Update(YOU) Kernel Update? batorma Linux - Newbie 9 10-30-2005 03:17 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 11:01 AM
KDE update and RH 9.0 Kernel update massacre Linux - Newbie 1 02-02-2004 06:13 PM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration