LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-20-2009, 03:26 AM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
kernel panic - not syncing : Attepted to kill init !!


Hi all...

I am getting following error when i try to boot fedora 9, I am getting this error even in single user mode

Code:
init: Error parsing configuraion: Input/Output error
kernel panic - not syncing : Attepted to kill init !!
Actually I was trying to create a new logical volume using lvcreate command in single user mode, after lvcreate i executed following

mkfs -t ext3 /dev/mapper/VolGroup00/lvo10
mount -t ext3 /dev/volgroup00/lvo10 /home

reboot

after this whenever i am trying to boot fedora i am getting following error....
 
Old 11-20-2009, 03:44 AM   #2
JohnGraham
Member
 
Registered: Oct 2009
Posts: 467

Rep: Reputation: 139Reputation: 139
Quote:
Originally Posted by vinaytp View Post
Hi all...

I am getting following error when i try to boot fedora 9, I am getting this error even in single user mode

Code:
init: Error parsing configuraion: Input/Output error
kernel panic - not syncing : Attepted to kill init !!
Actually I was trying to create a new logical volume using lvcreate command in single user mode, after lvcreate i executed following

mkfs -t ext3 /dev/mapper/VolGroup00/lvo10
mount -t ext3 /dev/volgroup00/lvo10 /home

reboot

after this whenever i am trying to boot fedora i am getting following error....
It sounds like init cannot read the inittab file, at least not correctly - maybe it references something under /home/? Sounds unlikely, though...

Anyway, first thing to do is get a shell running on your system. I assume you have grub as a bootloader - if not, you need to find out how to pass the option "init=/bin/bash" (or /bin/csh or whatever you normally use) to the kernel at boot-time. With grub:

1) At the bootloader menu, select the kernel you usually boot from and press 'e'

2) Go to the line that starts with 'kernel' and press 'e'

3) This should allow you to append the argument "init=/bin/whateversh" to the kernel boot arguments. Press enter to confirm, then 'b' to use that configuration to boot.

You should now have a workable shell (just about). Could you use this to get and post the contents of /etc/inittab here?

John G
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/sbin/init: Kernel panic - not syncing: Attempted to kill init! jalejo08 Linux - Kernel 7 07-02-2009 01:16 PM
kernel panic - not syncing: Attempted to kill init! Stoneperson Linux - Kernel 2 06-29-2009 06:50 PM
Kernel panic - not syncing : Attempted to kill init! rahman.athiq Linux - General 1 07-11-2007 05:13 AM
Kernel Panic - not syncing: Attempted to kill init! teluguswan Red Hat 0 12-20-2006 03:23 AM
kernel panic - no syncing: Attempted to kill init majara Linux - General 3 02-06-2006 01:01 AM


All times are GMT -5. The time now is 02:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration