LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2006, 10:47 PM   #1
CamelWide
LQ Newbie
 
Registered: Aug 2006
Posts: 7

Rep: Reputation: 0
Kernel Panic - Not Syncing


Hey there! Hope you can help! ok, I installed Knoppix 4.0 on a new HD, made primary partitions for the installation as required, the swap partition as well, now I dont know if the swap should be primary or not, anyway... The system let me install the Knoppix4.0 and everything was fine, but when I take out the live cd and try to run the HD with the Knoppix I get this thing:

Kernel Panic - Not Syncing VFS Unable to mount root fs on unknown - block (3,66)

Ive been reading some information about this, but I just dont get it, they talk about changing this in LILO and changing that in God knows what, Im a newbie and I have no idea what is that, Ive been looking for those terms in the livecd and cannot find em, I read about file systems and kernel properties but I just cant make it work, well I really hope you can help me out on this one, thanks in advance.

Is there a way to fix this using the terminal?
 
Old 10-23-2006, 01:32 AM   #2
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
The error your getting usually means that your lilo.conf or grub.conf isn't written correctly. Post your lilo or grub conf file and your paritioning scheme and we'll see if we can find the error.
 
Old 06-10-2009, 05:27 AM   #3
mrhooters
LQ Newbie
 
Registered: Jun 2009
Location: Manila, Philippines
Distribution: Gentoo, Fedora, Debian, Centos
Posts: 3

Rep: Reputation: 0
Smile Got same problem below are the details of my lilo conf

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

lilo.conf

boot=/dev/sda
prompt
timeout=10
default=gentoo
image=/boot/kernel
label=Gentoo
read-only
root=/dev/sda3


i'm using reiserfs as my sda3 (root)

Hope any masters can help me out in finding a solution to my problem.

Many Thanks!

Last edited by mrhooters; 06-10-2009 at 05:34 AM. Reason: added some words
 
Old 06-10-2009, 06:17 AM   #4
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
It often happens switching kernel, from an *-huge-* kernel to the *-generic-* one: I solved creating the initrd.gz and adding it to lilo.conf the initrd.gz, here's a README that might help you:

http://slackware.osuosl.org/slackwar.../README.initrd

It's my lilo.conf:

Code:
# Linux bootable partition config begins
  image = /boot/vmlinuz-generic-smp-2.6.29.4-smp
  initrd = /boot/initrd.gz
  root = /dev/sda4
  label = Linux
  read-only
Regards...
 
Old 06-10-2009, 07:31 AM   #5
mrhooters
LQ Newbie
 
Registered: Jun 2009
Location: Manila, Philippines
Distribution: Gentoo, Fedora, Debian, Centos
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by metrofox View Post
It often happens switching kernel, from an *-huge-* kernel to the *-generic-* one: I solved creating the initrd.gz and adding it to lilo.conf the initrd.gz, here's a README that might help you:

http://slackware.osuosl.org/slackwar.../README.initrd

It's my lilo.conf:

Code:
# Linux bootable partition config begins
  image = /boot/vmlinuz-generic-smp-2.6.29.4-smp
  initrd = /boot/initrd.gz
  root = /dev/sda4
  label = Linux
  read-only
Regards...
thanks for the reply and really appreciates it.
By the way, i might include this: i'm installing gentoo r9 on Dell 1950 server. This might help in solving my problem ^^
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic-not syncing PowersurgeX Linux - Newbie 5 09-14-2006 03:27 PM
Kernel Panic (!) - not syncing Andknig Linux - General 2 09-14-2006 01:15 PM
kernel panic - not syncing gentoo_user Linux - Hardware 1 06-01-2006 09:48 PM
Kernel panic-not syncing MRDucks Mandriva 2 11-04-2005 07:57 PM
Kernel panic - not syncing darkarcon2015 Slackware 7 11-01-2005 10:02 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration