LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-03-2004, 06:53 PM   #1
PowersurgeX
LQ Newbie
 
Registered: Dec 2004
Distribution: Gentoo.
Posts: 7

Rep: Reputation: 0
Kernel panic-not syncing



so I have installed XP and Debian Sarge on my laptop using Grub as the bootloader. Sarge booted fine with 2.4. something or the other kernel, but I decided to be adventurous and try updating to a new kernel.
Long story short, new kernel won't load. Here's some specifics that I get upon boot:

hda: bad access: block=blah, count=8
end_request: I/O error, dev hda, sector blah blah
ReiserFS: hda2 warning sh-2006: read_super_block: bread failed (dev hda2, block 2, size 4096)
hda: bad access: block=blah, count =8
end_request: I/O error, dev hda, sector blah blah
ReiserFS: hda2 warning sh-2006: read_super_block: bread failed (dev hda2, block 2, size 4096)
hda: bad access: block=blah, count =2
end_request: I/O error, dev hda, sector blah blah
EXT3-fs: unable to read superblock
hda: bad access: block=blah, count =2
end_request: I/O error, dev hda, sector blah blah
EXT2-fs: unable to read superblock
hda: bad access: block=blah, count =1
end_request: I/O error, dev hda, sector blah blah
FAT: unable to read boot sector
VFS: Cannot open root device "hda2" or unknown-block(3,2)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)

Here's the grub edit details:

root (hd0,1)
kernel /boot/vmlinuz-2.6.9 root=/dev/hda2 ro
savedefault
boot


This is essentially the same as my 2.4.7 details except that my 2.4.7 has an initrd line.

Do I need to do initrd stuff for my 2.6.9 as well? If so, how do I do that?

Edit... There are actually numbers where the blah blah's are, i'm just to lazy to type them.

Last edited by PowersurgeX; 12-03-2004 at 10:16 PM.
 
Old 12-04-2004, 02:26 AM   #2
kushalshah
LQ Newbie
 
Registered: Jun 2004
Location: chennai, india
Distribution: slackware
Posts: 7

Rep: Reputation: 0
cd /usr/src/linux-2.*.*
make xconfig
select support for the filesystem type of the '/' partition and all other partitions.
i.e. if your '/' partition is reiserfs, then select support for reiserfs... and so on...

then recompile the kernel, copy the bzImage to /boot and reboot......

this should work.....

sometimes this error also happens because u included those modules in your xonfig that were not compatible with your hardware..... so check your kernel configuration again and remove all unnecessary modules......... and recompile.......

this should help..

bye,
kushal.
 
Old 12-14-2004, 07:40 AM   #3
skottieb
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
2.6.9 dosent have IDE enabled by default, check that IDE support is enabled unter drivers and the relevant selections (IDE disk, Generic IDE chipset, ...) are built into the kernel, unless you use a SCSI based machine, which i say, do the obvious
 
Old 12-24-2004, 06:36 PM   #4
catalyst82
LQ Newbie
 
Registered: Dec 2004
Location: Poland
Distribution: slackware
Posts: 1

Rep: Reputation: 0
Hi there,

I've had the same problem ... Just make sure to compile into the kernel (not as a module) Device Drivers -> Block devices -> RAM disk support -> Initial RAM disk (initrd) support if you intend to use initrd...

pozdrawiam
catalyst82
 
Old 09-14-2006, 01:18 PM   #5
nisha081
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
how do i compile the kernel?
u told about device driver thing na,, for that

nisha
 
Old 09-14-2006, 03:27 PM   #6
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 14.1
Posts: 1,141

Rep: Reputation: 55
Quote:
Originally Posted by kushalshah
sometimes this error also happens because u included those modules in your xonfig that were not compatible with your hardware..... so check your kernel configuration again and remove all unnecessary modules......... and recompile.......
Well that's not quite right. The kernel doesn't stop booting if you have modules for non-existent hardware. If what you are saying is right then most default kernels that come with different linux distro would not even boot because they contain lot of **unneccessary** modules for your particular system.

However, removing unneccesary modules does help make the system leaner and the compile faster. Besides why do you need modules you don't have the hardware for?

Basically the OP forgot to include IDE support or file system support or even sata drivers (if the hard drive is sata). The best bet is to compile IDE support and file system support in the kernel (read not as module).

Initrd is only needed if you have any of the above compiled as modules.

Tux,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic (!) - not syncing Andknig Linux - General 2 09-14-2006 01:15 PM
Kernel panic - not syncing carboncopy Slackware 9 12-13-2005 06:53 AM
Kernel Panic - not syncing: VFS slack_prad Slackware 8 12-05-2005 03:47 PM
Kernel panic-not syncing MRDucks Mandriva 2 11-04-2005 07:57 PM
Kernel panic - not syncing darkarcon2015 Slackware 7 11-01-2005 10:02 PM


All times are GMT -5. The time now is 06:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration