LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-02-2003, 10:32 AM   #1
E-Rick
LQ Newbie
 
Registered: Aug 2003
Location: Belgium
Distribution: Red Hat Linux 8
Posts: 17

Rep: Reputation: 0
Kernel panic: no init found


Hi,

I have a disk with several partitions (two with Windows XP, one for data only, and one for Linux Red Hat 8). I don't want Linux to mess up my MBR, so I executed grub to install on the partition where Linux is; /dev/hda7. I get errors however when I boot to my Linux partition with grub:

the parameters I give to grub are:

root (hd0,6)
kernel /boot/vmlinuz
initrd /boot/initrd.img
boot

all this works ok, until I get the errors:

mounting root file system
EXT2-fs: unable to read superblock
mount: error 22 mounting ext2
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
kernel panic: no init found

I tried to put init=/bin/bash, init=/sbin/init, and init=bin/sh on the kernel command, without any success. I used Red Hat 2.4.18-14.

Now, when I boot from my startup floppy disk, everything works smoothly! So I presume it's not really a problem with the filesystem, but with the configuration. Does anyone have an idea?

Thanks!

E-Rick
 
Old 08-02-2003, 10:37 AM   #2
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
Install it on the MBR and make windows bootable. The problem here is that it cant find your init. ITs definately a problem with your bootloader. Read on:
http://www.redhat.com/docs/manuals/l...ootloader.html
http://www.denniswarner.net/lfp/configuring_grub.html
 
Old 08-02-2003, 01:23 PM   #3
TheWalkingDead
LQ Newbie
 
Registered: Jul 2003
Location: SoCal
Distribution: RedHat 7.3
Posts: 15

Rep: Reputation: 0
well i always use lilo because it's easier. first of all, lilo will not screw up your MBR. lilo is a better bootloader than windows uses. hell NTloader doesn't even recognize linux! i would suggest putting lilo in your MBR. if you have problems, you can always fdisk mbr and lilo is gone. its that simple.
but since you used grub, lets see what we can do. i'm no expert on grub but if you look at your file, you said you installed linux on /dev/hda7 yet you are telling grub root is on /dev/hd06??? so my guess is you are getting errors because grub is looking for root on /dev/hd06 when it's really on /dev/hda7.
also, if your system boots properly from your bootdisk, take a look at the config files on the bootdisk and see where it's telling the loader to look for root.

Last edited by TheWalkingDead; 08-02-2003 at 01:25 PM.
 
Old 08-02-2003, 01:56 PM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
hd0,6 is correct in grubs terms, grub starts counting at zero, so this would be correct for /dev/hda7
 
Old 08-03-2003, 05:39 PM   #5
E-Rick
LQ Newbie
 
Registered: Aug 2003
Location: Belgium
Distribution: Red Hat Linux 8
Posts: 17

Original Poster
Rep: Reputation: 0
Hi guys, thanks a lot for your help.

Ok about hd0,6: i also wanted to mention that it is actually pointing to /dev/hda7, but that's already done.

I looked at the boot files on the floppy disk, and they point to the same partition and files as I've put in grub.

I use BootMagic of PowerQuest, and I prefer to keep this one because it's so easy to add and delete boot partitions.

I don't want to install the boot on the mbr neither.

I will have a look at the proposed manuals tomorrow. If anyone else has an idea, please do not hesitate!

E-Rick
 
Old 08-05-2003, 09:08 AM   #6
E-Rick
LQ Newbie
 
Registered: Aug 2003
Location: Belgium
Distribution: Red Hat Linux 8
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, it works now. I just stopped trying doing it manually, and created the grub.conf file, which I customized as follows:

default=0
timeout=0
splashimage=(hd0,6) /boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.18-14)
root (hd0,6)
kernel /boot/vmlinuz-2.4.18-14 ro root=LABEL=/ hdd=ide-scsi
initrd /boot/initrd-2.4.18-14.img

Everything works now, and the MBR was not touched - all's done on the hda7 partition only.

E-Rick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic: No init found. Try passing init= option to kernel ridak Fedora 0 07-14-2004 08:23 PM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-19-2004 12:10 AM
Kernel Panic: No Init Found Try Passing Init=option To Kernel Bakame Mandriva 7 03-14-2004 03:37 PM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 11:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 04:38 AM


All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration