LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-01-2008, 09:11 AM   #1
tarunmadiraju
LQ Newbie
 
Registered: Aug 2008
Posts: 14

Rep: Reputation: 0
kernel panic:ioapic+timer not syncing


i hve 2 hdd..on the primary one i installed win xp sp2... and on the second hdd i tried installin ubuntu,rhel,fedora...all of dem displayed the same error..i m really new to this operating system and i need immediate assistance... wen i disable d apic thru bios i m able to install linux n run it but then my win os is not booting...inorder to use win xp i need to enable apic options from bios but then linux doesnt boot........i need immediate assistance...thnk u vry much
 
Old 08-01-2008, 02:11 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,334

Rep: Reputation: 144Reputation: 144
Which linux distro are you running? There is a simple solution to your problem in all likelihood. You should edit your linux bootloader configuration file, usually /boot/grub/menu.lst or if you are using fedora/rh, /boot/grub/grub.conf, to add these kernel parameters:

noapic nolapic acpi=off

After doing that, you can turn on acpi/apic in your bios setup and linux will ignore it and boot as if acpi was disabled. Post your distro and either your menu.lst or grub.conf file here and I'll show you exactly what edits to make.
 
Old 08-04-2008, 03:01 AM   #3
tarunmadiraju
LQ Newbie
 
Registered: Aug 2008
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kilgoretrout View Post
Which linux distro are you running? There is a simple solution to your problem in all likelihood. You should edit your linux bootloader configuration file, usually /boot/grub/menu.lst or if you are using fedora/rh, /boot/grub/grub.conf, to add these kernel parameters:

noapic nolapic acpi=off

After doing that, you can turn on acpi/apic in your bios setup and linux will ignore it and boot as if acpi was disabled. Post your distro and either your menu.lst or grub.conf file here and I'll show you exactly what edits to make.
i installed fedora 9(sulphur) by first disabling the acpi apic option(under power) of bios...then i opened the /boot/grub/grub.conf and tried placing "noapic nolapic acpi=off"(of course w/o quotes} at various loc in d file...but could find d solution... i tried placing the line 1.in the begining 2.hidden menu and tittle and 3.at the end ....can u actually temme where i should place that data... in that particular file..
one more thing is it the same loc(i mean above/below) in the boot loader file for other linux os as well...

i ll post the boot loader file soon...


thnk u vry much for taking interest in my problem and providing me a solution...

Last edited by tarunmadiraju; 08-04-2008 at 05:45 AM.
 
Old 08-04-2008, 06:07 AM   #4
tarunmadiraju
LQ Newbie
 
Registered: Aug 2008
Posts: 14

Original Poster
Rep: Reputation: 0
grub.conf file

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/sda8
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25-14.fc9.i686)
root (hd0,1)
kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=819d769d-b349-4f11-937b-ef781ed7f200 rhgb quiet
initrd /initrd-2.6.25-14.fc9.i686.img
title Other
rootnoverify (hd0,4)
chainloader +1

------------------------------------------------------------------------
also temme where to place it if i install ubuntu(8.04)...thnk u vry much...awaitin ur reply
 
Old 08-04-2008, 04:13 PM   #5
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,334

Rep: Reputation: 144Reputation: 144
You insert those options on the "kernel" line between rhgb and quiet like so:

kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=819d769d-b349-4f11-937b-ef781ed7f20 rhgb noapic nolapic acpi=off quiet

It's a little confusing because the "kernel" line is actually all one line but the formatting here doesn't allow that to be shown as one line.
 
Old 08-05-2008, 01:10 PM   #6
tarunmadiraju
LQ Newbie
 
Registered: Aug 2008
Posts: 14

Original Poster
Rep: Reputation: 0
thnk u vry much...i ll try that one n let u knw if that worked thnks again
 
Old 08-06-2008, 01:37 PM   #7
tarunmadiraju
LQ Newbie
 
Registered: Aug 2008
Posts: 14

Original Poster
Rep: Reputation: 0
thanks

thnk u vry much...it really worked...thnk u...
cn u also temme where those noapic... have to placed in ubuntu as well...any other tips...i am new to linux...any good e book for it
 
Old 08-07-2008, 01:21 PM   #8
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,334

Rep: Reputation: 144Reputation: 144
Can't predict how your system will react to ubuntu; you would have to try it and see. It will all depend on the kernel used by ubuntu. If you do need to disable apic/acpi in ubuntu, you would edit the /boot/grub/menu.lst file. Insert those options in the kernel line separated by one space from the other kernel options on that line.
 
Old 09-02-2008, 10:37 AM   #9
malefisocu
LQ Newbie
 
Registered: Sep 2008
Posts: 1

Rep: Reputation: 0
Hi, I have same issue. I'm installing Ubuntu Server 8.04 on a new pc, Mother Asus m2n-mx se plus, amd sempron le 1200 am2, hd wd 160 Gb, 1gb ram kingston 667 mhz, and prior to any grub menu the error message appeared. What I did was enter setup and disabled acpci apic support under Power tab. That was enough for me to allow instalation. But I wonder if that means I will have further problems. Searching google for that error, every solution found was telling linux kernel noapic, not touching bios setup. Can anybody explain pros and cons of each alternative?
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing: IO-APIC + timer dosen't work! gamer4lyf3 Linux - Kernel 3 04-02-2008 12:19 PM
Kernel panic-not syncing PowersurgeX Linux - Newbie 5 09-14-2006 03:27 PM
kernel panic - not syncing gentoo_user Linux - Hardware 1 06-01-2006 09:48 PM
Kernel panic-not syncing MRDucks Mandriva 2 11-04-2005 07:57 PM
Kernel panic - not syncing darkarcon2015 Slackware 7 11-01-2005 10:02 PM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration