LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2008, 09:33 AM   #1
vvuiverine
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Rep: Reputation: 0
Kernel Panic: init not found


A live distro has been installed to my laptop. This is a triple boot configuration with Ubuntu, Windows XP, and Back TRack. The live distro, Back Track, is now booting but getting a kernel panic. The kernel panic is giving the error "no init found try passing init= option to kernel". Adding init=3 to kernel parameters does nothing.

sda configuration:
Code:
sda1 = WinXp (boots Grub on MBR)
sda2 = Back Track
sda3 = Ubuntu
sda4 = swap
I've tried the following:
adding init=3 to kernel parameters of menu.lst entry
adding and removing initrd = /boot/initrd.gz

Any other ideas would be great. As all fixes provided from google have been exhausted.

Thank you.
 
Old 08-05-2008, 09:40 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Can you boot into Ubuntu or Windows?

Which is the last OS installed, and did you install GRUB at that time? (We need to know which Linux "owns" GRUB.)

If you can boot into Ubuntu, find the correct GRUB config. file (/boot/grub/menu.lst).

For example, if GRUB was installed from Ubuntu, then the file will be in the Ubuntu partition. If you installed BackTrack last, and installed GRUB with it, the the correct file will be on the Backtrack partition.

When you find the right one, post the entry for Backtrack.

If you can't get into any Linux, you can do all of this from the Live CD.
 
Old 08-05-2008, 09:45 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
PS: What was "init=3" intended to do? (It sounds like it might control the runlevel)

The typical menu.lst entry will look something like this:
title Kubuntu
root (hd0,4)
kernel /boot/vmlinuz root=/dev/sda5
initrd /boot/initrd
boot

The first "root" statement tell GRUB where its files are ("(hd0,4)" is grubese for /dev/sda5)
The second "root" statement tells the kernel where "/" is. In this example, it's the same place
 
Old 08-05-2008, 10:24 AM   #4
vvuiverine
LQ Newbie
 
Registered: Jun 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks so much for your help guys. I figured it out though. initrd was compressed as initrd.gz. Just unzipped it and put it in /boot.

As for init=3. I've got no idea how that could be a fix. Several posts found through google have that as a successful fix.
 
Old 08-05-2008, 11:12 AM   #5
Berticus
Member
 
Registered: Jul 2005
Distribution: Arch
Posts: 159

Rep: Reputation: 31
for the kernel line, you don't need to write init=3, just a simple 3 will do:
Code:
title Back Track
root (hd0,0)
kernel /vmlinuz26 root=/dev/sda3 3
initrd /initrd
Of course changing the parameters as needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernal panic no init found try passing init option to kernel m2azer Linux - General 3 11-08-2007 02:51 PM
Kernel panic: No init found. Try passing init= option to kernel kryptobs2000 Linux - Software 1 09-08-2006 07:50 PM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-19-2004 12:10 AM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 11:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 04:38 AM


All times are GMT -5. The time now is 09:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration