LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-30-2004, 05:25 PM   #1
phoenixdbq
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Rep: Reputation: 0
Unhappy Kernel panic after dual-boot XP drive failed


I have a dual-boot system with 2 IDE HDDs. The primary drive contained a Windows XP OS and GRUB for the 2nd drive which contains RedHat Linux 8.

Problem: The primary drive failed. I replaced the drive and reinstalled XP on it.... XP works fine. I then installed Paragon Boot Mgr and set it up to give a choice for XP or Linux booting. When Linux is chosen, it goes through the boot process until it hits a Kernel panic and the system halts.

Here are the last few lines:

kmod: failed to exec /sbin/modprobe -s -k block-major-72, errno = 2
VFS: Cannot open root device "" or 48:05
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 48:05

I'm at a loss as to where to go from here. I know the Windows OS's like the back of my hand, but when it comes to Linux, I can install it and use it, but not troubleshoot it. The only thing that comes to mind is that the GRUB on the defective drive had a reference for "root=" that it passes to the boot process, and my Paragon Boot Mgr doesn't include this???

Any help would be greatly appreciated. This system is not mine, and I know the owner had a lot of data on the Linux drive... they've already had a total loss on the XP one

Thanks!
 
Old 01-30-2004, 05:33 PM   #2
thewizard20
Member
 
Registered: Sep 2003
Location: ny
Distribution: slackware 9.1
Posts: 73

Rep: Reputation: 15
Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Linux
read-only
for lilo this is the way it should look in the config for your boot manager im not sure. hope this helps
 
Old 01-30-2004, 05:35 PM   #3
Breezwell
Member
 
Registered: Apr 2001
Location: Chicago
Distribution: Gentoo 1.4
Posts: 214

Rep: Reputation: 30
phoenixdbq,

Can you boot straight off the Linux drive?
If you can, make Linux the primary and Windows the secondary. Install GRUB or LILO on the Linux drive and use it to boot either the Windows or Linux drive.

I dual boot in this way with Linux and WinXP with no problems at all. If decide to use GURB, I can post my configuration for you.
 
Old 01-30-2004, 05:43 PM   #4
phoenixdbq
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Unable to boot with Linux drive alone. In the original config, XP was primary master and Linux was primary slave. The system had XP and Linux was installed after.

No changes were made to the Linux drive... the XP drive simply failed outright... whatever MBR that drive had holds the key to what I need to do to fix it... Can I install GRUB and retain the data that is on the Linux drive???

Thanks!
 
Old 01-31-2004, 01:15 AM   #5
Breezwell
Member
 
Registered: Apr 2001
Location: Chicago
Distribution: Gentoo 1.4
Posts: 214

Rep: Reputation: 30
Here is what my grub.conf file looks like:

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

# Gentoo 1.4
title=Gentoo Linux 1.4
root(hd0,0)
kernel(hd0,0)/boot/bzImage root=/dev/hda3

# Windows XP
title=WinXP
root(hd1,0)
map(hd0) (hd1)
map(hd1) (hd0)
chainloader+1

The error message you are getting that states the following:

Please append a correct "root=" boot option

is basically telling you that the location of your kernel image canno't be found. In my case, the location of the boot image is on the third partition (hda3) of the first drive (hd0). Assuming the kernel image is correct and complete, you should be able to install GRUB and create the correct grub.conf file for your system to boot. Again, this is 'if' the kernel image is complete and correct.

You might want to try using a GRUB Floppy Image to try and boot the drive before attempting to install GRUB to the hard drive. GRUB allows you to pass options at boot time from an interactive prompt. You will need access to a system with GRUB installed to make the floppy image.

http://www.yo-linux.com/TUTORIALS/Li...dBootDisk.html

Hope this helps a little.
 
Old 02-02-2004, 02:22 AM   #6
phoenixdbq
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Well, I finally got ahold of the Red Hat install disks. I did an upgrade install and selected GRUB, but it wouldn't install the bootloader (said something about nothing to upgrade). I did get it to make a boot disk, which does work and boots the Linux system all the way into X.

What I can't figure out now is how to use that boot configuration from the floppy to get my dual boot with XP to work.

Also, I must have answered the question wrong when KUDZU wanted to update my mouse configuration, because the mouse is inop and it no longer asks if I want to configure the new mouse. Is there a way to force a new hardware detection (without the use of the mouse)

Thanks everyone for your help so far! I know these last items should be easy.
 
Old 02-04-2004, 02:37 PM   #7
sgtbob
Member
 
Registered: Jan 2004
Location: Kansas
Distribution: Windows 7, iMAC Lion 8.5, Ubuntu
Posts: 92

Rep: Reputation: 15
Phoenix - I'm a real newbie here also, but I recall reading somewhere that doing an 'install' as opposed to an 'upgrade' is a better install method.

I'm running RH 9 on a slower box, so I am still trying to learn about dual boot processes.... Can't settle on whether to use Redhat or Mandrake. I got started on Mandrake and became somewhat familiar with it, but my SIG is total RH so whachyagonnado!!!!!!

bob
 
Old 02-05-2004, 09:17 AM   #8
phoenixdbq
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Got it figured out. I booted to Linux from my boot floppy and then installed GRUB from the command line... like I thought easy, but very elusive when you're not familiar with the OS.

Also, the mouse problem was a simple fix. Had to switch to a console window with Ctrl-Alt-Esc. Once there, there is a simple command to force a redetect on the mouse.

I know I should be listing what the commands were, but I don't have them handy. I'll repost them when I have more time.

Thanks for all the replies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux bootup: kernel panic: pivot_root failed evansg Fedora 4 10-24-2007 10:56 AM
failed to install redhat 9 (kernel panic:attempt to kill init) omnia Linux - Hardware 1 06-13-2005 06:43 AM
failed to install redhat 9(kernel panic:attempt to kill init) omnia Linux - Hardware 5 06-08-2005 07:18 AM
Dual Boot XP/RH8 autoconfig failed Nimbus Linux - Newbie 2 12-15-2004 01:27 PM
HPT372 on mandrake 9.2 = kernel panic ( init failed ) micro_sucks Linux - Software 0 12-17-2003 10:45 PM


All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration